TODOPIC

FORO TÉCNICO => Telefonía, GPS y Microcontroladores => Mensaje iniciado por: KALLITOS en 28 de Abril de 2013, 18:09:09

Título: Problemas en recepción con SIM900
Publicado por: KALLITOS en 28 de Abril de 2013, 18:09:09
Hola muchachos, estoy haciendo unas pruebas con el MODULO SIM900 (http://www.ebay.com/itm/SIMCOM-SIM900-Quad-band-GSM-GPRS-Shield-Development-Board-for-Arduino-Iduino-/190722841911?pt=LH_DefaultDomain_0&hash=item2c67f79d37), lo que pasa es que el equipo ya trabaja bien, recibe y responde con información solicitada. El equipo trabaja bien en taller.

Ahora vamonos al campo que es donde se quedará y a veces llegan los sms y a veces no, el problema es con el módulo ya que del teléfono celular si se envían y reciben los sms, estando en el mismo lugar. Envié 4 sms esperando 4 respuestas, sólo se respondió a una.

En el celular el indicador de señal esta a medio nivel, pero éste si trabaja.

Entonces que debo hacer cambiar de antena?, en el lugar donde esta el equipo hay una pequeña torrecita de 3 metros, si pongo el módulo de comunicación alli, trabajará?

No sé que hacer ustedes que opinan.

saludos.
Título: Re: Problemas en recepción con SIM900
Publicado por: Nocturno en 28 de Abril de 2013, 19:04:08
¿Que antena le has puesto?
Título: Re: Problemas en recepción con SIM900
Publicado por: KALLITOS en 29 de Abril de 2013, 15:13:36
Hola manolo, el módulo en sí ya trae la antena y es la que se muestra en la pagina de ebay, no indica las caracteristicas de la antena referente a ganancia y esas cosas.

saludos.
Título: Re: Problemas en recepción con SIM900
Publicado por: PalitroqueZ en 29 de Abril de 2013, 16:35:25
en el campo:

¿las fuente de alimentación del equipo es la misma?
¿el equipo se encuentra debidamente protegido contra interferencias externas?
¿qué respuesta te genera el comando at+creg?
¿cuando el módem va a enviar un sms, que respuesta genera el comando at+cmgs?

Título: Re: Problemas en recepción con SIM900
Publicado por: KALLITOS en 29 de Abril de 2013, 17:33:21
Gracias por contestar palitroquez.

1: es la misma, bateria de 12v el amperaje exacto no lo anoté, pero van 2 en paralelo de unos 100Ah c/u cargados con paneles solares 2 de 70W, instalado para el uso de otros equipos pero no utilizados, es decir estan exclusivamente para mi equipo. Instalación que no hice yo, lo que hago es usar lo ya existente.

2: debido a la nula disponibilidad de cajas apropiadas, pues le acondioné una caja de pvc como ESTA (http://www.google.com.pe/url?sa=i&rct=j&q=&esrc=s&source=images&cd=&cad=rja&docid=oH2JrWMJOh1xxM&tbnid=ZFOWg2cUCnievM:&ved=0CAUQjRw&url=http%3A%2F%2Fwww.electromisiones.com.ar%2F23909%2Froker-caja-paso-blanca-ext-ip65-antill%2Fuv-115x115x-67mm&ei=lNN-Ufj_H5CB0AHypoHABA&bvm=bv.45645796,d.dmQ&psig=AFQjCNFmq7kN9QKDN7EW94vQY0qoCfgkvw&ust=1367352587370755), y está sin apantallamiento metalico.

3: No he comprobado ese comando, pero si logró recibir y responder.

4: La situación es que el módem responde, es decir, espera que le solicite información, pero como no llega el sms no responde.

El equipo lo tengo aca en taller, el cable para rs485 está siendo instalado por tuberías metalicas para que quede definitivo, inicialmente sólo fué puesto al aire libre para probar, esta parte trabajó bien, sin problemas.

saludos.
Título: Re: Problemas en recepción con SIM900
Publicado por: MGLSOFT en 29 de Abril de 2013, 17:48:28
A esas cajas comunes, internamente le das pintura aluminio, varias capas, y te queda como si la hubieras comprado... :mrgreen: :mrgreen:
Título: Re: Problemas en recepción con SIM900
Publicado por: KALLITOS en 29 de Abril de 2013, 20:31:13
Que opinan de ESTO (http://www.ebay.com/itm/150832074090?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1423.l2649) ??
Título: Re: Problemas en recepción con SIM900
Publicado por: vdiazg en 01 de Mayo de 2013, 03:24:48
tu modulo, tiene el led que indica si hay señal GSM, sino deberias chequear la señal periodicamente con AT+CREG? y ver la respuesta; el problema lo tienes tambien en el taller o es solo en el campo?, intenta ponerle la antena de las bases celulares (las que usan en los locutorios, la que tiene la antena extendible)
Título: Re: Problemas en recepción con SIM900
Publicado por: stk500 en 01 de Mayo de 2013, 07:20:53
Kallitos  esa antena te podria servir pero te aconsejo que el cable no sea mas de 2 metro de largo porque podria necesitar un Bosster(amplificador de Antena), y claro cable de 50 Ohmio de impedancia, yo probaria con esa ante de comprarla, En esa Zona hay Radio Taxi? quizas alguien te podria prestar algunas, pero aseguraste siempre su impedancia ya que podria dañar el amplificador de salida del modulo, te podria servir tambien los modulos de Antena que usan los microfonos sin alambre, por ejemplo de Sehnheisser o Shure pero que vayan a la frecuencia GSM 850MHz, EGSM 900MHz, DCS 1800MHz and PCS 1900MHz. ojos modelo que van a 2Ghz.
para esto modulo tambien hay Booster de Antena, me imagino que alla en Peru hay empresa que alquilan equipo de sonido alli podria alquilar algunos, informaste con ellos.
Saludos y suerte
Título: Re: Problemas en recepción con SIM900
Publicado por: KALLITOS en 10 de Mayo de 2013, 14:48:44
Perdón por la tardanza y gracias por las respuestas.

tu modulo, tiene el led que indica si hay señal GSM, sino deberias chequear la señal periodicamente con AT+CREG? y ver la respuesta; el problema lo tienes tambien en el taller o es solo en el campo?, intenta ponerle la antena de las bases celulares (las que usan en los locutorios, la que tiene la antena extendible)

Si trae led indicador de conexión, pero el modulo esta dentro de una caja de pvc y no se puede ver a simple vista, pero la idea es que el equipo sepa esos parametros, asi que usaré los comandos necesarios.
El problema me lo dá en el campo, en taller va todo bien.

Lo de la antena aun ando viendo opciones; QUE OPINAN DE ESTO (http://articulo.mercadolibre.com.pe/MPE-404130135-antena-celular-generacion-4-gold-mejorada-senal-superior-_JM) funciona? como se instala?

Estoy trasteando con ese comando también con AT+CSQ, justamente de este ando confundido por el tipo de reporte que dá y como mostrarlo tal cual se muestra la barra de antena en el móvil.

En taller el módulo me responde lo siguiente +CSQ: 16,0, no sé como interpretarlo, encontre ESTE PDF (http://www.etsi.org/deliver/etsi_gts/05/0508/05.01.00_60/gsmts_0508v050100p.pdf), que se menciona en el manual del SIM900

EL manual indica lo siguiente
+CSQ: <rssi>,<ber>

<rssi>
0         -115 dBm or less
1         -111 dBm
2...30   -110...-54 dBm
31        -52 dBm or greater
99        not known or not detectable

<ber> (in percent)

0...7     As RXQUAL values in the table GSM 05.08[20] subclause 7.2.4
99        Not known or not detectable


Entonces no se como mostrarlo. Porfa ayudenme en esto.


para esto modulo tambien hay Booster de Antena, me imagino que alla en Peru hay empresa que alquilan equipo de sonido alli podria alquilar algunos, informaste con ellos.
Saludos y suerte

Podrías ser mas específico por favor para ver que debo buscar/encontrar.

Muchas gracias por las respuestas otra vez. :)
Título: Re: Problemas en recepción con SIM900
Publicado por: Nocturno en 10 de Mayo de 2013, 14:53:41
Todo lo que sea un CSQ por encima de 10 es una recepción de señal aceptable.

Mi módulo, cuando le quito la antena, me marca un CSQ de 2, y cuando se la pongo, pilla hasta 24.