Autor Tema: Problema con velocidad de propagacion - disparos sucesivos con monoestables  (Leído 991 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Cryn

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 4169
saludos a todos. Creo que tengo un problema de velocidad de propagacion, ya que he configurado un contador de 3 bits con flip-flops J-K, y debo usar sus entradas de preset y reset para darle los bits necesarios cuando se presione un pulsador, y cuando deba resetear, y pues como sabran hay bastantes compuertas que he sacado segun mi diseño el circuito de control para las entradas asincronas (Pre y Res) y pues sucede qeu segun mi tabal de verda, las cosas deberias ir de maravilla, y pues no encontraba respuesta hasta que me puse a verlo a fondo en el simulador proteus, con la grafica de mis salidas digitales, y logre ver esa pequeña falla que hace que mi circuito se trunque cuando no debe y si paso ese truncamiento todo ira de maravilla. Pienso que necesitare un contador mas rápido para que las compuertas no vean el cambio lento y vean directamente el otro estado, nose si estare en lo correcto que me dicen ustedes??

talvez asi no se me ha entendido muy concretamente, y como les menciono es una circuiteria muy grande ya (segun yo, jeje) y pues si estan dispuestos a colaborarme lo subire por aca para qque vean el enenuciado de mi problema y la solucion que hice, y la simulacion y todo, pero como les digo esta complicado entenderlo a primera vista, y si se animan, denme un anuncio para colgarlo, vale??

probare primero con un flip flips mas rápido

muchas gracias adios.
« Última modificación: 04 de Octubre de 2007, 15:06:24 por Cryn »
.

Desconectado el_legal

  • PIC12
  • **
  • Mensajes: 65
    • LINAP SRL
Re: Problema con velocidad de propagacion
« Respuesta #1 en: 03 de Octubre de 2007, 20:23:05 »
hola:
si colocas el enunciado de lo que tenes que hacer a lo mejor te puedo ayudar por que en si no te entiendo.
"Si alguno quiere ser el primero, que se haga el último de todos y el servidor de todos."
 Mc 9.35

Desconectado Cryn

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 4169
Re: Problema con velocidad de propagacion
« Respuesta #2 en: 03 de Octubre de 2007, 21:46:24 »
he adjuntado en este link el enunciado, mi solucion, el problema qeu logre observar y las simulaciones que hice con proteus 7.1 sp4, espero logren ayudarme, un saludo y muchas gracias de antemano

si es que me falto explicar algo o no esta muy claro avisenme para que lo aclare, un saludo
.

Desconectado Cryn

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 4169
Ayuda con disparo retardado para otro monoestable
« Respuesta #3 en: 04 de Octubre de 2007, 15:05:01 »
nose si sera un problema de velocidad, talvez si, ahora comprare unos integrados de ese tipo si es que encuentro, pero cual son mas veloces qeu los LS pero a la vez compatibles con TTL?? estan bien los HC, los ALS o los F??

he logrado encontrar una solucion algo tonta talvez pero funciona, para evitar esos reseteos por retardos creo yo; y es disparar un otro monoestable unos instantes despues de disparar el primero, como puedo hacerlo alguien sugiere algo; lo que intento hacer es disparar un monoestable que durara 9 segundos con un pulsador (este ya estaba en el circuito) y a la vez despues de haber disparado este mismo que pase menos de un segundo y se dispare otro monoestable, ambos accionados con un mismo pulsador, se entendio? espero logren ayudarme, muchas gracias, un saludo para todos
.

Desconectado Cryn

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 4169
Re: Problema con velocidad de propagacion - disparos sucesivos con monoestables
« Respuesta #4 en: 05 de Octubre de 2007, 14:10:18 »
no encontre flipflops de otro tipo por aca, siempre es asi por estos lugares, no hay nada!! pero bueno ni modo, asi que esa opcion quedo descartada, y ademas en el proteus no pude simularlo con integrados F, intentare con lo otros, se me olvido.

Aunque eso solo quedara para la prueba ya que he dado con una solucion, jeje segun yo algo tonta tb, ya que logro mi retardo necesario haciendo pasar la señal por unos cuantos negadores, cuatro para ser exactos, jeje, no probe conmenos, pero con esos cuatro suficiente, ya que tenia un 7404 casi sin usar asi que no hubo problema, jeje, weno pues si alguien quiere mas detalles me los pide, aunque no creo que este semaforo sea util a todos ya que es una practica de una materia por aca.

bueno, un saludo para todos y ya espero me crezcan los pelos despues, porque quede con unos pocos, jajaja
.


 

anything