TODOPIC
Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
21 de Diciembre de 2014, 21:41:03

Ingresar con nombre de usuario, contraseña y duración de la sesión
Buscar:     Búsqueda Avanzada
352565 Mensajes en 39588 Temas por 41376 Usuarios
Último usuario: jorgeB
* Inicio Ayuda Buscar Calendario Ingresar Registrarse
Buscar en TodoPIC
+  TODOPIC
|-+  Microcontroladores PIC
| |-+  Todo en microcontroladores PIC (Moderadores: marmatar, maunix, MGLSOFT, Modulay, pocher, Sasián, Suky)
| | |-+  Pic y Triac
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Marcar como favorito Imprimir
Autor Tema: Pic y Triac  (Leído 12390 veces)
pmoreno
PIC10
*
Desconectado Desconectado

España España

Mensajes: 13


« : 21 de Marzo de 2008, 12:25:40 »

Hola, estoy haciendo pruebas para prepararme unos experimentos sobre domótica y x10 y me he preparado unos circuitillos buscando el minimalismo y simpleza. Probando inicialmente hacer dimmer digital con pic y triac me he encontrado con la pega de que tengo parpadeo en las lámparas (parecido al que ocurriría si sólo disparamos el triac en uno de los semiciclos). Estoy convencido de tener correctamente implementados la detección de cruce por cero y los momentos de excitación a la gate ( por comodidad y ahorro de componentes siempre con pulso positivo independientemente del semiciclo ). El circuito se alimenta con un máximo de 10 mA y no utilizo opto entre el pin del pic y la gate del triac (tipo minidimmer que ya conoceis en el foro). Necesitaría ayuda de algún forero que conozca triacs y su funcionamiento porque...

Creo que lo que tengo es un error en la elección del triac. No acabo de comprender bien el tema de cuadrantes en los triac pero creo que me queda claro que necesito uno que pueda activar con muy poquitos mA en gate en los cuadrantes MT2+ G+ y MT2- G+ (creo haber entendido que son los cuadrantes 1 y 4, y lo normal es utilizar el 1  y 3). He estado probando con
BT137 y TIC226 pero necesitan más mA en el cuadrante 4 de los que mi circuito puede dar sin añadir componentes y consumo. Microchip recomienda el L4008L6 en alguna nota de aplicación que he consultado pero no lo localizo en proveedores.

Podríais darme algún equivalente u orientarme sobre si estoy equivocado y cómo solucionar este puñetero parpadeo en las lámparas? me gustaría poder ahorrar el optotriac en la pcb.


Un saludo,
« Última modificación: 21 de Marzo de 2008, 12:56:55 por pmoreno » En línea
migsantiago
Colaborador
DsPIC33
*****
Desconectado Desconectado

Sexo: Masculino
Mexico Mexico

Mensajes: 8317



WWW
« Respuesta #1 : 21 de Marzo de 2008, 13:18:28 »

Estoy convencido de tener correctamente implementados la detección de cruce por cero y los momentos de excitación a la gate ( por comodidad y ahorro de componentes siempre con pulso positivo independientemente del semiciclo ).

Hola

El disparo de la compuerta del triac debe hacerse en ambos semiciclos, con pulso negativo y pulso positivo dependiendo del semiciclo en el que se encuentra.

Sería buena idea que publicaras tu diagrama de conexiones. Tal vez sea problema de sensibilidad de la compuerta como tú mencionas.
En línea

pmoreno
PIC10
*
Desconectado Desconectado

España España

Mensajes: 13


« Respuesta #2 : 21 de Marzo de 2008, 13:57:48 »

Gracias por la respuesta,
Realizo el disparo de la compuerta en ambos semiciclos, pero siempre inyecto positivo a la gate, de ahí el hecho de necesitar triac con compuerta sensible en el cuadrante 4 ( semiciclo negativo de mt2 y pulso positivo a compuerta ) en el cuadrante 1 y 3 funcionan todos los triac sin problemas. Creo haber encontrado 2 referencias que me vendrían muy bien dependiendo de consumos y el espacio a utilizar, pero para manejar lámparas creo que van sobrados, ya me comentaréis:

 http://docs-europe.electrocomponents.com/webdocs/0931/0900766b80931614.pdf

http://docs-europe.electrocomponents.com/webdocs/048e/0900766b8048e21b.pdf

Veo que con estos no deberíamos tener problemas en activar la gate con unos pocos milivoltios positivos desde el pin del pic independientemente del semiciclo en el que nos encontramos.

Un saludo,
En línea
Javicho
Colaborador
PIC24F
*****
Desconectado Desconectado

Peru Peru

Mensajes: 570


« Respuesta #3 : 22 de Marzo de 2008, 11:06:51 »

Recuerdo haber usado hace tiempo un simple BT136 y anduvo bien, tal vez tu lógica de disparo es la que está mal. Comentanos como disparas, por cuanto tiempo mantienes activo el disparo, muestra el diagrama que usas para darte una mano.

Javicho.
En línea
beth
PIC10
*
Desconectado Desconectado

Mensajes: 6


« Respuesta #4 : 23 de Marzo de 2008, 07:46:08 »

Hola, ya se que quizas sea introducir un componente adicional, pero a mi me ha dado muy buenos resultados con un bt16 y similares. Es usar un optoaislador con salida a triac como los moc304XX, en los mismos datasheets vienen ejemplos de uso.

Ciao
En línea
pmoreno
PIC10
*
Desconectado Desconectado

España España

Mensajes: 13


« Respuesta #5 : 24 de Marzo de 2008, 14:05:04 »

Hola a todos y muchas gracias por las respuestas. Trataba conseguirlo con el mínimo de componentes (no usando acopladores tipo optotriacs), ni excitando la gate con pulso negativo cuando el semiciclo también lo es.
Efectivamente mi problema era que utilizaba triacs con la gate poco sensible y mi circuito no aportaba más de 10mA. Acabo de probar los que he recibido hoy, y el parpadeo se acabó, puedo excitar la gate en cualquier cuadrante con 7mA positivos sin ningún problema. El TIC206 funciona fenomenal para dispararlo con un pin del pic sin más intermediarios.

Un saludo,

En línea
apolov
PIC10
*
Desconectado Desconectado

Ecuador Ecuador

Mensajes: 2


« Respuesta #6 : 21 de Octubre de 2008, 16:30:15 »

Hola
ando en el mismo problema , sin poder disparar el Triac
una pregunta, por qué cambiaste del TiC226 al 206?
es posible saber la duración de los ciclos , o saber cómo dispararlo
Ayuda porfavor
AV
En línea
Giovanny
PIC12
**
Desconectado Desconectado

Sexo: Masculino
Colombia Colombia

Mensajes: 97



WWW
« Respuesta #7 : 21 de Octubre de 2008, 17:09:09 »

en este enlacehay un ejemplo simulado en proteus , donde se usa un triac. para algo similar a lo que buscan
En línea

        Saludos desde Colombia! Que hermoso país....
MordorInc
PIC10
*
Desconectado Desconectado

Sexo: Masculino
Colombia Colombia

Mensajes: 5



« Respuesta #8 : 15 de Diciembre de 2008, 19:05:22 »

Hola a todos,
estoy trabajando con un TRIAC BTA08 600B, y con el PIC10F202 con la configuracion que aparece en la grafica 1, detecto sin problemas el cruce por cero y podria detectar si es con flanco de subida o de bajada, pero no tengo esta caracteristica en este momento.

Lo que hago es detectar el flanco y con los pulsadores aumentar y disminuir el angulo de disparo, cada 12.5%, es decir muevo el tiempo (angulo) en que hago el disparo desde 0% hasta 100%, mi problema esta en que funciona para la parte positiva de la señal (como se observa en la grafica 2) pero no en la negativa.

se que debo disparar cuando la onda (120VAC @ 60Hz) esta en el cuacrante positivo una señal positiva y asi lo hago, mando cero por el puerto GP1 hasta que debo disparar y en ese momento paso el valor del puerto a uno. y funciona.
Como debo hacer con el ciclo negativo, envio cuando cruza por cero la señal un 1 hasta que llega el momento de disparar y saco en ese instante un 0.
otra pregunta, como sabe uno en que cuadrante se encuentra trabajando, como se si estoy trabajando en el cuadrante 2 y 3 que segun leo son los optimos..
les agradezco su ayuda
En línea
TODOPIC
   

 En línea
Páginas: [1] Imprimir 
« anterior próximo »
Ir a:  

Impulsado por MySQL Impulsado por PHP Powered by SMF 1.1.20 | SMF © 2006-2008, Simple Machines XHTML 1.0 válido! CSS válido!
Página creada en 0.097 segundos con 25 consultas.
anything