Autor Tema: Cable USB-DB9 Fallido o drivers malos?  (Leído 1878 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado geronimoo

  • PIC10
  • *
  • Mensajes: 34
    • Divide & Conquer
Cable USB-DB9 Fallido o drivers malos?
« en: 11 de Enero de 2009, 16:46:49 »
Buenas!
Compre un cable USB-DB9 para comunicar un PIC con una PC.
La comunicacion va de 10 con una PC con puerto serie, pero al usar el cable con una notebook, recibo los datos, pero bajo un patron interesante.

Supongamos que el programa es este:
main(){
delay_ms(1000);
printf("Hola mundo");
}

Lo que recibo es esto:
Hola mund(1 SEGUNDO)oHola mun(1 SEGUNDO)do Hola m
Y asi sucesivamente...

Es como si el controlador del cable, no vaciara su buffer, sino hasta recibir la proxima trama.

La verdad es algo que me tiene muy confundido, y me molesta haber pagado por un cable que anda  a medias, porque de funcionar como esta funcionando, el cable no sirve para nada.

Aguna idea?
Le paso esto a alguien?
Saludos!
.::GERO::.

Desconectado Slalen

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1079
    • Página web personal de Guillermo Herrero González
Re: Cable USB-DB9 Fallido o drivers malos?
« Respuesta #1 en: 11 de Enero de 2009, 20:31:07 »
¿Tienes la misma velocidad de transmisión? ¿Has configurado todo igual?

Parece que te manda 9 bytes y espera (si lo que te envía es como lo has escrito)

Si lo tienes todo igual, prueba a buscar otro driver y si no parece que está mal el cable.

Es muy raro....

Desconectado ema

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1078
Re: Cable USB-DB9 Fallido o drivers malos?
« Respuesta #2 en: 11 de Enero de 2009, 20:37:24 »
A mi me paso. Resulta que el cable era una copia de otro que si funciona. Pero este tiene la diferencia que no tiene cristal, y en cambio usa un RC. La unica solución es reclamar tu dinero y comprar otro cable.

A veces con el cambio de calor sobre el cable, funcionaba pero otras no.

Saludos

Desconectado geronimoo

  • PIC10
  • *
  • Mensajes: 34
    • Divide & Conquer
Re: Cable USB-DB9 Fallido o drivers malos?
« Respuesta #3 en: 12 de Enero de 2009, 03:11:46 »
Huuuyy que mala noticia ema!  :(
Lo del dinero, no es negociable jeje...
Asi que voy a seguir con las pruebas...
La configuracion es la misma en los 2 puntos.
Voy a probar  a diferentes baudajes, controles de flujo y todo lo que sea modificable, aver si logro hacerlo andar...
Luego probare con otros drivers que encuentre por internet
Y luego, me lo meto en el culo jeje
Gracias por als respuestas!
Si tengo novedades, aviso!
Saludos!
.::GERO::.


 

anything