Autor Tema: Pico consumo arranque motor eléctrico  (Leído 20906 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Conectado planeta9999

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3479
    • Pinballsp
Re:Pico consumo arranque motor eléctrico
« Respuesta #30 en: 02 de Abril de 2016, 17:10:38 »
Qué tipo de motor usas yo he tenido más problemas con el motor serie dc es porque jala mucho al arranque y el micro se baja mucha la tensión y sube muy rápido por eso le pude doble regulador en serie mas capacitores de alto valor.

Si, es un motor de contínua, que consume 18 Amperios cuando está rodando. No tengo más información de ese motor porque va dentro de un fusil de paintball (o algo así), y no se puede sacar.

Todo va conectado a una batería de 12 voltios, y de esos 12 voltios con un regulador de 3.3v LD1117 saco el voltaje para el micro. Mucho tendría que caer la tensión para que el regulador pierda voltaje, creo que el drop-out es de 1 voltio, osea que el motor tendría que tirar el voltaje de la batería de 12v a menos de 4.3v, me parece poco probable.

Más me parecen reseteos por interferencias de señales de RF generadas por el motor, que por una caída de voltaje. Además los reseteos se producen cuando el motor ya está rodando, cada pocos segundos.

Si tuviera aquí todo, le metería el osciloscopio, a ver que hay en el positivo de los 3.3v, cuando el motor gira.

También creo que le metí un electrolítico demasiado pequeño a la salida del regulador, de solo 10uF, a ver si con uno más gordito de 220uF por ejemplo, se resuelve.
« Última modificación: 02 de Abril de 2016, 17:14:40 por planeta9999 »

Desconectado cristian_elect

  • PIC18
  • ****
  • Mensajes: 449
Re:Pico consumo arranque motor eléctrico
« Respuesta #31 en: 02 de Abril de 2016, 20:43:15 »
Algo parecido me paso tengo un motor que hace girar una bomba hidráulica y cuando arranca el micro controlador de reinicia porque le jala mucha corriente a la batería pero no era problema por el micro que solo se dedicaba a medir voltaje y la controlar la carga de la batería y no del control del motor pero en otro caso parecido que tenía que controlar el motor que solo adicionándole filtros  y dos estepas de regulación de voltaje y unos tvs de 5V lo solucione.

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7325
Re:Pico consumo arranque motor eléctrico
« Respuesta #32 en: 02 de Abril de 2016, 20:45:33 »
Puede ser que el mismo pico de corriente / voltaje este entrando por la capacidad parasita del mismo MOSFET al gate. Con lo cual lleva que si podes controlar el brusco dv/dt o di/dt seria la solucion (snubber para la dv/dt)