Autor Tema: Simple PWM con potenciometro?  (Leído 709 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2173
Re:Simple PWM con potenciometro?
« Respuesta #15 en: 01 de Marzo de 2017, 09:56:12 »
Bueno, el circuito esta funcionando. Pero ahora resta calcular los componentes para obtener un duty entre 75% y 100%

Saludos
-
Leonardo Garberoglio

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4230
Re:Simple PWM con potenciometro?
« Respuesta #16 en: 01 de Marzo de 2017, 10:29:08 »
Hola elgarbe, en eso estás complicado, con ese circuito nunca conseguirás duty's extremos, por ejemplo del 100% o del 0%, puedes acercarte mucho, pero nunca llegar.

Esto es precisamente por el uso de la resistencia que te e recomendado que apliques para proteger el integrado, pero por ahí, con acercarte mucho te es de utilidad.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2173
Re:Simple PWM con potenciometro?
« Respuesta #17 en: 01 de Marzo de 2017, 11:05:24 »
Si si. Con acercarme al 100% estoy bien.
En principio tengo el pote de 10K, R1 en 1K y el capacitor C1 1nF y las 2 resistencias en los extremos del pote de 220ohm

Con el pote en 0 ohm en el sentido de carga del capacitor :
ton  0.7*(1000 + 220) * 100E-9 = 85.4uSeg
toff = 0.7 * (10000 + 220) * 100nF = 715useg
f=1/(715+85.4) = 1248 Hz

El duty cycle es 10%

Con el pote en el otro extremo tenemos
ton  0.7*(10000 + 1000 + 220) * 100E-9 = 785.4uSeg
toff = 0.7 * (0 + 220) * 100nF = 15.4useg
f=1/(785.4+15.4) = 1/800.8useg = 1248 Hz

El duty cycle es 785.4/800.8 * 100 = 98%

No tengo el osciloscopio a mano por lo que mido la tension con un tester digital de los comunes.
En el gate del mosfet tengo 1.5V y 10.5V. La alimentacion esta en 11V (tengo una fuente externa hasta que coloque el 7812). Entonces 11V * 10% = es 1.1V y 11V * 98% = 10.78V

Lo que no me termina de cerrar es que en la placa LED tengo 13.8V y 23.8V cuando esperaba tener 24V * 10% = 2.4V y 24V * 98% = 23.5V (este ultimo esta correcto).

Incluso con 2.4V los led se apagarían, pero no consigo que se apaguen, quedan encendidos como si tuvieses efectivamente los 13.8V.

Alguna idea? Los mosfet son IRFZ44...

Saludos
-
Leonardo Garberoglio

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4230
Re:Simple PWM con potenciometro?
« Respuesta #18 en: 01 de Marzo de 2017, 14:01:21 »
Hola elgarbe

Si si. Con acercarme al 100% estoy bien.
En principio tengo el pote de 10K, R1 en 1K y el capacitor C1 1nF y las 2 resistencias en los extremos del pote de 220ohm

No me di cuenta antes, pero las dos resistencias R2 y R3, puedes reemplazarla por una sola. Siempre y cuando esta resistencia esté conectada entre los diodos y el PIN7 del 555

Lo que no me termina de cerrar es que en la placa LED tengo 13.8V y 23.8V cuando esperaba tener 24V * 10% = 2.4V y 24V * 98% = 23.5V (este ultimo esta correcto).

Incluso con 2.4V los led se apagarían, pero no consigo que se apaguen, quedan encendidos como si tuvieses efectivamente los 13.8V.

Si, tengo idea, los "cálculos" tuyos están mal hechos (en realidad mal aplicados), porque vos estás queriendo sacar un "promedio" de la tensión de salida aplicando el duty del PWM, y esto no es posible con el circuito actual. Porque tu a la salida no posees una tensión de continua, si no que esta es una pulsante, que no es lo mismo. Para obtener una continua deberías de aplicarle un filtro RC tal como si fuera una fuente conmutada y ahí si podrías hacer los cálculos como tu los estás queriendo hacer ya que a la salida tendrías una continua. También podrías aplicar esos cálculos cuando la carga a usar tuviera una inercia importante, por ejemplo un motor o una lámpara de incandescencia, pero con led's, que poseen una inercia casi de cero, no es posible.

Esto es así, porque durante los tiempos OFF el led está completamente apagado, pero los tiempos ON el led está completamente encendido. Y como el led es rápido en responder, y la vista posee su buena persistencia, pues aunque el duty cicle esté al 10%, veras los led encendidos, para verlos apagados, deberás tener el duty muy próximo al 0%.

Por otro lado, la "medición" que estás haciendo con el multímetro no te da "pareja", porque tu mides todo el circuito referenciando a GND o masa, incluido los led's, pero si mides todo el circuito referenciando a masa, los led's debes de medirlos en paralelo a los mismos, o sea, una de las puntas del multímetro al 24V y la otra (punta negra) al DRAIN de los mosfet, entonces ahí si tendrás una tensión promedio más "pareja".

La solución? Aumentar el valor del potenciómetro y de ser necesario disminuir el valor de C1 para que la frecuencia se mantenga por encima de los 100 Hz. Tampoco te recomiendo frecuencias muy elevadas, así mantenes el rendimiento lo más alto posible y la disipasión/calentamiento sobre los morfet sea menor.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2173
Re:Simple PWM con potenciometro?
« Respuesta #19 en: 01 de Marzo de 2017, 14:37:39 »
Excelente, justo estabamos discutiendo con mi socio lo que me explicas, los LED reciven pulsos de 24V, de corta duracion, pero de 24V por lo tanto van a encenderse.
Para bajar el duty minimo no puedo achicar R1? se me va a bajar un poquito el duty máximo... x q no tengo un pote mas grande... sino tengo que esperar a viajar para comprar o ver si consigo alguno por ahi...

Saludos
-
Leonardo Garberoglio

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4230
Re:Simple PWM con potenciometro?
« Respuesta #20 en: 01 de Marzo de 2017, 15:58:26 »
Hola elgarbe, podrías bajar R1, pero no te lo recomendaría, por la propia integridad del 555, si no tienes potes, puedes probar con preset, por lo menos hasta que consigas el pote adecuado.

Un saludo.

Atte. CARLOS.

Pda. Si ya no tienes algún preset, pues cierra el boliche  :D  :D  :D

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Picuino

  • Moderador Local
  • DsPIC33
  • *****
  • Mensajes: 4342
    • Picuino
Re:Simple PWM con potenciometro?
« Respuesta #21 en: 01 de Marzo de 2017, 16:52:58 »
En la página 9 del datasheet de Texas Instruments aparece un monoestable con la patilla de descarga directamente conectada al condensador. http://www.ti.com/lit/ds/symlink/lm555.pdf

Yo creo que podrías probar a cortocircuitar R2 a ver si el 555 aguanta, pero no conseguirás mejorar mucho el tiempo de ciclo.
En cuanto a R3 no tiene casi ningún efecto. Se suma a R1, que es mucho mayor. Puedes cortocircuitarla también.

Si quieres valores extremos, deberías probar con un potenciómetro mayor (100k). Así llegarás a una relación con R1 de un 1% y podrás conseguir ciclos del 1% al 99%.

El condensador de 1nF te valdrá para conseguir frecuencias en torno a los 10kHz. No pasaría nada si pones 10nF para tener frecuencias de 1kHz

Si quieres medir tensión en los led con un polímetro, pon una resistencia en paralelo a los led para que al desconectar la tensión su valor caiga rápidamente a cero. Así si podrás hacer mediciones de la  tensión media directamente con el polímetro.

Un saludo.

Desconectado Picuino

  • Moderador Local
  • DsPIC33
  • *****
  • Mensajes: 4342
    • Picuino
Re:Simple PWM con potenciometro?
« Respuesta #22 en: 01 de Marzo de 2017, 17:04:20 »
Si bajas R1, el consumo aumenta mucho. El datasheet no dice nada, pero según su curva de saturación no deberías pasar de 50mA en la descarga.
Eso significa una resistencia de 240 Ohmios y 1vatio. Con una resistencia así mejorarás del 10%-97% actual aproximadamente a un 3%-97%

Creo que la solución del potenciómetro mayor es mejor.

Saludos.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2173
Re:Simple PWM con potenciometro?
« Respuesta #23 en: 01 de Marzo de 2017, 19:54:24 »
Consegui el pote de 100K!!!!!

jajaja. mañana lo pruebo, me tengo que acordar de bajar C1 a 10nF...

Saludos y gracias!!!
-
Leonardo Garberoglio


 

anything