Autor Tema: Problema con sensor de color  (Leído 213 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Kspids

  • PIC16
  • ***
  • Mensajes: 134
Problema con sensor de color
« en: 28 de Septiembre de 2018, 06:13:47 »
Buenas a todos,

estoy utilizando un sensor de color modelo TCS3472. Me funciona con cambio de colores bruscos pero no para tonalidades dentro de un único color. He probado a cambiar la ganancia pero no me vale. Por ejemplo, entre dos colores que necesito distinguir hay una diferencia de 100 y eso es muy inestable ya que varía enseguida. Además creo que hay un problema añadido y es que entre el sensor y el color hay una plástico que no se puede quitar por tema de diseño.
¿Saben alguna manera para conseguir que aumente la diferencia numérica entre los dos colores para poder aumentar el intervalo entre ellos y que aunque varía un poco no se salga del rango que establezca? o ¿conocen algún otro modelo que me de mejor resultado y más preciso?
Cualquier otra idea será bienvenida!

Desconectado Robert76

  • PIC16
  • ***
  • Mensajes: 213
Re:Problema con sensor de color
« Respuesta #1 en: 28 de Septiembre de 2018, 07:20:38 »
Hola, bueno has probado aumentar la iluminación incidente en el objeto?
Quizás aumentando la ganancia de la señal que arroja. El tema es que tendrás mejor resolución en una porción del espectro, pero quizás pierdas margen para el resto.

Desconectado Kspids

  • PIC16
  • ***
  • Mensajes: 134
Re:Problema con sensor de color
« Respuesta #2 en: 28 de Septiembre de 2018, 09:00:15 »
Sí, he probado con ganancia 0, 1 y 2 pero lo ideal sería de 1,5 porque ni el 1 y el 2 me vale, o no llego o me paso..