Autor Tema: No puedo conectar los buses desde dentro de un subcircuito a la hoja principal  (Leído 203 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado vra

  • PIC10
  • *
  • Mensajes: 22
Hola a todos, cómo están?. Estoy haciendo un proyecto en Proteus el cual quiero hacerlo lo más modular posible, desde la hoja principal tengo una pantalla LCD (ver imágenes adjuntas "Conexión a la pantalla.png" y "Puertos para buses en subcircuito.png") cuyos terminales los estoy moviendo mediante un bus hacia un subcircuito y dentro del subcircuito coloco otro bus nombrado como el terminal de bus de la parte externa del subcircuito y dimensionado para manejar todas las señales necesarias.

Dentro del subcircuito (ver imagen adjunta "Conexión dentro del subcircuito.png") todo está conectado pero cuando corro la simulación los terminales en la hoja principal aparecen flotantes lo cual significa que no se está realizando la interconexión entre el subcircuito aparentemente por un error mío, los terminales normales para una sola señal si funcionan a la perfección.

Cómo podría resolver este problema?.

Muchas gracias de antemano por la ayuda brindada.

Desconectado Yoshua

  • PIC16
  • ***
  • Mensajes: 181
Re:No puedo conectar los buses desde dentro de un subcircuito a la hoja principal
« Respuesta #1 en: 18 de Abril de 2020, 10:58:11 »
Tienen que tener los mismos nombres las lineas. Si pones LCD_x de un lado, tiene que salir LCD_x del otro, sino te lo toma como distintas lineas.

Desconectado vra

  • PIC10
  • *
  • Mensajes: 22
Re:No puedo conectar los buses desde dentro de un subcircuito a la hoja principal
« Respuesta #2 en: 19 de Abril de 2020, 15:40:04 »
Tienen que tener los mismos nombres las lineas. Si pones LCD_x de un lado, tiene que salir LCD_x del otro, sino te lo toma como distintas lineas.

Uppss...error de capa 8, adicionalmente tenía otros errores en las etiquetas de los cables individuales pero todo está resuelto ahora, muchas gracias


 

anything