Autor Tema: ERROR EN 000H PIC16F877A  (Leído 1205 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado pepocor

  • PIC10
  • *
  • Mensajes: 8
ERROR EN 000H PIC16F877A
« en: 22 de Noviembre de 2004, 12:20:00 »
Hola a todos. Después de muuuucho leer por internet dejo aquí mi duda a ver si alguien consigue echarme un cable con mi problema con el dichoso 0000h.

He construido un TE-20 con un esquema que sé que funcionaba para el 16f876 y lo he adaptado para la versión de 40 pines del 77.
El cambio ha sido basicamente...
                        28 pines                  40 pines
Vpp                       1                                 1              
RB7/PGD             28                               40
RB6/PGC             27                               39
VDD                     20                             32/20
VSS                     19                              31/12

¿Sería correcto el cambio?. No tenía claro si pasar VDD a ambas patas, al igual que VSS pero creo que está bien hecho porque así se alimenta el 77, ¿no?.

He testeado el TE-20 con un programa y funciona perfectamente y he verificado todos los puntos con un multímetro por lo que no se donde puede estar el fallo del hw. Por otro lado también he comprobado todas las posiblidades del ICPROG (Cambiar el I/O, la velocidad del COM2, etc, etc) y nada, sigue dando el fallo de verificación en 0000h, como que no grabara nada. Pensaba que podía ser el microcontrolador y probé con otros nuevos y tampoco...

Lo último que hice que leí en otra página fue puentear en el hw la patilla 36 (RB3/PGM) a tierra para ver si servía de algo habilitar la programación a nivel bajo y tampoco sirvió, además ni siquiera sé si está bien hecho.

No entiendo que puede ser, estoy desesperado. Si alguien tuviera un esquema de este hardware algo claro se lo agradecería mucho o si alguien que haya construido un programador Te20 y lo haya hecho funcionar con el 16f877A me puede echar un cable....

Muchas gracias y perdón por el ladrillo.

Desconectado odukec

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 174
RE: ERROR EN 000H PIC16F877A
« Respuesta #1 en: 22 de Noviembre de 2004, 20:09:00 »
Hola pepocor..

Pon el mensaje en el subforo "programadores".. alli seguro te ayudarán con tu problema.. si lo expones aca depronto se pierde tu mensaje. ya que este subforo se dedica a otra cosa. Sonrisa Gigante

Saludos


 

anything