TODOPIC

FORO TÉCNICO => Foro Técnico => Mensaje iniciado por: jfmateos2 en 18 de Agosto de 2006, 11:27:01

Título: Problema con backlight de LCD
Publicado por: jfmateos2 en 18 de Agosto de 2006, 11:27:01
Hola,

He comprado un LCD 16x2 verde con backlight en Futurlec (C1602-1). El problema que estoy experimentando es que al activar el backlight, transcurridos unos segundos, la iluminación empieza a parpadear, y un poco después se borran todos los caracteres del LCD. Parece que fuera un problema de sobrecalentamiento.

Actualmente estoy conectando el pin 15 a +5 y el 16 a tierra. He probado introduciendo resistencias entre +5 y el pin 15.
Con una resistencia de 100R la retroiluminación apenas se enciende. Con una resistencia de 10R, se enciende bien, pero transcurridos unos minutos vuelve a producirse el mismo fallo.

En el datasheet del LCD no encuentro nada al respecto.

¿Alguna idea?

Gracias
Título: Re: Problema con backlight de LCD
Publicado por: BrunoF en 18 de Agosto de 2006, 12:21:26
Hola.
¿Con cuantos V estás alimentando el circuito?
El backlight generalmente trabaja con 4.5V maximo. 4.2V mejor aún.
Lo que se hace normalmente es poner un potenciometro de 10K como divisor de voltaje en el pin 15 del LCD(seria el pin de alimentacion + del backlight)

        pin15
           !
           !
           !
 5V---~~~----oV
         10K

Anda variandolo.
Otros LCD trabajan con su alimentacion  por debajo de los 5v. Por lo tanto podrias poner otro potenciometro de 10K con la misma logica en el pin 2(Vdd).
El pin3 es el de contraste. asegurate que estes enviando el voltaje bien, sino puede que no veas bien los caracteres.
Saludos.
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 18 de Agosto de 2006, 12:39:17
Gracias BrunoF.

Lo primero que hice fue probar con un pot de 10K, pues en otro hilo del foro encontré un mensaje tuyo aconsejando eso mismo, pero la retroiluminación sólo se activaba llevando el potenciómetro al extremo.

He seguido haciendo pruebas y parece que el problema se encuentra en que estoy usando un 7805 para rebajar la tensión de alimentación de 14V a 5V; esto provoca un calentamiento considerable del 7805 incluso cuando no está conectada la retroiluminación. Al conectar la retroiluminación, el calentamiento del 7805 se dispara y creo que empieza a fallar.

De momento lo he solucionado alimientando la retroiluminación directamente desde los 14V (antes del regulador 7805) a través de una resistencia de 10R y 1W (no tenía otra más apropiada).

En cualquier caso ¿saben de algún modo para bajar de 14V a 5V sin tanta disipación?

Gracias
Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 18 de Agosto de 2006, 19:58:42
Hola BrunoF, ¿un potenciómetro de 10K para ese uso? mmmmmmm, yo pondría uno de 10 o 20 ohm, andaría más cercano a lo que realmente necesita, pero para ser más realista no usaría un potenciómetro, usaría un diodo en conexión directa, con lo que conseguiré una caida de tensión de +/-0.7V que es lo que necesita el backlight.

Un saludo.

Atte. CARLOS.
Título: Re: Problema con backlight de LCD
Publicado por: xocas en 19 de Agosto de 2006, 09:48:58
hola

perdonar la intromision porque a lo mejor estoy diciendo una autentica tonteria...

he leido hace poco algo sobre como calcular la disipacion del transistor de salida de una fuente de alimentacion, y si no recuerdo mal -cito de memoria- era algo asi: (tension de entrada - tension de salida) * corriente de salida. por ejemplo para una salida de 5v y 1.5a con una tension de entrada de 14v nos daria (14 - 5) * 1.5 = 13.5w de potencia; sin embargo, si reducimos la tension de entrada a por ejemplo 9v tras hacer los calculos nos quedaria en 6w... menos de la mitad.

¿esto es asi? y ¿se puede aplicar al 7805? si se te calienta ya el 7805 sin lcd creo que la solucion pasara por tomar la tension para el backlight antes de que pase por este porque segun tengo entendido cuando hay una sobrecarga a su salida se desconecta (entrega 0v) para protegerse.

un saludo
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 19 de Agosto de 2006, 09:59:43
Hola xocas:

Efectivamente he conectado el backlight delante del 78T05 y, en principio, me pareció que el problema estaba resuleto.

Sin embargo, no es así; sólo tarda más en presentarse (ahora, transcurridos unos 15 minutos, observo que la tensión suministrada por el 78T05 empieza a oscilar, y cuando roza los 4.5V provoca el fallo del PIC).

El circuito cosume unos 250mA y el 78T05 recibe a la entrada 15V. Según tu fórmula (creo que yo también la he visto en alguna respuesta de Chaly) sería (15-5)*0.25=2.5 W.

¿Acaso no admite esta disipación un 78T05? En el datasheet no lo veo claro porque dice algo de potencia máxima de disipación 30W, pero luego comenta algo de switching.

Si no me vale un 78T05 ¿qué alternativas tengo?
¿Cómo puedo extraer 250mA a 5V de un modo estable de una fuente de 15V?
Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 19 de Agosto de 2006, 10:13:53
Hola jfmateos2, ponle un pequeño disipador al 78T05 que debería funcionar bien, si ya no lo hace y estas seguro que no hay algun capacitor malo o un corto, tíralo porque esta fallado, el 78T05 soporta una salida de asta 3A y yo e realizado circuitos similares en características usando un 7805 de 1A si disipador y funcionan bien ahunque calientan de lo lindo  :mrgreen:.

Entonces tienes 2 opciones, que caliente por falta de disipación o que este fallado.

Un saludo.

Atte. CARLOS.
Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 19 de Agosto de 2006, 10:18:35
A, me e olvidado de decirte que los 30W que soporta de disipación son con un muy buen disipador, ya que sin este tandrás fuegos artificiales  :D  :D

Un saludo.
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 19 de Agosto de 2006, 10:22:05
Gracias Chaly, ya probé lo del disipador y aguanta más o menos lo mismo. Voy a sustituir el 78T05 por otro por si está defectuoso, y si no, probaré con los condensadores.

También estoy mirando los conversores DC-DC stepdown, pues lei en un mensaje tuyo algo sobre ellos, pero no soy capaz de elegir el apropiado para mi caso (parece que están más pensados para alimentación mediante baterías).
Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 19 de Agosto de 2006, 10:27:06
Hola jfmateos2, los conversores stepdown estan pensado para equipos portatiles que necesiten un buen rendimiento de sus baterias, si este no es tu caso te recomendaría que sigas intentando con el 7805, ya que los otros son más complejos y costosos.

Para ser realistas, el 7805 debería funcionar muy bien.

Un saludo.

Atte. CARLOS.
Título: Re: Problema con backlight de LCD
Publicado por: xocas en 19 de Agosto de 2006, 10:56:06
hola

vaya, os dejo un momento para comer y ya teneis cuatro soluciones al canto...

crei que te referias a un 7805 que soporta hasta 1A con lo cual irias sobrado pero es que ademas es un 78T05 que es de 3A (mira por donde no sabia de su existencia, acabo de revisar su hoja de caracteristicas) con lo cual creo que no hay nada que añadir a lo dicho por Chaly29.

un saludo a ambos
Título: Re: Problema con backlight de LCD
Publicado por: xocas en 19 de Agosto de 2006, 11:00:47
por cierto Chaly...

¿la formula citada anteriormente se puede aplicar tambien en el caso del 7805? no termino de entender este punto en la hoja de caracteristicas...

gracias
Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 19 de Agosto de 2006, 11:17:53
Hola xocas06, si, las formulas citadas estan correctas y son perfectamente aplicables a los reguladores integrados como en este caso.

Un saludo.

Atte. CARLOS.
Título: Re: Problema con backlight de LCD
Publicado por: xocas en 19 de Agosto de 2006, 11:29:35
pues muchas gracias... y un saludo
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 19 de Agosto de 2006, 11:33:09
He cambiado el 78t05 y sigue fallando. Lo tengo instalado como dice en la hoja de datos, con un condensador de 0,1 uF a la salida y otro de 0,33 uF a la entrada. Lo único que se me ocurre es que el condensador que estoy utilizando no sea de 0,33 uF o que no soporte 15V. Les pongo una foto.
(http://img147.imageshack.us/img147/6323/conden33gm7.th.jpg) (http://img147.imageshack.us/my.php?image=conden33gm7.jpg)
Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 19 de Agosto de 2006, 12:08:33
Hola jfmateos2, sí, los capacitores son de los valores que comentas, pero si solo usas esos 2 capacitores para realizar todo el filtrado te comento que te estás quedando corto, en la entrada aparte del capacitor de 0.33uF necesitas colocar uno de 1000uF 35V electrolítico (como mínimo), y en la salida ademas del de 0.1uF otro de 100uF 16V electrolítico.

Espero este sea el problema y lo puedas solucionar.

Un saludo.

Atte. CARLOS.
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 19 de Agosto de 2006, 12:43:16
Chaaly, he puesto esos dos condensadores adicionales (1000uF y 100uF) y sigue fallando igual. El KA78T05 se calienta de un modo increíble, hasta tal punto, que sus protecciones se activan y deja de funcionar.

Raro, raro, muy raro...

No se me ocurre qué más probar. El lunes iré a comprar 78T05 de otra marca por si fuera un defecto de esta partida.

Gracias a todos por su ayuda y, si se les ocurre algo,...
Título: Re: Problema con backlight de LCD
Publicado por: xocas en 19 de Agosto de 2006, 12:46:49
hola

aparentemente son condensadores de 334kf/63v

parto de la idea de que los 14v que le llegan estan debidamente filtrados -no me lo tomes a mal, es un pensamiento en voz alta-.  aun asi yo añadiria un condensador electrolitico de entre 10uf y 47uf a la salida y comprobaria que el condensador de entrada fuera al menos de 1000uf...

como mis conocimientos no van muy alla, te dire los pasos que seguiria para intentar dar con el problema:

¿los 250mA de los que hablas son en base a calculos aproximados o los has medido?. no deja de ser un consumo considerable para un circuito basado en pic
¿que sucede si desconecto el lcd?
¿que sucede si alimento unicamente el lcd y desconecto el resto del circuito?
¿se calienta el pic? ¿que sucede si lo retiro del zocalo, en caso de estar en zocalo?
¿tengo en algun punto del circuito un divisor de tension con valores de resistencia muy bajos?
¿si hay algun condensador electrolitico en el circuito esta su parte superior abombada? seria signo de posible fuga

y esto es lo que se me ocurre en principio, espero que te sirva de algo

un saludo

pd:vaya ahora veo la respuesta de Chaly, que siempre esta ahi aunque alguien se rio de mi cuando lo comente en otro subforo...
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 19 de Agosto de 2006, 13:13:08
Olvidé mencionar que al 78T05 ni siquiera llegan 15V, sino aproximadamente 13, pues antes de la entrada del 78t05 tengo un puente rectificador de diodos en el que se pierden unos 2 V. Este puente admite 1.5 A. No sé si esto puede influir en que se caliente tantisimo.
El circuito está compuesto por un PIC, unos 18 CI lógicos del tipo 74LS, y el LCD.
Joaquí, iré probando el resto de tus propuestas.
Título: Re: Problema con backlight de LCD
Publicado por: xocas en 19 de Agosto de 2006, 13:42:42
hola

te comento que en mi pequeño entrenador tengo una fuente basicamente igual a la que apunta RedPic aqui: http://www.todopic.com.ar/foros/index.php?topic=13389.0 y con un consumo de unos 100-150mA el 7805 (de 1A y sin disipador) permanece frio aun despues de un buen rato de funcionamiento...

pd: ten siempre un repuesto de 7805, antes o despues lo necesitaras.

salu2
Título: Re: Problema con backlight de LCD
Publicado por: jfmateos2 en 19 de Agosto de 2006, 14:02:10
Gracias Joaquín.

Mi circuito va a ir instalado en un automóvil y por eso la entrada va a ser 15V aprox.

Para las pruebas estoy utilizando una fuente de laboratorio, que es la que indica que el consumo son 250 mA constantes. Al cabo de un rato este consumo empieza a descender hasta hacerse 0.

El PIC está siempre frío.

Si desconecto el LCD el consumo apenas varía.

Ahora estoy haciendo otra prueba alimentando con 12,5V y lleva casi una hora funcionando ininterrumpidamente, pero el 78T05 sigue calentándose a rabiar.

Todo esto me parece rarísimo. Es la primera vez que uso un 78T05, porque hasta ahora me había apañado con el 78L05 en todos mis proyectos (menos de 100mA).

Hasta el lunes no podré probar con un 78T05 de otro fabricante. Voy a dejarlo funcionando a 12,5V para ver cuánto aguanta.

Muchas gracias por todo.

Título: Re: Problema con backlight de LCD
Publicado por: Chaly29 en 19 de Agosto de 2006, 14:12:11
Hola jfmateos2, ¿estas seguro que consume 250mA y la fuente esta indicando lo correcto?, a mi los cálculos me dicen que los 18 IC, más el pic y el display es vastante más de 250mA, ¿por que no lo mides con un multímetro?

¿Que disipador as usado?
¿De que tamaño?
¿Usaste grasa siliconada para aumentar la conducción térmica?
¿As probado de desconectar todo el circuito y ver si el 78T05 sigue calentando?

Un saludo y espero tus respuestas.

Atte. CARLOS.