Autor Tema: sondas de temperatura RUIDOS en las lecturas.  (Leído 2244 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado danone

  • PIC12
  • **
  • Mensajes: 78
sondas de temperatura RUIDOS en las lecturas.
« en: 15 de Junio de 2006, 06:29:14 »
Hola muy buenas, pues a ver hace tiempo gracias a la ayuda de mucha gente estoy llevando como puedo un circuitillo que usa un pic 16f876, un display lcd y 4 sondas de temperatura tmp36 su fabricante es analog devices, he usado estas y no la tipica lm35 ya que estas entregan siempre valores positivos incluso para temperaturas negativas... es decir:

a una temperatura de 25ºc la sonda entrega 750mV.
a una temperatura de 0ºc la sonda entraga 500mV.
-25ºc la sonda entraga 250mV.

Bueno hasta ahi todo bien, el codigo ya lo he apañado en c, y funciona ya bien, el procedimiento para leer las temperaturas, es que las leo 5 veces con intervalos de unos 200ms y luego hago la media y esa es la temperatura que saco por el display para cada sonda con esto arregle bastante los problemas, pero aun sigo teniendo cambios muy bruscos en los decimales.
He conectado a todos los integrados condensadores de desacoplo de 100nF, tambien he usado dos lm358  , es decir dos amplificadores operacionales para cada sonda, con esto ya solucione bastante las lecturas pero aun asi ya os digo que sigo teniendo ruidos,las sondas las tengo aun montadas en la protoboard, para el montaje final usare cable apantallado.

En el circuito tengo un bootloader para pasarle las modicaciones al pic, pero he notado que sio cuando uso las sondas le kito la alimentacion al bootloader tb quito mucho ruido y las sondas son mas precisas y hacen menos cambios bruscos.

el circuito que toy usando es el siguiente, solo que es para 4 sondas y no para dos como he dibujado en el circuito, a ver que me recomendais.

y un video para que os hagais una idea: www.adri.no-ip.org/video.avi


Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #1 en: 15 de Junio de 2006, 07:08:26 »
Hola danone, creo que deberías colocar en serie con el Vout del sensor una resistencia de 1K y desde la entrada no inversora del operacional un condensador a masa de 0.1 uF, con esto deberías solucionar el problema, por supuesto esta resistencia y condensador lo más proximo a las entradas del operacional.

Un saludo.

Atte. CARLOS.
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado danone

  • PIC12
  • **
  • Mensajes: 78
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #2 en: 15 de Junio de 2006, 07:57:54 »
en primer lugar, muchas gracias por contestar, pues las resistencias ya las tenia puestas lo siento se me olvido ponerlas en el esquema, pero en vez de 1k las puse de 750ohm pq en el datasheet de la sonda recomendaban ese tamaño, lo del condensador tb lo puse y no me soluciono mucho la verdad.... hace mas o menos lo mismo.

Tambien es que me estoy obsesionando un poco pq nunca las dos sondas en el mismo sitio me miden lo mismo, asi que yo ya no se si es ke ese es el margen de error que tienen las sondas que creo que pone que es de +/- 1 ºc o es problemas de ruido :(
saludos.
« Última modificación: 15 de Junio de 2006, 08:21:19 por danone »

Desconectado JavisusII

  • PIC12
  • **
  • Mensajes: 79
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #3 en: 15 de Junio de 2006, 19:11:43 »
Buenas danone

Un par de cosas:

1- El filtro rc que comenta Chaly29 es vital, je je pon tu equipo en un entorno industrial ,enciende el osciloscopio y me lo cuentas. Osease para ese ruidillo que comentas. :lol:
2- ¿Por qué no amplificas la señal?, no lo acabo de entender. :(
3- Entre dos sondas puede haber una pequeña variación, es posible, consulta el datasheet.
4- es de suponer que la alimentación es limpia no?
5- realiza el esquema definitivo y lo pones , creo intuir ciertos fallos.

Xavi (Barcelona)

Desconectado GustavoT

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 102
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #4 en: 20 de Junio de 2006, 20:21:43 »
Lo mejor en esos casos es que el micro haga  un promedio, tomas 10 o 20 o mas valores, los sumas y los divides, de esta formas eliminas en gran medida los ruidos y como la variaciones de temperatura son lentas, no afectan en la respuesta dinámica de tu medición.

Con eso solucione muchos inconvenientes de ruido, simple y elegante.

Otra cosa que deberías tener en cuenta es que el display consume mucho, y seria bueno que tuviera su propio regulador.

Atte Gustavo T
« Última modificación: 20 de Junio de 2006, 20:25:39 por GustavoT »
Hay dos cosas infinitas: el Universo y la estupidez humana. Y del Universo no estoy seguro.   Albert Einstein

Desconectado danone

  • PIC12
  • **
  • Mensajes: 78
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #5 en: 30 de Junio de 2006, 10:08:23 »
he hecho lo de los condensadores, y la resistencia de 1 k en serie y demas, y consigo valores muy estables... y con una variacion de unas 4 decimas o algo asi estoy satisfecho, el problema ha venido que todo eso lo tenia montado con cables
y protoboard con cables de estos de conexiones e iba de lujo, es soldarla a un cable normal
de unos 30 cm.. y de menos seccion y ya empieza de nuevo los problemas de valores extraños....

me estan volviendo loco estas sondas... con las sondas digitales pasa igual? o van mejor? lo digo pq me han llegao hoy unos samples de las ds1821.

saludos.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #6 en: 30 de Junio de 2006, 14:00:08 »
Hola danone, reemplaza el cable de conexion por un cable apantallado (mallado) este deberia ser mejor, con las sondas diguitales ese problema no se presenta ya que estas sondas envian los datos de manera digital y no analoga.

Un saludo.

Atte. CARLOS.
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado danone

  • PIC12
  • **
  • Mensajes: 78
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #7 en: 01 de Julio de 2006, 21:21:30 »
gracias por contestar charly, pues mira te comento he probado con varios cables, usando tb cable apantallado y no he resuelto el problema, principalmente me he dado cuenta de que el problema es cuando uso un cable que supera una cierta longitud , si el cable es mas o menos corto... no me sucede ese problema si ya se alarga un poco puff... se welve loco dando valores etxraños.

La verdad creo q seria interesante cacharrear un poco con la digital a ver si tengo menos problemas que con la analogica, pero es que no he encontrado aun la manera de leerla en C la ds1821.

muchas gracias .


Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: sondas de temperatura RUIDOS en las lecturas.
« Respuesta #8 en: 01 de Julio de 2006, 23:46:42 »
Hola danone, para leer las DS1821 en C deberás crear una librería, lo cual no tengo ni idea de como hacer.

Otra opción que tienes para sacar el ruido totalmente de la entrada es usar una entrada con operacionales que sea balanceada, en la mayoría de los circuitos de este tipo que deben sensar niveles de corriente muy bajos y a distancia usan entradas balanceadas con lo que se logra discriminar casi totalmente el ruido producido por las interferencias.

Espero te sea de ayuda.

Un saludo.

Atte. CARLOS.
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.