Autor Tema: Problema con backlight de LCD  (Leído 7640 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: Problema con backlight de LCD
« Respuesta #15 en: 19 de Agosto de 2006, 12:08:33 »
Hola jfmateos2, sí, los capacitores son de los valores que comentas, pero si solo usas esos 2 capacitores para realizar todo el filtrado te comento que te estás quedando corto, en la entrada aparte del capacitor de 0.33uF necesitas colocar uno de 1000uF 35V electrolítico (como mínimo), y en la salida ademas del de 0.1uF otro de 100uF 16V electrolítico.

Espero este sea el problema y lo puedas solucionar.

Un saludo.

Atte. CARLOS.
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado jfmateos2

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3145
Re: Problema con backlight de LCD
« Respuesta #16 en: 19 de Agosto de 2006, 12:43:16 »
Chaaly, he puesto esos dos condensadores adicionales (1000uF y 100uF) y sigue fallando igual. El KA78T05 se calienta de un modo increíble, hasta tal punto, que sus protecciones se activan y deja de funcionar.

Raro, raro, muy raro...

No se me ocurre qué más probar. El lunes iré a comprar 78T05 de otra marca por si fuera un defecto de esta partida.

Gracias a todos por su ayuda y, si se les ocurre algo,...

Desconectado xocas

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 2292
Re: Problema con backlight de LCD
« Respuesta #17 en: 19 de Agosto de 2006, 12:46:49 »
hola

aparentemente son condensadores de 334kf/63v

parto de la idea de que los 14v que le llegan estan debidamente filtrados -no me lo tomes a mal, es un pensamiento en voz alta-.  aun asi yo añadiria un condensador electrolitico de entre 10uf y 47uf a la salida y comprobaria que el condensador de entrada fuera al menos de 1000uf...

como mis conocimientos no van muy alla, te dire los pasos que seguiria para intentar dar con el problema:

¿los 250mA de los que hablas son en base a calculos aproximados o los has medido?. no deja de ser un consumo considerable para un circuito basado en pic
¿que sucede si desconecto el lcd?
¿que sucede si alimento unicamente el lcd y desconecto el resto del circuito?
¿se calienta el pic? ¿que sucede si lo retiro del zocalo, en caso de estar en zocalo?
¿tengo en algun punto del circuito un divisor de tension con valores de resistencia muy bajos?
¿si hay algun condensador electrolitico en el circuito esta su parte superior abombada? seria signo de posible fuga

y esto es lo que se me ocurre en principio, espero que te sirva de algo

un saludo

pd:vaya ahora veo la respuesta de Chaly, que siempre esta ahi aunque alguien se rio de mi cuando lo comente en otro subforo...

Desconectado jfmateos2

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3145
Re: Problema con backlight de LCD
« Respuesta #18 en: 19 de Agosto de 2006, 13:13:08 »
Olvidé mencionar que al 78T05 ni siquiera llegan 15V, sino aproximadamente 13, pues antes de la entrada del 78t05 tengo un puente rectificador de diodos en el que se pierden unos 2 V. Este puente admite 1.5 A. No sé si esto puede influir en que se caliente tantisimo.
El circuito está compuesto por un PIC, unos 18 CI lógicos del tipo 74LS, y el LCD.
Joaquí, iré probando el resto de tus propuestas.

Desconectado xocas

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 2292
Re: Problema con backlight de LCD
« Respuesta #19 en: 19 de Agosto de 2006, 13:42:42 »
hola

te comento que en mi pequeño entrenador tengo una fuente basicamente igual a la que apunta RedPic aqui: http://www.todopic.com.ar/foros/index.php?topic=13389.0 y con un consumo de unos 100-150mA el 7805 (de 1A y sin disipador) permanece frio aun despues de un buen rato de funcionamiento...

pd: ten siempre un repuesto de 7805, antes o despues lo necesitaras.

salu2

Desconectado jfmateos2

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3145
Re: Problema con backlight de LCD
« Respuesta #20 en: 19 de Agosto de 2006, 14:02:10 »
Gracias Joaquín.

Mi circuito va a ir instalado en un automóvil y por eso la entrada va a ser 15V aprox.

Para las pruebas estoy utilizando una fuente de laboratorio, que es la que indica que el consumo son 250 mA constantes. Al cabo de un rato este consumo empieza a descender hasta hacerse 0.

El PIC está siempre frío.

Si desconecto el LCD el consumo apenas varía.

Ahora estoy haciendo otra prueba alimentando con 12,5V y lleva casi una hora funcionando ininterrumpidamente, pero el 78T05 sigue calentándose a rabiar.

Todo esto me parece rarísimo. Es la primera vez que uso un 78T05, porque hasta ahora me había apañado con el 78L05 en todos mis proyectos (menos de 100mA).

Hasta el lunes no podré probar con un 78T05 de otro fabricante. Voy a dejarlo funcionando a 12,5V para ver cuánto aguanta.

Muchas gracias por todo.


Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: Problema con backlight de LCD
« Respuesta #21 en: 19 de Agosto de 2006, 14:12:11 »
Hola jfmateos2, ¿estas seguro que consume 250mA y la fuente esta indicando lo correcto?, a mi los cálculos me dicen que los 18 IC, más el pic y el display es vastante más de 250mA, ¿por que no lo mides con un multímetro?

¿Que disipador as usado?
¿De que tamaño?
¿Usaste grasa siliconada para aumentar la conducción térmica?
¿As probado de desconectar todo el circuito y ver si el 78T05 sigue calentando?

Un saludo y espero tus respuestas.

Atte. CARLOS.
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.


 

anything