Autor Tema: Comunicacion pic a pic con modulos TM1000-1 y RM1SG  (Leído 3422 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Eyedol

  • PIC16
  • ***
  • Mensajes: 129
Comunicacion pic a pic con modulos TM1000-1 y RM1SG
« en: 02 de Abril de 2008, 01:46:00 »
Saudos amigos del foro. Se que hay varias personas que han tenido problemas con modulos rf. incluso yo he utilizado otros modulos RF (tws-434 y rws-434) pero esta vez necesito mayor distancia y estoy utilizando un modulo llamado TM1000 que segun el fabricante comunica 1000 metros. Estoy utilizando dos PIC16f88 que se comunican por hardware USART.

 he probado la comunicacion con cables y funciona muy bien pero al conectar los modulos mirando en el osciloscopio no recivo exactamente lo que envio no entiendo que sucede. ademas esta claro que los micros no se comunican.

Con Respecto al Funcionamiento de los modulos lo que he observado es:
Por ejemplo si manualmente genero pulsos de 0 a 5 v los recivo perfectamente en el otro modulo a la misma frecuencia.

Hay algo que me produce curiosidad y es que si mantengo en 5v la entrada del transmisor esta permanece en 5v durante un cuarto de segundo o algo asi luego mientras en el transmisor tengo 5v el receptor se va a cero.  Adjunto les dejo las datasheet del transmisor y

Desconectado jfh900

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3595
Re: Comunicacion pic a pic con modulos TM1000-1 y RM1SG
« Respuesta #1 en: 02 de Abril de 2008, 06:03:22 »
Este tipo de transmisores no puede codificar una señal continua, solo admite impulsos.

Un saludo
* Cuando hables, procura que tus palabras sean mejores que el silencio.
* 'Todos somos ignorantes, lo que ocurre es que no todos ignoramos las mismas cosas.' Albert Einstein.
* No hay nada peor que un experto para evitar el progreso en un campo
* "La vida es como una novela. No importa que sea larga, sino que esté bien narrada" Seneca
* La vida no se vive por las veces que respiras, sino por los momentos que dejan sin aliento.
* Dios dijo: ∇·E=ρ/ε0 ; ∇·B=0 ; ∇xE=-dB/dt ; ∇xB= μ0ε0dE/dt..y la luz se hizo..!!..

Desde España Jesús

Desconectado Eyedol

  • PIC16
  • ***
  • Mensajes: 129
Re: Comunicacion pic a pic con modulos TM1000-1 y RM1SG
« Respuesta #2 en: 02 de Abril de 2008, 12:02:46 »
Ok amigo gracias eso es con respecto a dejarlo en un valor. Pero que sucede con la señal Serial ya que estoy Comunicando dos pic con comunicacion serial asincrona 8N1 a 1200kbps como indica en el digrama que he subido. solo que en ves de ser con un cable lo hago con los modulos.



Desconectado Eyedol

  • PIC16
  • ***
  • Mensajes: 129
Re: Comunicacion pic a pic con modulos TM1000-1 y RM1SG
« Respuesta #3 en: 02 de Abril de 2008, 15:48:06 »
En este momento he aclarado muchas dudas con el port de ALQUIMUS aqui:http://www.todopic.com.ar/foros/index.php?topic=18606.0 y he decidido implementar mi comunicacion con modulacion de ancho de pulso....

A una frecuencia de unos 100HZ estoy programando en PBP y simulando en proteus. La simulacion de me va excelente pero cuando monto en el protoboard el PIC16F88 con un relog de 12MHZ pues no le da la gana de generar ningun pulso por el RB0...ni por el RB3 lo estoy viendo con un osciloscopio... Alguien sabra porque esto? este mismo micro lo usaba con la usart y funcionaba perfecto.... aqui el codigo del transmisor?

ANSEL = %00000000 
CMCON = $07 
define osc 12


manda:
HPWM 1,200,100
pause 1000
HPWM 1,10,100
pause 1000
goto manda
« Última modificación: 02 de Abril de 2008, 15:50:21 por Eyedol »


 

anything