Autor Tema: Problemas con el oscilador  (Leído 4175 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado cucu

  • PIC12
  • **
  • Mensajes: 74
Problemas con el oscilador
« en: 20 de Enero de 2009, 10:48:05 »
hola, estoy realizando mi propio circuito para mi pic, y tengo un problema con el oscilador, es una de dos opciones:

O no hace bien contacto con las patillas OSC1 y OSC2 de mi pic o no funciona bien. Por lo que parece no puedo ver las señales de sus patillas sin que esté conectado el pic, ¿eso es así?

Sería  bueno comprobar su funcionamiento sin pic para ver que sucede.

Otra cosa, ¿qué significa que el oscilador sea "populate"? La traducción de la palabra a español no me ayuda...


Gracias por la ayuda.
« Última modificación: 20 de Enero de 2009, 11:18:59 por cucu »

Desconectado Javicho

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 570
Re: Problemas con el oscilador
« Respuesta #1 en: 20 de Enero de 2009, 12:21:20 »
Hola:

Uhm no recuerdo haber visto esa palabra en el datasheet, quizás stá por algún lado pero igual no se que significa. Qué pic usas?

Para ver las señales del cristal (si a eso te refieres) necesitarias un osciloscopio para que veas los 4Mhz de onda senoidal.

Si quieres probar el cristal tendrias que armarte un circuito oscilador con ese cristal y una compuerta con red RC, buscalo por la red lo vas a encontrar, hay muchos.

Antes de echarle la culpa a algo primero debes verificar cosas basicas como si al pic le llega alimentación entre sus pines Vcc y GND, MCLR en nivel alto, pines del cristal en continuidad con los pines respectivos del pic (OSCI y OSCO), haz un programa simple de parpadeo de led o un pin a una frecuencia que puedas ver su parpadeo, prueba con otro pic, prueba con otro cristal, cambia de protboard.

Bueno despues de realizar estos pasos seguro que por ahi encuentras la falla.

Javicho.

jacrmr

  • Visitante
Re: Problemas con el oscilador
« Respuesta #2 en: 20 de Enero de 2009, 15:32:41 »
Populate, que esté físicamente en el circuito, que lo coloques.

Puedes comprobar su funcionamiento sin el PIC mientras te refieras al oscilador, no al cristal, ya que no es lo mismo. El cristal que se le coloca a un PIC no es el oscilador. El oscilador lo trae interno el PIC (no me refiero al INTOSC, sino al circuito oscilador interno que permite que se use un cristal externo con el PIC) y tú sólo completas el circuito con el cristal que elijas.

Desconectado cucu

  • PIC12
  • **
  • Mensajes: 74
Re: Problemas con el oscilador
« Respuesta #3 en: 21 de Enero de 2009, 05:30:39 »
Gracias a los dos, me habeis aclarado muchas cosas.

La diferencia entre oscilador y cristal siempre me ha liado un poco, en realidad jacmrmr tiene razón, yo me refería al cristal.

Entonces, la señal de un cristal, hasta que la cierro no puedo verla, ¿no? Y OSC1 y OSC2 del pic hasta que no le ponga un cristal tampoco, ¿verdad?

Otra cosa, ¿las señales de oscilador son siempre senoidales? ¿no son cuadradas? entonces, ¿el funcionamiento se basa en V> Vh es uno y V<Vl un cero?

Aunque parece que mi error en el circuito está localizado me ayudaría mucho entenderlo bien para no volver a caer en el error. Muchas gracias.

Desconectado Javicho

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 570
Re: Problemas con el oscilador
« Respuesta #4 en: 21 de Enero de 2009, 11:51:04 »
La diferencia entre oscilador y cristal siempre me ha liado un poco, en realidad jacmrmr tiene razón, yo me refería al cristal.

Asi es y sospeché que estabas confundido con eso, por eso te hablé del cristal y de armar un circuito oscilador con el cristal que tienes, de ahi podias deducir que no es lo mismo y cuando te dije que con el osciloscopio puedes ver los 4Mhz de señal senoidal del cristal, te estaba diciendo en realidad "ojo, no vayas a pensar que la señal que veras en esos pines es cuadrada sino senoidal".

Seria interesante que nos comentes cual fue la falla en tu circuito, asi para la proxima estamos precavidos todos.

Javicho.

Desconectado cucu

  • PIC12
  • **
  • Mensajes: 74
Re: Problemas con el oscilador
« Respuesta #5 en: 22 de Enero de 2009, 05:16:04 »
El problema estaba en la alimentación, únicamente había que poner condensadores a masa a ambos lados del cristal y utilizar cada uno de las patillas como entradas OSC1 y OSC2. Me pasé complicando el circuito...

Muchas gracias por la ayuda.

Saludos


 

anything