Autor Tema: Problemas con max232  (Leído 1193 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado PabloFiscella

  • PIC16
  • ***
  • Mensajes: 154
Problemas con max232
« en: 23 de Marzo de 2006, 20:01:00 »
Hola a todos:

Tengo un problemita y no se electronica por eso acudo a la ayuda de uds.
Estoy probando o tratando de comunicar un pic con la pc.
Pero no hace absolutamente nada.
Cuando medi el voltaje que llegaba al max232 me extraño y de seguro hay algo que esta mal.
A la pata 11 le llegan -6.88 y a la 12 -8.15 esto cuanto el puerto desde el visual basic esta cerrado. Cuando ejecuto el programa y abre el puerto los voltajes llegan a -19v

La pata 1 esta conectado a un cap + y de ahi a la pata 3
La pata 2 esta conectado a un cap + y de ahi 5v
La pata 4 esta conectado a un cap + y de ahi a la pata 5
La pata 6 esta conectado a un cap - y de ahi masa
pata 14 5v y pata 13 a masa

Espero puedan ayudarme.
Saludos.
Pablo

Desconectado doppel

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 1531
RE: Problemas con max232
« Respuesta #1 en: 23 de Marzo de 2006, 22:06:00 »
Hola Pablo

con respecto al circuito te conviene mirar el datasheet del componente en este caso MAX 232 para saber sobre el circuito de aplicación!!

y te dejo un enlace para que puedas realizar pruebas! es de la página del amigo RedPic de este mismo foro!! está muy bien explicado y tb encontrarás el datasheet del componente

 suerte


ENLACE!!!!!!
" Para ser exitoso no tienes que hacer cosas extraordinarias. Haz cosas ordinarias, extraordinariamente bien "

Desconectado RedPic

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 5500
    • Picmania by Redraven
RE: Problemas con max232
« Respuesta #2 en: 24 de Marzo de 2006, 00:44:00 »
Gracias doppel por tus palabras de elogio.

Amigo Pablo, en este mismo foro tengo publicado un pequeño ejemplo donde
explico tanto el hardware necesario como el software para el  PIC en C y ASM:

Ejemplito 16F876A: Lo mínimo para comunicarnos vía RS232 Hardware y Software


Contra la estupidez los propios dioses luchan en vano. Schiller
Mi Güeb : Picmania

Desconectado PabloFiscella

  • PIC16
  • ***
  • Mensajes: 154
RE: Problemas con max232
« Respuesta #3 en: 24 de Marzo de 2006, 08:26:00 »
Mil gracias muchachos, el enlace me sirvio para darme cuenta que tenia una mala conexion del db9. Estaba usando patas 3 y 4 en lugar de 2 y 3.
Ahora funciona perfecto.

Muchas gracias.
Saludos.
Pablo

Desconectado RedPic

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 5500
    • Picmania by Redraven
RE: Problemas con max232
« Respuesta #4 en: 24 de Marzo de 2006, 08:28:00 »
Me encanta cuando las cosas terminan bien y funcionan. Soy feliz. Muchas risas Muchas risas Muchas risas
Contra la estupidez los propios dioses luchan en vano. Schiller
Mi Güeb : Picmania