Autor Tema: Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W  (Leído 4562 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #30 en: 20 de Marzo de 2021, 13:33:23 »
No tengo osciloscopio USB, el que tengo va enchufado a la red.

Entiendo, Killer, que si mi osciloscopio no estuviera conectado a Tierra no saltaría el diferencial, ¿verdad?. ¿Puedo conectarlo a una alargadera que sólo tiene 2 hilos y estaría resuelto entonces?

Respecto a las resistencias que me indicas, las he medido y aparentemente están todas bien. Doy por hecho que cuando dices R79 y R78 realmente te refieres a R79 y R80, ¿no?
He medido en el punto medio de ambas, llamado UVL, y me encuentro 104V.

Respecto a R17, también parece correcta. En este caso, en ambas patillas de la misma leo 0V.

Por último, en las tres patas de Q1 veo 0V.
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado Picuino

  • Moderador Local
  • DsPIC33
  • *****
  • Mensajes: 5615
    • Picuino
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #31 en: 20 de Marzo de 2021, 15:38:09 »
Cuidado con quitar la tierra al osciloscopio. Está ahí precisamente para protegerte ante posibles derivaciones que podrían electrocutarte.
Con el polímetro se pueden realizar muchas medidas y comprobaciones sin necesidad del osciloscopio.

Es posible que se haya quemado también el circuito IC8 (L4981A) que controla al transistor quemado Q5

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #32 en: 20 de Marzo de 2021, 15:41:16 »
¿Se te ocurre alguna manera de comprobar dicho integrado?, ¿o la única forma es sustituyéndolo por uno nuevo?
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado Picuino

  • Moderador Local
  • DsPIC33
  • *****
  • Mensajes: 5615
    • Picuino
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #33 en: 20 de Marzo de 2021, 15:51:26 »
Comprobar las tensiones con el polímetro. Alimentación y resto de pines. Según la función de cada pin, la tensión que se puede esperar de él.

https://www.st.com/resource/en/datasheet/l4981.pdf

EDITO:

En especial yo comprobaría las tensiones de alimentación, la tensión de referencia (pin 11) y la de output (pin 20).

 

* potencia.png
(140.6 kB, 3792x2592 - visto 208 veces)
« Última modificación: 20 de Marzo de 2021, 15:55:12 por Picuino »

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #34 en: 20 de Marzo de 2021, 16:17:21 »
Están todas mal, miden 0.1V, excepto alguna que sube a 0.9V.

Lo desoldaré y compraré uno, a ver si hay suerte.
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8136
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #35 en: 20 de Marzo de 2021, 18:35:14 »
Entiendo, Killer, que si mi osciloscopio no estuviera conectado a Tierra no saltaría el diferencial, ¿verdad?. ¿Puedo conectarlo a una alargadera que sólo tiene 2 hilos y estaría resuelto entonces?

Exacto, al menos desde que toque por primera vez un osciloscopio, nunca supe de la existencia de un transformador de aislación. Siempre se uso así el osciloscopio en donde estuve (escuela, universidad, mi casa y hasta algunos lugares donde reparan). y estoy hablando de casi ya 15 años o mas. Los transformadores de aislación son muy raros acá, es decir aplicaciones muy puntuales.

Respecto a las resistencias que me indicas, las he medido y aparentemente están todas bien. Doy por hecho que cuando dices R79 y R78 realmente te refieres a R79 y R80, ¿no?
He medido en el punto medio de ambas, llamado UVL, y me encuentro 104V.
Si un error mio, eran las 7AM y hacia media hora que me levantaba para ir al trabajo.

Respecto a R17, también parece correcta. En este caso, en ambas patillas de la misma leo 0V.

Por último, en las tres patas de Q1 veo 0V.

Respecto a estos 2 puntos....
R17 no vas a tener tensión si la tensión de entrada a la fuente switching principal esta bajo.. Por lo tanto no esperes ver tension ahi por ahora.

Una posibilidad es que el L4981 este quemado. Pero también tenes que saber que hay formas de "inhabilitar" el integrado a que funcione.
Y una de ellas es haciendo un pull-down en el pin SS (Soft-Start) el cual es controlado por Q1.

Por las tensiones que me contas, no creo que Q1 este conduciendo, ya que en su base no tiene absolutamente nada. Pero en el colector deberías tener la tensión que esta en el capacitor de soft-start o C117.
En VCC del integrado deberías tener como mínimo 15.5V para arriba, debido a que este es el limite que hace el turn-on del integrado sin ninguna red divisiva sobre el pin de UVLO. Lo podes medir desde el zener D66.
También podrías medir la caída de corriente en las resistencia R79 o R80, para tener una idea de la corriente que esta pasando por ese lugar. (Como para detectar si hay algún consumo grande que indique que esta quemado, o si hay algun otro problema en esa linea (diodo zener o transistores de la parte de UVL Q6 y Q10 ) Ya que si esos transistores están en corto, no vas a tener un cortocircuito debido a todas las resistencias.

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #36 en: 21 de Marzo de 2021, 03:22:59 »
En VCC del integrado deberías tener como mínimo 15.5V para arriba, debido a que este es el limite que hace el turn-on del integrado sin ninguna red divisiva sobre el pin de UVLO. Lo podes medir desde el zener D66.
También podrías medir la caída de corriente en las resistencia R79 o R80, para tener una idea de la corriente que esta pasando por ese lugar. (Como para detectar si hay algún consumo grande que indique que esta quemado, o si hay algun otro problema en esa linea (diodo zener o transistores de la parte de UVL Q6 y Q10 ) Ya que si esos transistores están en corto, no vas a tener un cortocircuito debido a todas las resistencias.
En VCC tengo 0V.
La caída en las resistencias R79/R80 es de 275V a 0V. En el punto medio de ambas (UVL) mido 104V.
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8136
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #37 en: 21 de Marzo de 2021, 08:43:11 »
Por lo que comentas, y teniendo D68 sano. Puede ser el integrado o el Zener que estén en corto.


Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #38 en: 21 de Marzo de 2021, 13:29:14 »
Pues parece que el zener D66 estaba cortocircuitado, de hecho se observa en su superficie una quemadura.


Lo he sustituido por un zener de 22V y ahora me encuentro las siguientes tensiones en el integrado:
Pin  1PGND0V
Pin  2IPK0.3V
Pin  3OVP1V
Pin  4IAC1V
Pin  5CA-Out0.33V
Pin  6LFF0.33V
Pin  7VRMS0.35V
Pin  8MULT-OUT0V
Pin  9ISENSE0.32V
Pin 10SGND0V
Pin 11VREF0.33V
Pin 12SS0.33V
Pin 13VA-OUT0.33V
Pin 14VFEED1V
Pin 15P-UVLO0.32V
Pin 16SYNC0.32V
Pin 17ROSC0.32V
Pin 18COSC0.33V
Pin 19VCC0.46V
Pin 20GDRV0.33V
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #39 en: 21 de Marzo de 2021, 13:49:15 »
Nuevo dato: he sacado el integrado L4981A y al enchufar la fuente para medir tensiones ha quemado el fusible.

Me temo que no podré volver a conectarla hasta que me lleguen los L4981A que he comprado.
« Última modificación: 21 de Marzo de 2021, 14:06:17 por Nocturno »
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8136
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #40 en: 21 de Marzo de 2021, 19:11:32 »
Antes de sustituir el L4981 nuevo, revisa los demás componentes.
Ya que hay algo en corto circuito ahora.

De nuevo el zener D66. Ya que al no tener consumo, toda la corriente paso por el zener y seguramente puff..

Y para proteccion del nuevo L4981 los zener y diodos de la salida (los que van al mosfet quemado Q5) D52, D53 y D57 por las dudas...
Tambien ya que estamos revisa el diodo del snubber de Q5 que seria D50
« Última modificación: 21 de Marzo de 2021, 19:15:43 por KILLERJC »

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #41 en: 22 de Marzo de 2021, 13:18:54 »
He revisado los diodos que mencionas sacándolos de la PCB, y muchos otros directamente con el polímetro en el mismo circuito, de lo que concluyo:
  • D66 estaba en corto, lo cambié, y tras la rotura del fusible sigue funcionando correctamente
  • D52 estaba en corto, sustituido
  • D53 funciona correctamente
  • D50 funciona correctamente
  • D57 estaba en corto, lo he cambiado por un BAV99 (la diferencia es que el BAS21 aguanta 250V, y el que yo he puesto sólo 100V, pero es lo que tenía)
  • no he encontrado más diodos estropeados

¿Se os ocurre alguna otra comprobación a hacer antes de que me lleguen los integrados?
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8136
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #42 en: 24 de Marzo de 2021, 18:26:41 »
No se me ocurre otra cosa, lo que se podria hacer es revisar que la bobina L3 no este en corto, midiendo inductancia ya que resistencia seguramente es poca. Pero si ademas da poca inductancia... Podría ser un corto.

Lo demas queda siempre controlar los semiconductores que veas.

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #43 en: 25 de Marzo de 2021, 02:50:14 »
Estoy comprobando todos los transistores y diodos, miraré también esa bobina. Aún tengo dos semanas por delante para recibir los integrados, así que me dará tiempo a revisar todo  :D
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17909
    • MicroPIC
Re:Reparación de una fuente de alimentación TTi EX354RD DUAL POWER SUPPLY 280W
« Respuesta #44 en: 25 de Marzo de 2021, 13:23:55 »
Ya he revisado todos los semiconductores de la placa y no he encontrado más fallos. La bobina L3 tampoco falla.
A esperar los chips. Seguiré informando.
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ