Autor Tema: ¿PUEDE SER QUE NO PUEDA PRENDER UN LED?  (Leído 2022 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado GUEORK

  • PIC10
  • *
  • Mensajes: 20
¿PUEDE SER QUE NO PUEDA PRENDER UN LED?
« en: 10 de Octubre de 2004, 13:20:00 »
Estuve haciendo unos circuitos con ISIS (los primeros) y no me simulan. Fuí para atrás e hice un circuito con una batería de 12V una resistencia y un led, cuando lo simulo me pone "simulating" pero el led no enciende. Le intercalé un pulsador para probar que el led encienda y apague pero nada. Igualmente en los otros circuitos no sé como darle al terminal de VCC la tensión apropiada, al igual que a la masa. Me parece que estoy simulando circuitos a los que no se le aplica tensión y eso es porque NADA me funciona.
¿Es muy tonto lo que me pasa? Leí algo que había que usar el ANNOTATE para asignar los terminales, pero no lo encuentro por ningún lado.
¡¡¡¡AYUDA!!!! SE AGRADECERÁ.

Desconectado oshow

  • PIC18
  • ****
  • Mensajes: 321
RE: ¿PUEDE SER QUE NO PUEDA PRENDER UN LED?
« Respuesta #1 en: 10 de Octubre de 2004, 14:11:00 »
Hola, gueork y bienvenido.


La verdad es que es bien raro lo que comentas...y eso del annotate es la primera vez que lo veo...y yo he simulado sin problemas....

No se, así a primeras y sin ver el circuito ni tener más datos, no se me ocurre más que pensar que has puesto un led no simulable.

En Proteus existen modelos simulables y otros no... no pongas el que solo pone led, porque ese no es simulable, pon cualquier otro p.e. led-red o led-blue... a ver si con eso consigues simular algo...

En cuanto a lo de la alimentación, en el menú grafico "generator" puedes poner cualquier tipo de fuente para alimentar el circuito. Pero por ejemplo con ciertos elementos como pics o lcd´s no hace falta darles alimentación, el proteus ya entiende que para que funionen tienen que ir a 5v y no hace falta alimentarlos, simulan perfectamente sin alimentación...

No se.... mira a ver este pequeño tutorial a ver si puedes solucionar alguna cosilla más con él:

http://usuarios.lycos.es/arsabe75/index.html


Un saludo.

Desconectado GUEORK

  • PIC10
  • *
  • Mensajes: 20
RE: ¿PUEDE SER QUE NO PUEDA PRENDER UN LED?
« Respuesta #2 en: 10 de Octubre de 2004, 15:41:00 »
ALGO CONSEGUÍ!!
Bueno, probando y leyendo y viendo los ejemplos conseguí encender una bombilla y luego un led. Otra cosa que vi es que el display de 7 segmentos que había elegido no me funcionaba. Probé con otro GREEN y anda bien. Probé con una batería y con el generador como me decís y OK! También le puse para que me coloree los positivos y los negativos cuando simula, todo bien.
Pero tengo un problema con el programa que me envió un compañero del foro, porque no me simulan los ejemplos con PIC ni con 80C51 etc. Con el 68hc si funcionan. Los mismos ejemplos en el programa DEMO (que bajé del foro) me funcionan bien, pero en el programa que me mandaron me dan una serie de errores ¿Qué haré lo cargaré de nuevo?

Desconectado oshow

  • PIC18
  • ****
  • Mensajes: 321
RE: ¿PUEDE SER QUE NO PUEDA PRENDER UN LED?
« Respuesta #3 en: 10 de Octubre de 2004, 16:13:00 »
Sí, prueba a cargarlo otra vez, sabes como es no?. muy facil, seleccionas el microcontrolador (un click sobre él con el botón derecho) y se selecciona en color rojo, y luego un click con el boton izquierdo estando seleccionado, te sale un cuadro de dialogo donde puedes darle la direccion del programa del micro.

Mira a ver si con eso se te soluciona, sino habrá que examinar el problema con mas detalle.

Un saludo.

Desconectado GUEORK

  • PIC10
  • *
  • Mensajes: 20
RE: ¿PUEDE SER QUE NO PUEDA PRENDER UN LED?
« Respuesta #4 en: 19 de Octubre de 2004, 15:24:00 »
HOLA:
Lo que hice fue cargar el programa de nuevo y lo probé antes de sobreescribirle las librerías. Anda todo bien. Tenía algunos problemas en el dibujo (las líneas aunque estaban contínuas no conectaban y era justo el Reset) gracias a los cuadraditos que pone de las señales (rojo para positivo y azul para neg.) me dí cuenta. Me ponía un cuadradito gris en el reset, borré toda la línea la dibujé nuevamente y ¡Listo! Siempre es tan obvio cuando uno finalmente lo resuelve...
Pero sin la ayuda del foro: IMPOSIBLE.
GRACIAS A TODOS.


 

anything