Autor Tema: Problrma con sensor  (Leído 1089 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado KALLITOS

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1255
Problrma con sensor
« en: 01 de Junio de 2006, 19:50:48 »
una consultita he estado haciendo pruebas con los sensores que viene en el mouse ( por estos lares no hay de esos sensores que tienen emisor y receptor en una pieza ) he logrado que funcione pero el pulso que emite no es suficiente para exitar al pic asi que le he puesto un BC548 pero igual el pulso es demasiado debil y he hecho lo siguiente un divisor de tension de dos resist de 10k y la union de estos la conecto a la base del BC548 emisor a tierra y colector con una resistencia de 75 ohm a 5v...ya funciona pero el problema es que tengo una LCD en el circuito y cuando hay pulso del sensor la pantalla medio que se desvanece como si se chupara la fuente (pila de 9v con 7805)

he pensado hacerlo con un buffer stmich trigger (creo que asi se escribe) a ver que pasa, pero si alguien tuviera una solución mejor pues se lo agradeceria bastante

  es algo asi   
SENSOR        5V
    I                I
    I              75 ohm
   10K             I______PIC
    I________I/             
    I              I\
   10K             I
    I                I
    I           TIERRA
TIERRA   

:z):z) ojala que entiendan el ckto :z) :z)











A un microcontrolador hay que sacarle hasta el ultimo byte....(YO)

Cómo puede ser que un pic24EP512 me quede corto de memoria, señores de MICROCHIP saquen pics con más memoria flash

Más de 45 mil lineas de codigo y aun no termino el equipo, asu mare!!

S34ML08G1TFI200 no necesito mas memoria externa.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: Problrma con sensor
« Respuesta #1 en: 02 de Junio de 2006, 02:07:33 »
Hola KALLITOS, si este circuito que as usado anda bien lo que debes hacer es reemplazar la resistencia de 75 ohm por una de 4K7 o similar y listo, nada más que eso hara que todo este OK.

Un saludo.

Atte. CARLOS.
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado KALLITOS

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1255
Re: Problema con sensor
« Respuesta #2 en: 02 de Junio de 2006, 13:47:01 »
Te cuento inicialmente coloqué una resistencia de 2.2k pero no pasaba nada, habia voltaje pero no exitaba el pic entonces decidi ir bajando la resist para aumentar la corriente y hasta que me quedó con 75 ohm pero surgio el probema que te comento  he visto por alli que en la base le colocan una resistencia de 1 mega y en el colector una de 10K voy a probar con eso a ver que pasa...de todas maneras si alguein ha trabajado con esto pues bienvenidas opiniones y sugerencias. :P
A un microcontrolador hay que sacarle hasta el ultimo byte....(YO)

Cómo puede ser que un pic24EP512 me quede corto de memoria, señores de MICROCHIP saquen pics con más memoria flash

Más de 45 mil lineas de codigo y aun no termino el equipo, asu mare!!

S34ML08G1TFI200 no necesito mas memoria externa.

Desconectado MSK

  • PIC12
  • **
  • Mensajes: 53
Re: Problrma con sensor
« Respuesta #3 en: 02 de Junio de 2006, 14:35:28 »
Hola me parece que no te funciona con la de 2k2, porque la tension no subia a 5v entonces no leia un 1 el pic, el problema esta en la base del 548 modifica los valores de las resistencias de 10k para que cuando el sensor este en 0 tengas 5v colector y al pic.

Desconectado KALLITOS

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1255
Re: Problrma con sensor
« Respuesta #4 en: 08 de Junio de 2006, 14:29:12 »
bueno llegué de viaje anoche e hice lo que me recomendaste MSK; cambié 10 k por 100 k y le puse una resist. de 4.7 k al colector y quedó.

muchas gracias muchachos por la atención prestada.
A un microcontrolador hay que sacarle hasta el ultimo byte....(YO)

Cómo puede ser que un pic24EP512 me quede corto de memoria, señores de MICROCHIP saquen pics con más memoria flash

Más de 45 mil lineas de codigo y aun no termino el equipo, asu mare!!

S34ML08G1TFI200 no necesito mas memoria externa.


 

anything