Autor Tema: Problema en la recepcion de datos desde un GR48 utilizando comandos AT  (Leído 3547 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado badtzdizzy

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 234
Hola a todos

Pues nuevamente por aqui y es que tengo algunos problemas cuando recibo los datos que me manda el modem, por ejemplo si mando el comando "AT*", el modem me debe regresar todos los comandos disponibles y lo hace solo que de una forma extraña, ya que primeramente me manda el eco del comando que yo envié y al final de los datos despues del "OK" el micro se queda colgado y ya no responde y tengo que darle un reset. Alguien sabe a que se pueda deber esto? De antemano gracias, la forma en como recibo los caracteres es la siguiente:

Código: [Seleccionar]
do
{
dato=fgetc(MODEM);
fputc(dato,PC);
output_toggle(PIN_B7);
}
while(!kbhit(MODEM)); // Mientras haya caracteres en el buffer

Saludos

Desconectado maunix

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 4751
    • Mi Sitio Web Personal
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #1 en: 07 de Octubre de 2006, 12:17:25 »
Hola a todos

Pues nuevamente por aqui y es que tengo algunos problemas cuando recibo los datos que me manda el modem, por ejemplo si mando el comando "AT*", el modem me debe regresar todos los comandos disponibles y lo hace solo que de una forma extraña, ya que primeramente me manda el eco del comando que yo envié y al final de los datos despues del "OK" el micro se queda colgado y ya no responde y tengo que darle un reset. Alguien sabe a que se pueda deber esto? De antemano gracias, la forma en como recibo los caracteres es la siguiente:

Código: [Seleccionar]
do
{
dato=fgetc(MODEM);
fputc(dato,PC);
output_toggle(PIN_B7);
}
while(!kbhit(MODEM)); // Mientras haya caracteres en el buffer

Saludos

Comentame un poco más, jamás me pasó eso que dices.

¿Cómo sabes que es el modem el que se "tilda" y no tu pic?

¿En tu secuencia de recepción no veo que hagas un chequeo de errores, esto te lo hace automáticamente fgetc ()?

- La soberbia de un Einstein es entendible.. la de un salame es intolerable (A.Dolina)
- En teoría no hay diferencia entre la teoría y la práctica. En la práctica... si la hay.
- Lee, Lee, Lee y luego pregunta.(maunix)
- Las que conducen y arrastran al mundo no son las máquinas, sino las ideas (V. Hugo)
- Todos los hombres se parecen por sus palabras; solamente las obras evidencian que no son iguales.(Moliere)
- Todo debería ser hecho tan simple como sea posible pero no mas simple que eso.(A.Einstein)

Desconectado badtzdizzy

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 234
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #2 en: 09 de Octubre de 2006, 12:24:09 »
Hola

Pues como te decia maunix, utilizo la rutina que menciono para obtener los datos que me mande el modem. Con ayuda de un osciloscopio he comprobado que los datos que le mando al modem van y este responde asi que el problema lo tengo en el programa para el pic y te digo que es el pic porque cuando este se cuelga lo reseteo sin apagar el modem y funciona correctamente pero solo una vez. Asi que pues tengo que resetearlo cada vez que ingreso un nuevo comando. De hecho se me hace muy raro pero si yo coloco un if(kbhit) dentro del do - while automaticamente se sale y ya no continua. Al igual que como lo hice para el gps me basé en el programa de RedPic para hacer este y pues mi problema justo está en la recepción de datos desde el modem. Respecto a lo que me preguntas si el fgetc() checa errores pues creo que no y tienes razon no hice ninguna rutina para manejarlos quizá sea eso mi problema. Aqui te pongo el código para envio de comandos at para que le eches un vistazo y gracias por todo.
Código: [Seleccionar]
if(cbuff[0]=='a'&&cbuff[1]=='t')  // Comparo inicio del buffer con comando "at"

flagvalido=1;                    // Marco comando válido
fprintf(MODEM,"%s\r",cbuff);
do
{
fputc(fgetc(MODEM),PC);
output_toggle(PIN_B7);
}
while(!kbhit(MODEM)); // Mientras haya caracteres en el buffer
}

Desconectado maunix

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 4751
    • Mi Sitio Web Personal
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #3 en: 09 de Octubre de 2006, 13:05:27 »
Antes de revisar tu código que tal vez esté bien, ¿porqué no agregas un chequeo del bit OERR del RCSTA?  Fijate en el datasheet además como hacer para eliminar dicho error, que consiste en deshabilitar y habilitar el continuous receive del módulo usart.

Es que si este error salta, te dejará de recibir la usart.  Y todo lo demás que hagas por el software no servirá de nada que esté perfecto porque no recibirás ni un solo caracter luego de que el error se presente.

Saludos

- La soberbia de un Einstein es entendible.. la de un salame es intolerable (A.Dolina)
- En teoría no hay diferencia entre la teoría y la práctica. En la práctica... si la hay.
- Lee, Lee, Lee y luego pregunta.(maunix)
- Las que conducen y arrastran al mundo no son las máquinas, sino las ideas (V. Hugo)
- Todos los hombres se parecen por sus palabras; solamente las obras evidencian que no son iguales.(Moliere)
- Todo debería ser hecho tan simple como sea posible pero no mas simple que eso.(A.Einstein)

Desconectado badtzdizzy

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 234
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #4 en: 09 de Octubre de 2006, 15:34:38 »
OK maunix

Voy a checar y leer y leer lo que me dices para comprender mejor lo que está pasando y ya te contaré despues.

Gracias

Desconectado Orko

  • Colaborador
  • PIC18
  • *****
  • Mensajes: 423
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #5 en: 20 de Octubre de 2006, 15:42:20 »
Cuando mandas el comando "AT", el modem responde unicamente con "OK" y no con la lista de
comandos disponibles. Revisa la informacion del GR48.

Orko  8)

Desconectado badtzdizzy

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 234
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #6 en: 23 de Octubre de 2006, 17:44:54 »
Hola Orko

Lo que sucede es que yo mando el comando "AT*" que te da toda la lista de comandos disponibles para el modem en cuestión.

Saludos

Desconectado maunix

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 4751
    • Mi Sitio Web Personal
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #7 en: 23 de Octubre de 2006, 20:13:18 »
Hola Orko

Lo que sucede es que yo mando el comando "AT*" que te da toda la lista de comandos disponibles para el modem en cuestión.

Saludos

badtzdizzy ¿Aún sigues con el problema de que no te responde?


- La soberbia de un Einstein es entendible.. la de un salame es intolerable (A.Dolina)
- En teoría no hay diferencia entre la teoría y la práctica. En la práctica... si la hay.
- Lee, Lee, Lee y luego pregunta.(maunix)
- Las que conducen y arrastran al mundo no son las máquinas, sino las ideas (V. Hugo)
- Todos los hombres se parecen por sus palabras; solamente las obras evidencian que no son iguales.(Moliere)
- Todo debería ser hecho tan simple como sea posible pero no mas simple que eso.(A.Einstein)

Desconectado badtzdizzy

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 234
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #8 en: 24 de Octubre de 2006, 12:06:59 »
Hola maunix

Pues de alguna u otra forma todavia tengo el problema, lo que sucede es que ahora le he dado prioridad a otros asuntos relacionados. Decidí dejar un rato lo de la comunicación con comandos AT que se realiza por la UART 1 puesto que yo voy a manejar la UART 3, y ahi ya no he tenido problemas, de hecho ya pude enviar un mensaje con coordenadas obtenidas de un gps. Subiré los programas que utilicé para compartir con ustedes lo que voy aprendiendo. De hecho como estoy utilizando la UART 3 tambien  estoy adentrado en la programación con el M2M Power de Sony Ericsson.

Gracias por todo y seguimos en la lucha para usar el gprs

Saludos

Desconectado Orko

  • Colaborador
  • PIC18
  • *****
  • Mensajes: 423
Re: Problema en la recepcion de datos desde un GR48 utilizando comandos AT
« Respuesta #9 en: 25 de Octubre de 2006, 17:19:21 »
Entiendo la diferencia, no había visto el asterisco, y si tienes razón.

Orko  8)
« Última modificación: 26 de Octubre de 2006, 19:28:26 por Orko »


 

anything