Autor Tema: Estan bien las conexiones ?? :-D triacs  (Leído 2703 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado AKENAFAB

  • Colaborador
  • DsPIC30
  • *****
  • Mensajes: 3177
    • Automation Media Lab
Estan bien las conexiones ?? :-D triacs
« en: 22 de Enero de 2009, 07:49:28 »
Hola amigos!

Pido su ayuda para echarle una miradita al esquema que he armado, no estoy muy seguro de la parte AC.

Les cuento un poco lo que prentendo hacer!


Voy a utilizar ese circuito para controlar las lamparas de mi recamara o cualquier otra cosa que se me ocurra via infrarroja.
Tambien se me ocurre cargarle puras luces y hacer show  xD :D.

Con el control remoto enviarle el comando para habilitar cualquier carga.
EN caso de luces guardar hasta 512 secuencias en la eeprom,si hay falla electrica me tenga la ultima config usada al restablecer.
Utilizar el rtc para encender u apagar las luces a la hora que se determine,junto con el buzzer como alarma e indicador.




1 sensor de temperatura lm35
1 memoria eeprom de 512B
1 sensor infrarrojo pna4602
1 pic16f88
1 registro de corriemiento
1 pantalla lcd 2x16
1 buzzer
4 botones(estan multiplexados con la pantalla)
1 rtc (posiblemente)

8 posibles salidas posibles a triac(mediante el registro de corrimiento).

Aqui le spego el esquema!

Les agradezco su miradita ! :mrgreen:



Saludos!


Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Estan bien las conexiones ?? :-D triacs
« Respuesta #1 en: 22 de Enero de 2009, 11:36:52 »
... no estoy muy seguro de la parte AC....

Hola !

Se ven bien las conexiones.
Trata de no confundir M1 y M2 en los triacs (los terminales que conectan la carga) ya que si los inviertes no te funcionarán los mismos.

Lo único que podría sugerir es elevar un poco el valor de las resistencias de 100 ohm que activan los leds indicadores y los de los optoacopladores. No están mal, pero creo que están algo al límite de suministro de corriente hacia los leds.
Tal vez con 220 ó 330 Ohm funcione igual, con el consecuente incremento de la fiabilidad a largo plazo del sistema y el ahorro de energía, que en éste caso tal vez no interese, pero que siempre es importante.

Otra cosa.
Utilizo siempre la conexión que utilizas para el LCD, pero nunca había conectado a GND D0-D3.
Trae alguna ventaja ésto ? Yo siempre los dejo libres.

Ésa habitación parecerá una discoteca !  :)

Éxitos con la construcción !
Saludos
Mario

Desconectado AKENAFAB

  • Colaborador
  • DsPIC30
  • *****
  • Mensajes: 3177
    • Automation Media Lab
Re: Estan bien las conexiones ?? :-D triacs
« Respuesta #2 en: 22 de Enero de 2009, 19:23:21 »

Gracias Mario!

Voy a probar en proto lo de las resistencias y también ver si cabe en lo que llamamos aca una chalupa!
que es donde van apagadores y tomacorrientes.




Un saludos y gracias nuevamente!


Desconectado Javicho

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 570
Re: Estan bien las conexiones ?? :-D triacs
« Respuesta #3 en: 22 de Enero de 2009, 21:17:31 »
Hola:

No estoy seguro de los voltajes umbrales de los diodios emisores de los Mocs pero al estar en paralelo copn los leds lo que podria pasar es que en el mejor de los casos cuando active el diodo emisor digamos con 1v por decir algo entonces el led no encenderá o quizás solo un poco, como sugerencia mejor colocale su R al led desde el mismo pin del pic a gnd, asi aseguras que ambos quedarán bien energizados y trabajaran de forma estable.

Javicho.

Desconectado AKENAFAB

  • Colaborador
  • DsPIC30
  • *****
  • Mensajes: 3177
    • Automation Media Lab
Re: Estan bien las conexiones ?? :-D triacs
« Respuesta #4 en: 23 de Enero de 2009, 00:08:52 »
Gracias Javicho!

En las especificaciones indica 1.5v y min 10mA , recomiendan 15mA.

Entonces R=(Vcc-Vledmoc)/Iledmoc
               ( 5-1.5 ) /0.015 =233 ohms ~ 220 .

el registro de corriemiento me entrega hasta 25mA.

Calcule para el led indicador una resistencia de 200 ohms.  Vledinficador=2v  Iledindicador=15mA

Mi pregunta es si estaria bien entonces esa resistencia?

 Rt=(220*200)/(220+200)= 104.76 ohms ~ 100 ohms

Estos calculos los acabo de realizar.


Pero creo que lo que me dices javicho seria lo mejor o como ven?

Saludos!

Desconectado hamiltontodopic

  • PIC10
  • *
  • Mensajes: 3
Re: Estan bien las conexiones ?? :-D triacs
« Respuesta #5 en: 05 de Noviembre de 2009, 17:21:30 »
Hola maigo puedes poner el programa?


 

anything