TODOPIC
Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
02 de Septiembre de 2014, 01:14:13

Ingresar con nombre de usuario, contraseña y duración de la sesión
Buscar:     Búsqueda Avanzada
347948 Mensajes en 39039 Temas por 40658 Usuarios
Último usuario: pierceg4731
* Inicio Ayuda Buscar Calendario Ingresar Registrarse
Buscar en TodoPIC
+  TODOPIC
|-+  Mecatrónica
| |-+  PLC - Control Lógico Programable (Moderadores: MGLSOFT, Sasián)
| | |-+  Comunicacion RS232 entre PLC Micrologix 1500 LRC y Modem GSM Motorola G24
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Marcar como favorito Imprimir
Autor Tema: Comunicacion RS232 entre PLC Micrologix 1500 LRC y Modem GSM Motorola G24  (Leído 4308 veces)
Tec_Claudio_Perez
PIC12
**
Desconectado Desconectado

Mensajes: 62


« : 01 de Febrero de 2009, 13:49:42 »

Hola a todos,

Resulta que compre un modem GSM Motorola G24 en www.electrocomponentes.com.ar.
La idea es que al activarse una salida de falla del proceso que el PLC controla, este me envíe un mensaje de texto SMS.
El Micrologix se conecta al modem G24 usando el puerto 1 mediante RS232. Hasta aquí todo bien, se configura el modem enviando comandos "AT". Ya pude enviar SMS (usando instrucciones AWT), pero tengo un problema, no puedo recibir los caracteres que le responde el modem. Por ejemplo al enviar "AT" el modem responde "OK", pero no lo puedo ver.
Estoy usando continuamente la instruccion "ABL", con el registro de control "R6:3", que supuestamente sirve para verificar si llego algun caracter al buffer de recepcion, luego con el bit FD del registro "R6:3" realizo la lectura del buffer con la instruccion "ARL" y deposito los caracteres en la zona de memoria "ST9:4", pero resulta que no lee nada.
Se que es una pregunta un poco avanzada, pero si alguno alguna vez conecto este PLC a algún dispositivo que devuelva caracteres (modem, lector de codigo de barras, otro PLC, o la misma PC) utilizando el puerto de comunicacion en modo ASCII por favor le pido alguna directiva.
Muchas gracias y sigan participando en el foro que es espectacular...!

Tec. Claudio J. Pérez
En línea
jaw
PIC10
*
Desconectado Desconectado

Mexico Mexico

Mensajes: 2


« Respuesta #1 : 28 de Agosto de 2009, 17:29:55 »

Hola, probablemente tu problema sea a la cantidad de caracteres que estas designando para lectura es decir en el bloque ARL existe un renglon que se llama "string length" te recomiendo que pongas un numero grande por si el mensaje que esperas recibir viene con espacios o tiene un formato distinto al que esperas.
por otra parte deberias de revisar las conexiones que tienes en el plc verifica que tienes bien conectado el pin de envio  y el de recepcion de datos.
En línea
TODOPIC
   

 En línea
Páginas: [1] Imprimir 
« anterior próximo »
Ir a:  

Impulsado por MySQL Impulsado por PHP Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines XHTML 1.0 válido! CSS válido!
Página creada en 0.038 segundos con 23 consultas.