Autor Tema: Problemas con GPS PM-1211-A1 , error del GPS en la trama de datos??  (Leído 1626 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado richardjr

  • PIC12
  • **
  • Mensajes: 69
Problemas con GPS PM-1211-A1 , error del GPS en la trama de datos??
« en: 25 de Septiembre de 2009, 23:52:28 »
Hola a todos! Estoy un poco desorientado con esto del GPS... Sucede que el modulo lo ha probado levantando los datos por medio del hyper terminal, lo saque a pasear y luegop pude corroborar que los datos que capture (previa adaptacion de las cadenas NMEA) eran correctos con ayuda de google earth.
Ahora bien, una vez que logre dejar andando el codigo en un PIC 18F4550, previa simulacion en proteus, sali a dar una vuelta con la idea de ver si respondia bien haciendo un computo de la distancia cubierta y de la velocidad. La primera vez, lo hice en el auto, y anduvo muy bien. Pero luego, no he tenido exito alguno si pruebo a pie. De momentos estando quieto, veo que me marca velocidades del oredn de los 35Kmh :shock: mientras la distancia comienza a aumentar  :shock: :shock:. Tambien observo que viene todo bien hasta que pierde señal... cuando retoma, es que empiezan los problemas xq parece que la primer coordenada que larga tiene mucho error ...yo me aseguro de estar trabajando con Position fix quality indicator =1, Status=‘A’ , y de comprobar el checksum al final de la cadena antes de hacer cualquier calculo y aun asi... tira errores para nada pasables...
Alguien habra tenido alguna experiencia parecida que me pueda dar una mano? Sera el GPS ?
Dejo adjunto el pdf de la hoja de datos por las dudas, este modulo lo compre en CIKA