Autor Tema: Problema con ULN2803 y PIC  (Leído 4040 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado JCR77

  • PIC10
  • *
  • Mensajes: 6
Problema con ULN2803 y PIC
« en: 07 de Febrero de 2006, 08:18:00 »
Hola, como va?
Utilizo un PIC 16f84a y tengo que activar un rele de 12v.
Una pata de la bobina del rele la conecto a 12v y la otra a una salida del ULN2803,  la salida del PIC a la entrada del ULN2803. El problema es que cuando envio un 1 por el pic me aciva el rele, pero despues, cuando envio un 0, el rele no se desactiva. Espero que me puedan ayudar...
Saludos...

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
RE: Problema con ULN2803 y PIC
« Respuesta #1 en: 07 de Febrero de 2006, 09:52:00 »
Hola JCR77, ¿Estas seguro que el PIN del PIC posee un cero cuando debería?¿As controlado la entrada correspondiente a la del relé en el 2803?

Por lo general lo difícil es hacerlos andar o activar y no lo contrario.

Un saludo

Atte. CARLOS

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado elmasvital

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 1713
RE: Problema con ULN2803 y PIC
« Respuesta #2 en: 07 de Febrero de 2006, 10:08:00 »
Me juego lo que quieras a que no tienes puesto un condensador de 100nF entre vcc y gnd del pic (lo mas cerca de este posible)

otra cosa tienes conectado el diodo de protección del 2803??? creo que era la patilla 9 o 10, es el diodo de antiparalelo conectado a vcc, para evitar los picos. mirate el datasheet, pero vaya mas lo que te dije antes que esto.

1 saludo

Desconectado JCR77

  • PIC10
  • *
  • Mensajes: 6
RE: Problema con ULN2803 y PIC
« Respuesta #3 en: 07 de Febrero de 2006, 22:39:00 »
Bueno gracias por las respuestas, pero al final por cuestiones de tiempo deje de lado el ULN2803 y amplifique la corriente con un transistor BC547 como se explica en el hilo  "Como conecto un rele a un PIC?". La verdad que ya me estaba volviendo loco con ese integrado, era para una placa que tenia que entregar y ya me habia atrasado mucho. Igualmente en algunos dias voy a tener que aprender como conectarlo porque tengo pensado empezar a hacer un robot y lo necesito para los motores.
El condensador no lo tenia conectado pero ahora lo voy a colocar.
La conexion me quedo asi (No tengo escaner sino enviaba una foto):
El pin del PIC que  me activa el rele a la base del transistor (con una resistencia de 1K de por medio), el emisor a masa, y el colector a una pata de la bobina del rele. La otra pata de la bobina a positivo. Y le coloco un diodo en paralelo a la bobina.
Lo que les queria preguntar es que me conviene hacer con lo siguiente:
Tengo 2 reles uno de 12v y otro de 5v y no se cual de los dos colocar.
En la placa tengo un transformador de  9v y un regulador L2605. No se si me conviene poner el rele de 12v directo a 9v (igual se activa), o el de 5v a 5v regulados, o el rele 5v a 9v (Con esta ultima no probe pero tengo entendido que no se queman con algunos volts de mas). El circuito tiene que estar todo el tiempo encendido (No tiende demasiados componentes: Tengo el PIC, 4 leds, algunos interruptores y el rele). Lo ideal seria colocar el rele de 5v a los 5v regulados pero no se si se me va a recalentar mucho el regulador o si se va a quemar.
Saludos...

Desconectado elmasvital

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 1713
RE: Problema con ULN2803 y PIC
« Respuesta #4 en: 08 de Febrero de 2006, 06:18:00 »
Escrito originalmente por JCR77
Bueno gracias por las respuestas, pero al final por cuestiones de tiempo deje de lado el ULN2803 y amplifique la corriente con un transistor BC547 como se explica en el hilo  "Como conecto un rele a un PIC?". La verdad que ya me estaba volviendo loco con ese integrado, era para una placa que tenia que entregar y ya me habia atrasado mucho. Igualmente en algunos dias voy a tener que aprender como conectarlo porque tengo pensado empezar a hacer un robot y lo necesito para los motores.
El condensador no lo tenia conectado pero ahora lo voy a colocar.
La conexion me quedo asi (No tengo escaner sino enviaba una foto):
El pin del PIC que  me activa el rele a la base del transistor (con una resistencia de 1K de por medio), el emisor a masa, y el colector a una pata de la bobina del rele. La otra pata de la bobina a positivo. Y le coloco un diodo en paralelo a la bobina.
Lo que les queria preguntar es que me conviene hacer con lo siguiente:
Tengo 2 reles uno de 12v y otro de 5v y no se cual de los dos colocar.
En la placa tengo un transformador de  9v y un regulador L2605. No se si me conviene poner el rele de 12v directo a 9v (igual se activa), o el de 5v a 5v regulados, o el rele 5v a 9v (Con esta ultima no probe pero tengo entendido que no se queman con algunos volts de mas). El circuito tiene que estar todo el tiempo encendido (No tiende demasiados componentes: Tengo el PIC, 4 leds, algunos interruptores y el rele). Lo ideal seria colocar el rele de 5v a los 5v regulados pero no se si se me va a recalentar mucho el regulador o si se va a quemar.
Saludos...


Buff y donde dices que tienes que entregar ese circuito??? Ten cuidao con las burradas hombre...

Ni reles de 12v a 9 ni relés de 5v a 9... todo a su medida hombre. Si tienes un transformador de 9v pues usa el de 5v.. ahora bien tienes que tener en cuenta el límite de intensidad del relé... a ver si le vas a meter mucha caña y lo vas a matar... para 5 voltios no deberias conectarle mas de 1 amperio.

Indica que transistor usas... con la resistencia de 1k es posible que no te llegue para saturarlo (entrar en saturación... activarse)

1 saludo

Desconectado JCR77

  • PIC10
  • *
  • Mensajes: 6
RE: Problema con ULN2803 y PIC
« Respuesta #5 en: 08 de Febrero de 2006, 09:35:00 »
Cita:
Ni reles de 12v a 9 ni relés de 5v a 9... todo a su medida hombre. Si tienes un transformador de 9v pues usa el de 5v..

No entiendo lo que queres decir aca: primero decis que no ponga reles de 5v a 9v y despues me decis que si.
El transistor que uso ya lo indique en el segundo post.
El transformador me entrega 9v 300mA asi que no me va a quemar e rele
Cita:
Buff y donde dices que tienes que entregar ese circuito??? Ten cuidao con las burradas hombre...
A mi no me parece ninguna burrada preguntar algo que no se, yo no tengo grandes conocimientos en electronica, estoy aprendiendo y si pregunto eso es porque no quiero quemar nada y quiero que me funcione bien.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
RE: Problema con ULN2803 y PIC
« Respuesta #6 en: 08 de Febrero de 2006, 10:06:00 »
Hola JCR77, creo que as tenido un mal entendido por tú parte, te explicare los que a querido decir elmasvital:

* Cuando dice Si tienes un transformador de 9v pues usa el de 5v a querido decir que le coloques un regulador de voltaje al trafo de 9V para que el relay funcione con 5V, ya que con 9V de forma directa (aunque tengas 300ma lo quemarás ya que esa corriente será suficiente)

* Cuando dice Ten cuidado con las burradas hombre... solo te esta aconsejando, ya que tú estas queriendo vender (por lo que se ve) un circuito electrónico y como tu bien dices de electrónica no sabes nada. Y de la forma por la que te urge se ve que lo entregaras sin siquiera estar seguro del correcto funcionamiento y duración del mismo.

Por lo tanto preguntar algo que no sabes no es ninguna burrada ya que todas las personas del mundo aprenden de esta forma. Pero entregar un circuito sin saber siquiera si tendrá una duración mínima (si es burrada) por que dependiendo el uso que se le de a este podría llegar a quemar otros artefactos, y te acarreara muchos problemas, y estos mismos problemas son los que hay que tener en cuenta a la hora de diseñar ese circuito, pero como tu no sabes de electrónica ¿Los as tenido en cuenta?

Antes de pelearse creo que hay que intentar entenderse, si no se entienden, pues vuelvan a preguntar de la forma correcta y luego si quieren pueden pelearse (aunque elmasvital no tenia malas intenciones), y esto lo comento por experiencia propia.

Un saludo y suerte

Atte. CARLOS


La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado elmasvital

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 1713
RE: Problema con ULN2803 y PIC
« Respuesta #7 en: 08 de Febrero de 2006, 10:20:00 »
Entiende lo de burrada por lo siguiente.

1ro mencionas que la placa tenias que entregarla con prisa porque tenias que entregarla. Ok eso quiere decir que o estás estudiando o le estas haciendo un apañillo a algun colega, algun negocio o similares --- > por lo que se supone que deberia saber lo que estas haciendo... y por otro lado mencionas que tienes 2 reles uno a 12v y otro a 5v con un transformador de 9v y un ls2605. A ver con esto cualquier persona q sepa algo de electronica sabe que el de 12v no va a tirar...

2do digo lo de burradas porque los relés se utilizan para manejar voltajes importantes por lo que si no sabes lo que haces puedes hacerte o hacerle daño a alguien... aun montandolo bien si montas un relé de 5v la intensidad maxima que suelen soportar es 1 amp.... si le conectas ahí un motor electrico a 220v... algun secador... o algo importante te puede salir ardiendo el relé.

En fin no te tomas a mal las cosas pero ten cuidado con la electronica solo eso. Si te lo tomas a mal tu mismo... no fue con intención.

1 saludo

Desconectado JCR77

  • PIC10
  • *
  • Mensajes: 6
RE: Problema con ULN2803 y PIC
« Respuesta #8 en: 09 de Febrero de 2006, 21:42:00 »
Quiero dejar en claro que mi intencion no era pelear, solo quieria aclarar eso. Cuando lei el post, me cayo un poco mal lo de las burradas y eso, pero ya esta. No vamos a armar todo un circo por unas palabras (que a veces pueden ser mal interpretadas cuando se leen).
Bueno, gracias por la ayuda.


 

anything