Autor Tema: Problema, comportamiento no real del componente MAX6675 en Proteus  (Leído 1774 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 600
    • https://electronicaaficion.wordpress.com/
Buenas tardes, tengo un problemilla con la simulación del MAX6675, si nos fijamos en el datasheet del componente, cuando se le activa el pin para la lectura a nivel bajo, este envía una palabra de 16bits, dentro de esa palabra no valen todos los datos para la medida, el bit número 2 (3 si contamos el bit 0 como uno), nos indica si el termopar está conectado o no, entonces sólo se debe de activar cuando desconectamos el termopar, el resto de bits menos el último es donde está el dato de la temperatura, ósea 12 bits.

Pues bien, lo que he observado es que el bit numero 2 se activa por si solo al aumentar el valor del termopar  o disminuirlo y las simulaciones me dan resultados que no son reales.

¿alguien ha notado este comportamiento en este componente virtual?, ¿ hay alguna manera de arreglarlo?
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado pablomanieri

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 632
Re: Problema, comportamiento no real del componente MAX6675 en Proteus
« Respuesta #1 en: 19 de Agosto de 2011, 09:38:46 »
Según el datasheet:
Citar
Open Thermocouple
Bit D2 is normally low and goes high if the thermocouple
input is open. In order to allow the operation of the
open thermocouple detector, T- must be grounded.
Make the ground connection as close to the GND pin
as possible.

Tal vez sea ese el problema y no el modelo de Proteus. ¿Tienes conectado el T- a GND?

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 600
    • https://electronicaaficion.wordpress.com/
Re: Problema, comportamiento no real del componente MAX6675 en Proteus
« Respuesta #2 en: 20 de Agosto de 2011, 11:22:42 »
Si tengo la patilla del termopar a masa, con lo cual ese no es el problema, ¿que más podría ser?
« Última modificación: 20 de Agosto de 2011, 11:25:47 por Thulsa Doom »
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado jorge luis

  • PIC10
  • *
  • Mensajes: 13
Re:Problema, comportamiento no real del componente MAX6675 en Proteus
« Respuesta #3 en: 06 de Diciembre de 2017, 11:17:55 »
Hola Thulsa Doom, a mi me pasa lo mismo en mi simulación, el bit de estado de termopar abierto se me activa a pesar de estar conectado, has podido solucionar éste problema? me sería de gran ayuda

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 600
    • https://electronicaaficion.wordpress.com/
Re:Problema, comportamiento no real del componente MAX6675 en Proteus
« Respuesta #4 en: 06 de Diciembre de 2017, 19:03:47 »
Pues no he podido resolverlo, al final poté por montar una PCB con un microcontrolador con el termo par y toda la electrónica para que funcione y listo se acabó el problema.

lo siento pero creo que ese soft no está bien del todo
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...