TODOPIC
Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
02 de Septiembre de 2014, 13:37:20

Ingresar con nombre de usuario, contraseña y duración de la sesión
Buscar:     Búsqueda Avanzada
347961 Mensajes en 39041 Temas por 40661 Usuarios
Último usuario: otrodesion
* Inicio Ayuda Buscar Calendario Ingresar Registrarse
Buscar en TodoPIC
+  TODOPIC
|-+  Microcontroladores PIC
| |-+  * PROYECTOS * (Moderadores: J1M, jfh900, MGLSOFT, Modulay, Sasián, LABmouse)
| | |-+  Termometro Digital:16F84A, DS1820, Matrices 5x7 de leds, 74HC164
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Marcar como favorito Imprimir
Autor Tema: Termometro Digital:16F84A, DS1820, Matrices 5x7 de leds, 74HC164  (Leído 1402 veces)
Kibur
PIC10
*
Desconectado Desconectado

Sexo: Masculino
España España

Mensajes: 6



« : 06 de Septiembre de 2011, 16:48:46 »

Hola que tal, estoy realizando mi primer proyecto con un pic como ya comenté en un post cuando tuve problemas con la programación. Bueno ahora tengo una pequeña duda sobre el esquema electrónico, creo que me faltan unos transistores entre la salida del pic y la matriz de leds, porque según el datasheet del 16F84A una salida no puede suministrar 7*10mA de cada led = 70mA por pin, la alimentación del pic seria de 4,5V (con 3 pilas AA 1,5V) según he leído en el pic no hay ningún problema, lo que no se, es que pasará cuando se gasten las pilas y el voltaje disminuya, espero que no se queme el pic...

He buscado por el foro y he encontrado un post del "elmasvital" que se parece bastante con mi esquema, la pregunta seria que si iría bien poner a la salida del 74HC164 el ULN2803, y 10 transistores 2N2222 a cada salida del pic con sus respectivas resistencias. A lo mejor tendría que cambiar el valor de alguna resistencia porque esta alimentando 8 leds y yo 7 no?¿ y a lo mejor no se verían muy luminosos.
Él comenta también que su registro de desplazamiento en el peor de los casos va a soportar 20mA de cada led x 8=160mA, en mi caso sería 10mA de cada led x 14 = 140mA, también iría bien el ULN2803 no?

Además creo que si utilizo el ULN2803 podría quitar el optoacoplador y conectarlo directo al ULN2803 no¿?

Bueno si veis algún error más en el esquema, o me aconsejáis algún cambio se agradece.

Por cierto el pic se encontrará siempre en modo "sleep" hasta pulsar un botón

En línea
Kibur
PIC10
*
Desconectado Desconectado

Sexo: Masculino
España España

Mensajes: 6



« Respuesta #1 : 07 de Septiembre de 2011, 08:21:42 »

Olvidé poner el link http://www.todopic.com.ar/foros/index.php?topic=22108.0
En línea
TODOPIC
   

 En línea
Páginas: [1] Imprimir 
« anterior próximo »
Ir a:  

Impulsado por MySQL Impulsado por PHP Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines XHTML 1.0 válido! CSS válido!
Página creada en 0.109 segundos con 23 consultas.