Autor Tema: Interferencia servos y PIC  (Leído 994 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado rugs20

  • PIC10
  • *
  • Mensajes: 18
Interferencia servos y PIC
« en: 20 de Septiembre de 2012, 16:41:11 »
Hola!!

A ver si alguien me puede orientar un poco sobre que es lo que puede estar pasando...
Estoy controlando unos servos digitales con un PIC 16F88 La programacion y todo está correcto y funcionando el la placa de pruebas.
El problema ha surgido al montarlo sobre el PCB, Al encender el circuito el pic deja de funcionar, pero si desconecto los servos funciona correctamente, por lo que el problema es de los servos...
Los servos los he conectado directamente a las patillas del pic y la alimentacion es las misma que para el pic y he colocado entre Vdd y Vss un condensador de desacoplo de 470uF...
He probado con alimentacion por separada y uniendo las masas, en este caso los servos se mueven, pero no mantienen la posicion y funcionan de forma irregular.
Supongo que sera problema de interferencia en la alimentacion, pero no se que colocar para hacer un mejor filtrado...

Gracias por vuestra ayuda!!

Desconectado Suky

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 6759
Re: Interferencia servos y PIC
« Respuesta #1 en: 20 de Septiembre de 2012, 18:58:03 »
Entre Vcc y Gnd de cada servo podes colocar un capacitor de 100n. Luego para el pin de control podes probar de utilizar un par de transistores, adjunto imagen.


Saludos!
No contesto mensajes privados, las consultas en el foro

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17755
    • MicroPIC
Re: Interferencia servos y PIC
« Respuesta #2 en: 21 de Septiembre de 2012, 02:05:12 »
Yo tuve un problema parecido y la interferencia se transmitía a través de la alimentación, no por el pin de control.
Lo solucioné de esta manera:

Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado rugs20

  • PIC10
  • *
  • Mensajes: 18
Re: Interferencia servos y PIC
« Respuesta #3 en: 21 de Septiembre de 2012, 05:46:00 »
Hola de nuevo!

Muchas gracias por vuestras respuestas!

He probado con la solucion de Nocturno porque me parecia mas sencilla de implementar y con un solo servo parece que funciona!!!  ((:-))
Mas tarde conectare los otros a ver si sigue funcioando.

Gracias!!


 

anything