Autor Tema: amplificación  (Leído 1036 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado kidpic

  • PIC16
  • ***
  • Mensajes: 204
amplificación
« en: 08 de Mayo de 2014, 10:30:41 »
Estoy trabajando con un amplificador ina122 y de acuerdo a su hoja de datos para obtener una ganancia de 100 debo conectar una resistencia  Rg en sus pines correspondientes de 2.1K. hago las conexiones indicadas y utilizando una alimentación 0-5 volts  para el integrado para una entrada alterna de 20mv pico a pico deberia tener una salida de 2 v pico a pico. El problema es que no leo ningun valor de salida. pense que podria ser porque no estoy alimentando con una fuente simetrica pero en todo caso se recortaria la amplificacion para los valores negativos. que puede estar pasando. Muchas gracias por sus respuestas.
Si quieres trascender..., enseña humildemente  lo que sabes.

Desconectado jhozate

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1689
Re: amplificación
« Respuesta #1 en: 08 de Mayo de 2014, 11:51:09 »
He usado este amplificador sin problema, si es posible pon el esquemático que implementas. Hay que tener en cuenta que es un amplificador de instrumentación y puede dañarse incluso con la carga electróstatica, asi que ten un poco de cuidado al manipularlo.
Ser Colombiano es un Premio, Saludos desde CALI-COLOMBIA

Desconectado kidpic

  • PIC16
  • ***
  • Mensajes: 204
Re: amplificación
« Respuesta #2 en: 08 de Mayo de 2014, 22:32:37 »
Hola Jhozate. En estos momentos no puedo presentar el esquematico pero te describo las conexiones.
1- entre la pata 1 y 8 esta la resistencia de ganancia de 2,1 k
2- a masa esta la pata 4 y 5
3- la entrada del generador de señal que es de 20 mv pico a pico esta conectada a la pata 3 y la masa del genrador a las patas 4 y 5
4- la alimentacion esta en la pata 7 que es de 5 v
5- y mido la salida en la pata 6.
No obtengo señal alguna y eso q es  un INA 122   NUEVO!!!

gracias!
Si quieres trascender..., enseña humildemente  lo que sabes.

Desconectado HJG

  • PIC12
  • **
  • Mensajes: 77
Re: amplificación
« Respuesta #3 en: 08 de Mayo de 2014, 23:09:48 »
Hola Jhozate. En estos momentos no puedo presentar el esquematico pero te describo las conexiones.
1- entre la pata 1 y 8 esta la resistencia de ganancia de 2,1 k
2- a masa esta la pata 4 y 5
3- la entrada del generador de señal que es de 20 mv pico a pico esta conectada a la pata 3 y la masa del genrador a las patas 4 y 5
4- la alimentacion esta en la pata 7 que es de 5 v
5- y mido la salida en la pata 6.
No obtengo señal alguna y eso q es  un INA 122   NUEVO!!!

gracias!
Ya que alimentas con 5V y masa, deberías conectar el pin 2 a un divisor resistivo para generar una masa virtual.

Desconectado kidpic

  • PIC16
  • ***
  • Mensajes: 204
Re: amplificación
« Respuesta #4 en: 09 de Mayo de 2014, 09:04:54 »
Gracias por tu respuesta hjg. Que funcion cumpliría la masa virtual. Si lo conecto a un divisor resistivo a la pata 2 lo estoy conectando a un nivel de tension dado por la resitencia del divisor.
Gracias nuevamente.
Si quieres trascender..., enseña humildemente  lo que sabes.

Desconectado HJG

  • PIC12
  • **
  • Mensajes: 77
Re: amplificación
« Respuesta #5 en: 09 de Mayo de 2014, 10:11:15 »
Que funcion cumpliría la masa virtual. Si lo conecto a un divisor resistivo a la pata 2 lo estoy conectando a un nivel de tension dado por la resitencia del divisor.
Esa tensión debería ser Vcc dividido 2, en tu caso 2,5V, deberías utilizar dos resistencias iguales. Allí tendrías que conectar el retorno de la señal de entrada.

¿en que piensas utilizar este amplificador? no es un amplificador común, es un R2R, normalmente utilizado como amplificador de instrumentación.

Desconectado kidpic

  • PIC16
  • ***
  • Mensajes: 204
Re: amplificación
« Respuesta #6 en: 09 de Mayo de 2014, 10:21:13 »
Necesito amplificar la señal de un sensor de presion diferencial que va de 20mv a 55mv para llevarlo a un microcontrolador. No me queda claro el retorno de la señal de entrada. cual seria si la señal de entrada viene de un generador de señal.
Gracias
Si quieres trascender..., enseña humildemente  lo que sabes.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2178
Re: amplificación
« Respuesta #7 en: 09 de Mayo de 2014, 11:50:24 »
yo he usado el circuito adjunto para un sensor de presion, el SX150 con el INA122... si te interesa subo el proyecto completo en altium y el codigo C del micro.

Saludos!
-
Leonardo Garberoglio

Desconectado kidpic

  • PIC16
  • ***
  • Mensajes: 204
Re: amplificación
« Respuesta #8 en: 09 de Mayo de 2014, 12:35:24 »
Hola sería una gran ayuda si lo subes. Muchas gracias.
Si quieres trascender..., enseña humildemente  lo que sabes.


 

anything