Autor Tema: 16f627 a veces arranca bien, a veces no.  (Leído 1171 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado bluesboy

  • PIC12
  • **
  • Mensajes: 67
16f627 a veces arranca bien, a veces no.
« en: 22 de Agosto de 2014, 18:51:48 »
buenas.
Tengo un pequeño circuito que multiplexa 4 displays y mediante un sensor, cuenta y muestra esa cuenta en el display.
A modo de ejemplo, para que tengan una idea, pueden ver la multiplexación de 4 display en el tutorial de suky. Es ese mismo programa, lo usamos para enseñarle a unos pibes como manejar displays.
Bien, lo he hecho muchas veces y me ha funcionado pero me sucede que a veces arranca en cualquiera, es como que arranca tildado y tengo que reseterarlo hasta que quiere encender bien, o desconectarlo de la red.
Para mi que hay algo en hardware de la fuente que es el siguiente.
Transformador de 9v, puente de diodos, capacitor 2200uf x 16v, regulador 7805.
He hecho la prueba de poner un interruptor luego del 7805, por si me estaba afectando el tiempo de carga del capacitor, para esperar a que se estabilicen los valres de corriente y tensión; entonces dejaba unos segundos hasta que le mandaba los 5 v al pic mediante un interruptor a la salida del regulador.
Sigue haciendo lo que quiere. Entre los pines de masa y vcc, en los mismos pines del micro tiene un capacitor 100nf por si hay algún ruido.

O sea, resumiendo, a veces aparecen los 4 display encendidos bien, con 4 ceros y a veces aparece cualquier cosa.

El consumo en alterna, a la salida de los 9v del trasnformador es de 162mA AC y la tensión en bornes al conectar el circuito es de 8,01v AC, menos de 1,5 watts. Como vi que la tensión caia un volt, pense´que podía llegar a tener falta de potencia en el trasnformador, entonces le conecte una fuente externa de 12v1a CC a la entrada del regulador de 5v y sigue igual

¿Alguien tiene alguna idea o sugerencia?

Gracias.

Desconectado nico

  • PIC16
  • ***
  • Mensajes: 180
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #1 en: 22 de Agosto de 2014, 19:57:05 »
Me ha pasado en muchos casos que esta habilitado el BOR y por lo tanto se resetea, en este caso puntual, como el problema se da al conectar la alimentacion hay que mirar si tienes habilitado el POR(power on reset) y sino habilitarlo, asi el micro esperara a que la tensio se estabilize antes de salir del estado de reset.

Mas datos aquí

http://www.todopic.com.ar/foros/index.php?action=printpage;topic=17909.0

Salutes.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #2 en: 23 de Agosto de 2014, 15:53:09 »
Hola bluesboy, si con lo propuesto por nico no se soluciona, sería mejor guía que colocases el esquema que usas y el código fuente, de esta manera podríamos darte otra posible solución.

Un saludo.

Atte. CARLOS.

 
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado elmasvital

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 1713
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #3 en: 24 de Agosto de 2014, 14:26:02 »
Mira a ver si inicializas todas las variables al un valor dentro de los parametros. Las memorias cuando arranca el micro pueden coger cualquier valor... muchas veces FF

Desconectado bluesboy

  • PIC12
  • **
  • Mensajes: 67
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #4 en: 25 de Agosto de 2014, 11:43:23 »
Buen día

Tengo el Boren OFF, siempre asi en todos los programas.
No entiendo bien a qe se refieren con lo de la memoria, lo que si les puedo decir es que todos los registros que uso, son blanqueados al inicio, mediante un CLRF en cada uno.

Adjunto esquema de la fuente, el interruptor al final es para encender la fuente y luego de unos segundo energizar el circuito, porque en algunos proyectos, el tiempo de carga del capacitor influia en el arrancque, por la corriente de carga del capacitor.

El código es http://www.todopic.com.ar/foros/index.php?topic=24720.msg201403#msg201403

Pregunta, alguie saber por que puede pasar esto, a nivel electrónico? Disculpen que insista, pero me parece que es electrónico el asunto.

Se agradece cualquier sugerencia.


Desconectado nico

  • PIC16
  • ***
  • Mensajes: 180
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #5 en: 25 de Agosto de 2014, 12:47:50 »
Luego del regulador deberias tener un capacitor electrolitico y uno ceramico también. Coloca si puedes el diagrama completo de la aplicación para que podamos ver y entender porque puede estar ocacionandose el problema.

Salutes.

Desconectado bluesboy

  • PIC12
  • **
  • Mensajes: 67
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #6 en: 25 de Agosto de 2014, 13:08:55 »
Buen día

Encontre la falla, como decía elmasvital, revisé y si, me olvidé de limpiar un registro :oops:
Le puse un CLRF y se solucionó.

Muchas gracias a todos.
Voy a tener en cuenta lo de los capacitores luego del regulador.

Nuevamente, gracias a todos.

Desconectado elmasvital

  • Administrador
  • PIC24H
  • *******
  • Mensajes: 1713
Re: 16f627 a veces arranca bien, a veces no.
« Respuesta #7 en: 25 de Agosto de 2014, 17:52:00 »
Buen día

Encontre la falla, como decía elmasvital, revisé y si, me olvidé de limpiar un registro :oops:
Le puse un CLRF y se solucionó.

Muchas gracias a todos.
Voy a tener en cuenta lo de los capacitores luego del regulador.

Nuevamente, gracias a todos.

TIN TIN TIN TIN me llevo el premio :-P

Me pasó el otro día algo parecido :-P