Autor Tema: [SOLUCIONADO]Ayuda con LM5070 (Integrado para hacer una fuente POE)  (Leído 4225 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 720
    • https://electronicaaficion.wordpress.com/
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #15 en: 25 de Noviembre de 2014, 20:24:50 »
He estado haciendo pruebas y es verdad, la resistencia de la patilla 14 (RT) que es de 12.1K en el circuito, está ajustada para un frecuencia de 250KHz, justo la frecuencia que indica coilcraft que es para su transformador, la he medido con un osciloscópio y está clavada.

El bobinado está instalado tal como se ve en el esquema, si ven el datasheet del fabricante te dicen cual es el principio y el final de cada bobina, si, he de decir que ayer después de hacer tantas pruebas pues puse mal el secundario y tenía una perdida, hoy lo que colocado como es y ya da mas caña.

Según coilcraft los bobinado secuandarios se tiene que unir en paralelo en la pcb, yo he hecho como me indicas, les he puesto un diodo stocky a la salida de cada uno de los bobinados y luego los he unido en parlelo y luego he seguido el circuito con sus filtros y bobinas. hasta ahí la diferencia de unirlos después del diodo o antes es insignificante.

He tomado medidas por separado a cada bobina del secundario y las dos dan la misma tensión.

He tenido alguna duda con los bobinados, el secundario está claro pero en la zona del primario me confundía ese que pone Bias , a mi entender es el auxiliar y es el que va a la patilla 10 del LM y el mosfet va al primario que es donde se hace el trabajo.

Tengo algunas dudas con los condensadores, en las figuras del circuito son sin polaridad, entiendo que son condensadores de las capacidades de uf son de MKT o MKP, corrijanme si me equivoco, los de capacidades de pf son cerámicos. ¿los de capacidades de uF se podrían sustituir por electrolíticos de 105ºC como creo que mencionas más arriba o solo se podrían sustituir algunos dependiendo de donde están situados en el circuito?.

Ahora lo que me pasa es que me da la tensión de salida correcta y nada más ponerle una carga se viene la fuente abajo, los componentes están bien porque tengo más y los he sustituido y hacen lo mismo, creo que puede ser porque está montado en protoboard, mañana voy a ver si los monto en una placa de fibra que tengo que arruiné el montaje y la voy a utilizar para montar la fuente y uniré las patitas con cable de grapinar a ver la diferencia.

Otra duda que tengo es referente al diodo shunt, monté el divisor de tensión en un circuito a parte sin cargas, solo el divisor y a una tensión de 12v el divisor da 1,24v justos, le pongo el diodo zener y a su salida por la pata 5 da los 1,24v, hasta ahí perfecto, pero al colocar el optoacoplador con las resistencias de los cálculos ya no da la tensión a la salida del zener de 1,24v si no de 8v y en el divisor ósea la para 4 (Vref) hay 0,64v
según el dataseet del PC817 (ahora le puse este opto y va mucho mejor que el 4N35, el ajuste es más suave) la tensión máxima de diodo es de 1,4v con una intensidad de 20mA, ósea lo normal de los diodos led's y no está esa tensión está la tensión de 8v después de pasar por las resistencias que hemos calculado.

¿no se debería ajustar ese led a la tensión de 1v por ejemplo?.

Buscando por la red encontré un artículo que explica el funcionamiento de un diodo shunt y según el artículo diden que drena tan poca intensidad que no vale ni para alimentar un led, en los esquemas de implementación de ese zener, este está conectado a la base de un transistor que es el que soporta el trabajo del elemento a controlar, leyendo esto me pregunto ¿estará bien diseñado este esquema?, hasta en el datasheet del fabricante se ve el esquema del diodo excitando la base del un transistor.

Ufff que rollo me he metido  :oops:



 
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4311
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #16 en: 27 de Noviembre de 2014, 22:51:40 »
Hola KILLERJC, veremos:

Me entendiste mal Chaly, el trafo ES para ese circuito, pero la solucion que implemento el ( que es de cambiarle la frecuencia de oscilacion a una mucho mayor ) no es la solucion que deberia. Ya que con la resistencia que estaba antes la frecuencia de conmutacion era para ese trafo. Su problema es la realimentacion.

No te entendí mal, solo preguntaba si el trafo es para ese trabajo o nó, pero te entendí bien.

Tambien mirando los circuitos tipicos y funcionando como Shunt tanto del TL como del LMV

Se tiene una tension Vo = ( 1 + R1/R2 ) * Vref         Donde  R1 = R17 y R2 = R18

Es decir se busca una el divisor para que la tension de salida sea 12V, con lo cual los valores que dio Thulsa son correctos para el LMV.

Con esto estoy de acuerdo.

Ahora ya con este podemos pensarlo de otra forma. Sino:

12V --- filtro --- opto --- 12V(del shunt)

*El filtro es esa resistencia de 10 con el capacitor, un filtro pasa bajo.

Ante una variacion de la tension de la tension por ejemplo 13V, Existiria una diferencia de potencial de 1V entre la entrada y la tension que da el shunt pero ahora existiria una corriente. ( Los 1.24v son una tension de referencia que en ningun momento se trasladan al exterior. )
Entonces creo yo que con el divisor de tension esta bien. Y no deberias variar para nada R20, de variar R20 ante una diferencia de tension al modificarse la salida aumenta/disminuye la corriente que pasa por el diodo del optoacoplador. Para no superar los valores de corriente creo que no deberia superarse cierto umbral entre la tension a medir y lo que da el regulador.

En esta parte ya no estoy de acuerdo, como verás en el data sheet tanto del TL como del LMV estos funcionan con corriente, por lo que la resistencia R20 no está de gusto, si no que se encuentra para limitar la corriente máxima a circular por la serie, si no se quemaría o el opto o el TL/LMV y es por este motivo que hay que re-calcularla.

Si en la fuente aumentara la tensión de salida, lo que pasaría sería lo siguiente, en el divisor aumentaría la tensión de referencia, por lo que el LMV detectaría este aumento y por consiguiente aumentaría la intensidad de su cátodo haciendo que por el led del opto circulara más corriente, disminuyendo la tensión en el colector del Tr del opto, por consiguiente actuando el el IC controlador en consecuencia.

Pequeñas variaciones de tensión en la salida de la fuente por sí solas no hacen que el led del opto varíe mucho su corriente, acá el
encargado de generar esas grandes variaciones de corriente es el TL/LMV y esto es en base a la tensión que ingresa por su referencia y comparada con la referencia interna del mismo.

El TL/LMV no es solo un simple zener, es un circuito integrado bastante complejo, donde en su interior se encuentran un referencia de tensión de precisión, amplificadores operacionales, buffers, etc.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4311
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #17 en: 28 de Noviembre de 2014, 00:38:57 »
He estado haciendo pruebas y es verdad, la resistencia de la patilla 14 (RT) que es de 12.1K en el circuito, está ajustada para un frecuencia de 250KHz, justo la frecuencia que indica coilcraft que es para su transformador, la he medido con un osciloscópio y está clavada.
El bobinado está instalado tal como se ve en el esquema, si ven el datasheet del fabricante te dicen cual es el principio y el final de cada bobina, si, he de decir que ayer después de hacer tantas pruebas pues puse mal el secundario y tenía una perdida, hoy lo que colocado como es y ya da mas caña.
Según coilcraft los bobinado secuandarios se tiene que unir en paralelo en la pcb, yo he hecho como me indicas, les he puesto un diodo stocky a la salida de cada uno de los bobinados y luego los he unido en parlelo y luego he seguido el circuito con sus filtros y bobinas. hasta ahí la diferencia de unirlos después del diodo o antes es insignificante.

Para este caso, cuando el fabricante indica que los bobinados pueden ser unidos, es porque el trafo ya está diseñado y construido de manera tal que esta unión es posible, pero cuando este dato no está disponible los bobinados se deben trabajar por separados

He tomado medidas por separado a cada bobina del secundario y las dos dan la misma tensión. He tenido alguna duda con los bobinados, el secundario está claro pero en la zona del primario me confundía ese que pone Bias , a mi entender es el auxiliar y es el que va a la patilla 10 del LM y el mosfet va al primario que es donde se hace el trabajo.

En algunos circuito el BIAS es usado para alimentar el circuito integrado principal (como en este caso) y en otros casos el BIAS es usado para regular la tensión de salida del secundario.

Tengo algunas dudas con los condensadores, en las figuras del circuito son sin polaridad, entiendo que son condensadores de las capacidades de uf son de MKT o MKP, corrijanme si me equivoco, los de capacidades de pf son cerámicos. ¿los de capacidades de uF se podrían sustituir por electrolíticos de 105ºC como creo que mencionas más arriba o solo se podrían sustituir algunos dependiendo de donde están situados en el circuito?.

Capacitores electrolíticos menores de 1 uF es muy difícil de encontrar, por lo que la repartija queda de la siguiente manera:

Condensadores desde 0 y hasta 0.1uF serán cerámicos
Condensadores entre 0.1uF y 1uF serán MKP
Condensadores mayores de 1uF serán electrolíticos

Acordate que 1000000 pF = 1000 nF = 1 uF

Ahora lo que me pasa es que me da la tensión de salida correcta y nada más ponerle una carga se viene la fuente abajo, los componentes están bien porque tengo más y los he sustituido y hacen lo mismo, creo que puede ser porque está montado en protoboard, mañana voy a ver si los monto en una placa de fibra que tengo que arruiné el montaje y la voy a utilizar para montar la fuente y uniré las patitas con cable de grapinar a ver la diferencia.

Siempre para este tipo de circuito es mejor hacer la pruebas en PCB's, los protoboard acarean muchos problemas.

Otra duda que tengo es referente al diodo shunt, monté el divisor de tensión en un circuito a parte sin cargas, solo el divisor y a una tensión de 12v el divisor da 1,24v justos, le pongo el diodo zener y a su salida por la pata 5 da los 1,24v, hasta ahí perfecto, pero al colocar el optoacoplador con las resistencias de los cálculos ya no da la tensión a la salida del zener de 1,24v si no de 8v y en el divisor ósea la para 4 (Vref) hay 0,64v

Este efecto que acusa es porque esta no es la manera correcta de probar esa parte del circuito. Suponiendo que tú estés conectando todo bien, ya que la tensión de referencia no debería variar porque la tensión de la fuente no varía. Para probar esto, se debe conectar todo el circuito en serie con una resistencia adecuada y este conjunto conectarlo a una fuente mayor a la tensión que pretendes que regule, en este caso, por ejemplo a unos 15Vcc
Lo que te está pasando es que si bien tu fuente entrega los 12V que mencionas, no son exactamente iguales con los 12V a los que está "programado" el circuito (shunt, divisor, etc.) por lo tanto, el LMV esta detectando una variación de la tensión de salida de la "fuente" y está actuando en consecuencia.

según el dataseet del PC817 (ahora le puse este opto y va mucho mejor que el 4N35, el ajuste es más suave) la tensión máxima de diodo es de 1,4v con una intensidad de 20mA, ósea lo normal de los diodos led's y no está esa tensión está la tensión de 8v después de pasar por las resistencias que hemos calculado.

Pero tú mides la tensión entre los pines del opto? o mides con referencia a masa? Y si estas midiendo la tensión del diodo entre los pines del opto, desde ya te digo que tú opto esta dañado, y si es con referencia a masa, pues puede ser una tensión normal.

¿no se debería ajustar ese led a la tensión de 1v por ejemplo?.

Vuelve a medir esa tensión, pero esta ves entre los pines 1 y 2 del opto, si no te da próximo a 1Vcc desecha el opto.

Buscando por la red encontré un artículo que explica el funcionamiento de un diodo shunt y según el artículo diden que drena tan poca intensidad que no vale ni para alimentar un led, en los esquemas de implementación de ese zener, este está conectado a la base de un transistor que es el que soporta el trabajo del elemento a controlar, leyendo esto me pregunto ¿estará bien diseñado este esquema?, hasta en el datasheet del fabricante se ve el esquema del diodo excitando la base del un transistor.

Esto ya lo e aclarado en post anteriores, el circuito esta muy bien diseñado, el problema lo tienes tú con tus mediciones, o al ensamblar el circuito o en algún componente dañado, o simplemente los cálculos que realizamos están incorrectos.
Desde ya te digo que este circuito funciona perfectamente y como ya lo mencioné hay billones de fuente que lo usan y funcionan de maravillas.
El opto PC817 soporta un máximo de 20mA y el LMV soporta un máximo de 30mA, más que suficiente para alimentar cualquier led a su máximo potencial. Y ten en cuenta que estos optos están funcionando en su parte "lineal", por lo que la corriente que circula por ellos no está ni cerca de los 20mA máximos.
Quédate tranquilo que el error es nuestro y que el circuito bien diseñado y bien construido funciona de las mil maravillas.

Más allá de todo lo anterior, con la fuente en funcionamiento y cuando le conectas una carga:

Que tipo de carga es?
Que consumo produciría esa carga en una fuente de 12Vcc?
Que pasa con la tensión entre los puntos P15 y P16 de este circuito cuando conectas la carga y sin esta?
Que pasa con la tensión entre el punto P15 y masa cuando conectas la carga y sin esta?
Que pasa con la tensión entre el PIN10 y masa del circuito integrado cuando conectar la carga y sin esta?
Usaste todos los componentes indicados por el fabricante?
Que componentes usaste para el reemplazo?
Revisaste que todos los valores sean los correctos y que los componentes sean correcto para ese uso?
Estas seguro que el circuito que montaste esta bien realizado? (Mira que es un circuito bastante engañoso)

Un saludo y espero tú respuestas.

Atte. CARLOS.

« Última modificación: 28 de Noviembre de 2014, 00:45:32 por Chaly29 »
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7231
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #18 en: 28 de Noviembre de 2014, 00:49:01 »
En esta parte ya no estoy de acuerdo, como verás en el data sheet tanto del TL como del LMV estos funcionan con corriente, por lo que la resistencia R20 no está de gusto, si no que se encuentra para limitar la corriente máxima a circular por la serie, si no se quemaría o el opto o el TL/LMV y es por este motivo que hay que re-calcularla.

Si en la fuente aumentara la tensión de salida, lo que pasaría sería lo siguiente, en el divisor aumentaría la tensión de referencia, por lo que el LMV detectaría este aumento y por consiguiente aumentaría la intensidad de su cátodo haciendo que por el led del opto circulara más corriente, disminuyendo la tensión en el colector del Tr del opto, por consiguiente actuando el el IC controlador en consecuencia.

Pequeñas variaciones de tensión en la salida de la fuente por sí solas no hacen que el led del opto varíe mucho su corriente, acá el
encargado de generar esas grandes variaciones de corriente es el TL/LMV y esto es en base a la tensión que ingresa por su referencia y comparada con la referencia interna del mismo.

El TL/LMV no es solo un simple zener, es un circuito integrado bastante complejo, donde en su interior se encuentran un referencia de tensión de precisión, amplificadores operacionales, buffers, etc.

Un saludo.

Atte. CARLOS.

Puedo intentar entenderlo por su "analogo" donde muestra su salida BJT donde uno piense en su Ic, eso lo entiendo perfectamente y hasta escribi creo en alguna parte del hilo sobre la referencia de tension, AO, etc. ( nunca pense que fuera un simple zener, pero funciona igual ya que es un shunt ), ahora intenta seguir mi razonamiento ( no quiere decir que sea correcto) estas calculando la red divisora para que su salida sea "nula" ( estable ) a 12V. Es cierto que la diferencia puede ser mayor que con respecto con la salida de tension de 3.3V (Me refiero a tener una diferencia de 2V contra 0.5v cuando trabajas con 3.3v suponiendo),

Citar
Si en la fuente aumentara la tensión de salida, lo que pasaría sería lo siguiente, en el divisor aumentaría la tensión de referencia, por lo que el LMV detectaría este aumento y por consiguiente aumentaría la intensidad de su cátodo haciendo que por el led del opto circulara más corriente, disminuyendo la tensión en el colector del Tr del opto, por consiguiente actuando el el IC controlador en consecuencia.

Esta todo bien, el tema es como realiza eso que remarque.
A mi parecer si queres que responda con la misma linealidad ante la misma variacion de tension entonces deberia variar la corriente de la misma forma que antes ( me refiero a que si hay una entrada de 12.3V actue de la misma forma que con 3.6V ), por eso digo yo que la R20 no deberia tocarse, para que se entienda un poco mas, esa variacion de tension de 0.3V genere la misma cantidad de corriente sea la tension que sea. De incrementarla lo que estas haciendo que ante esa diferencia exista mucha menos corriente, y por lo tanto la salida del opto no variaria de la misma forma y es por eso que cae a 9V y se queda alli ( donde encuentra una corriente que genere el equilibrio ), espero que entiendas mi planteamiento del por que no anda o anda asi. Que tan errado estare realmente no se. Pero es algo que planteo como para que pruebe.

EDIT: Pensandolo bien sobre el funcionamiento, si es como decis que es un control de corriente y no tension, por que existe R20 ? No tendria por que existir. Ya que la corriente seria limitada por el LMV. Y por mas tension que tengas deberia solo consumir la corriente que dicte el LMV (si realmente regula corriente). Se me da por pensar por ejemplo los controladores para leds de corriente constante, lo que me lleva a pensar que R20 no es una resistencia limitadora (y mas que limitar la salida deberias limitar la entrada para que no exija al regulador que entregue mas de 30mA), sino que exista para compartir la tension con el opto pero no lo veo el caso (Seria parecido a lo de la control del led donde no se pone ni una resitencia). Ahora si es por tension, la resistencia R20 tiene su razon de existir, la diferencia de tension (Vcc - Vreg) + la resistencia te da un punto en tu opto que es la corriente Y la limitacion de lo que atravieza el regulador (Ya que si no tuvieras una resistencia la corriente seria infinita).

En esta parte ya no estoy de acuerdo, como verás en el data sheet tanto del TL como del LMV estos funcionan con corriente, por lo que la resistencia R20 no está de gusto, si no que se encuentra para limitar la corriente máxima a circular por la serie, si no se quemaría o el opto o el TL/LMV y es por este motivo que hay que re-calcularla.
The LMV431, LMV431A and LMV431B are precision 1.24 V shunt regulators capable of adjustment to 30 (1.24 V/30 V) V
Low Operation Current (55 µA)
Shorting the cathode to the adjust pin (voltage follower) provides a cathode voltage of a 1.24 V.

No veo donde diga que es por corriente. Hasta te dice que cortocircuitando esos pines te da una tension de salida y no una corriente. El regulador tiene un consumo que es de 55uA que es la minima corriente de catodo necesaria para que regule. Todo lo demas lo hace un "zener" (Al menos en su calculo)... excepto la parte "programable" con la referencia de tension y el AO. Ahora si lo pones directo tenes 1.24V y es el funcionamiento de lo que seria un zener comun de 1.24V donde te aseguras que la corriente sea mayor a 55uA y menos a 30mA con tu R20. Y si funciona como vos decis R20, pero el concepto atras yo pienso que esta equivocado, la unica forma de recalcularlo seria que cambiaras el opto para fijar un punto medio de la zona lineal.
La formula aplica a un shunt (Sacada de wikpedia en los zener):



Iz = consumo del regulador
IR2 = Corriente que atravesaria la resistencia

Como dije, Vo (Vz) te da 12V con ese divisor resistivo, y si observas lo unico que cambiaria es Vs que tambien seria 12V. En fin no deberias cambiar la resistencia. E incluso el circuito que provee el datasheet para una corriente constante esta lejos de ser lo que esta en el circuito y es mucho mas aproximado el circuito de tension.

Ufff que rollo me he metido  :oops:

No se vos pero yo me estoy divirtiendo, es lindo desmenuzar las cosas y ver como funcionan al punto del detalle. Ademas como ves estamos debatiendo sobre el funcionamiento del regulador, y es interesante ver el punto de vista de otras personas.
« Última modificación: 28 de Noviembre de 2014, 22:54:38 por KILLERJC »

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4311
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #19 en: 28 de Noviembre de 2014, 23:34:20 »
Hola KILLERJC, siempre es lindo discutir sanamente temas con alguien, siempre se aprende algo, y dos cabezas piensan mejor que una.

Entiendo tú punto de vista y el por que tú dices que no debería variar R20 y tiene su lógica. Pero con tú lógica incluso no haría falta R20 por lo tanto tú mismo te desmientes diciendo que "por algo está"  :D  :D  :D Que mambo que te metiste....

Hablando serio, o mejor escribiendo serio. Suponiendo por un minuto que la fuente entregará a la salida 24 Vcc (en ves de los 12 para que entiendas el ejemplo) todo anda perfecto, pero tú deseas colocar el valor original para R20 (el de texas instruments). Ahora ubícate a los pocos micro-segundos del momento del encendido, cuando la tensión está ascendiendo desde cero hacia el valor nominal (ya me parezco a Neil deGrasse Tyson de la serie cosmos :mrgreen:) nos pararemos cuando la salida está en torno a los 18V en la salida, el LMV le está tirando toda la corriente porque estamos muy lejos de los 24 deseados..... Que corriente circula en este momento por el led del opto? Con esa corriente cual sería el resultado?

Más allá de lo anterior y según tu razonamiento, la función de R20 es darle rango dinámico amplio al desplazamiento de corriente posible que pueda ejecutar el LMV. Pero si aumentamos la tensión de salida estamos reduciendo dicho rango, por lo que tendremos que re-calcular R20 para volver a ampliar ese rango.

Son simples razonamientos míos, por supuesto puedo estar equivocado. La mejor opción es que Thulsa Doom lo pruebe en la vida real y ver que pasa.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7231
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #20 en: 29 de Noviembre de 2014, 00:04:43 »
Entiendo tú punto de vista y el por que tú dices que no debería variar R20 y tiene su lógica. Pero con tú lógica incluso no haría falta R20 por lo tanto tú mismo te desmientes diciendo que "por algo está"  :D  :D  :D Que mambo que te metiste....

Si haria falta. A mi pensar no se si quedo muy claro, queria decir que el regulador ofrece una salida de tension. Y el tema era entre la diferencia de tension entre la entrada ( fuente ) y la proveida por el regulador, como primero pregunte en el primero post. ahora esa diferencia de tension (cuando se de) mayor o menor gracias a esa R20 existiria una corriente, si no por ley de ohm tendrias una corriente infinita.

Lo que yo decia de tu razonamiento sobre que el regulador controlaba corriente, como si el regulador manejara la corriente que lo atravieza (y no la tension y que luego atraves de la resistencia es una corriente), en este caso  si que la R20 no tendria sentido.

Citar
Más allá de lo anterior y según tu razonamiento, la función de R20 es darle rango dinámico amplio al desplazamiento de corriente posible que pueda ejecutar el LMV. Pero si aumentamos la tensión de salida estamos reduciendo dicho rango, por lo que tendremos que re-calcular R20 para volver a ampliar ese rango.

Estas aumentando la tension de salida PERO tambien estas aumentando la salida del regulador, no es que el regulador va a entregar 3.3 o 1.24v a la salida sino que con ese divisor resistivo son 12V. Por eso puse la formula de Vo que da el datasheet.

Citar
Hablando serio, o mejor escribiendo serio. Suponiendo por un minuto que la fuente entregará a la salida 24 Vcc (en ves de los 12 para que entiendas el ejemplo) todo anda perfecto, pero tú deseas colocar el valor original para R20 (el de texas instruments). Ahora ubícate a los pocos micro-segundos del momento del encendido, cuando la tensión está ascendiendo desde cero hacia el valor nominal (ya me parezco a Neil deGrasse Tyson de la serie cosmos Mr. Green) nos pararemos cuando la salida está en torno a los 18V en la salida, el LMV le está tirando toda la corriente porque estamos muy lejos de los 24 deseados..... Que corriente circula en este momento por el led del opto? Con esa corriente cual sería el resultado?

Ahi es el tema, jamas vas a tener 0V ofrecidos por el regulador, la tension no crece de golpe, esta filtrada, tiene una gran cantidad de capacitores, y a medida que crece la tension en el tiempo, tambien crece la tension a la entrada del regulador.

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 720
    • https://electronicaaficion.wordpress.com/
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #21 en: 01 de Diciembre de 2014, 15:29:24 »
Bueno,........vayamos por partes y paso a paso.

He desmontado todo el circuito y solo he montado la etapa del LM5070 y al parecer las tensiones están en sus rangos, solo tengo una duda que no entiendo muy bien en el datasheet, en la patilla 4 (UVLO), según la documentación esta pata tiene un voltaje de umbral de 2v, lo que no entiendo muy bien es lo que dice, según traduzco, por debajo de ese voltaje la salida PWM se anula y en rango normal de funcionamiento el voltaje no puede ser menos a 23v, por debajo de ese voltaje, la verdad que no sé muy bien lo que quiere decir.

Dejando de lado esto último, tal y como están los valores de los componentes el LM arranca y al parecer trabaja.

Al arrancar el sistema, la patilla 4 tiene un voltaje de 2.4v a 3v.(eso es medido entre la patilla 4 y el menos de los rectificadores) y mido con el osciloscópio la patilla 9 (OUT), ósea la salida PWM y tengo una señal cuadrada de 250KHz.

Pongo capturas de la pantalla del osciloscópio.
La señal PWM está en el canal de abajo, el de arriba que está con la línea en plano no hay nada conectado


Hasta ahí creo que vamos bien.

Llegado ha este punto y comprobando que la salida es buena, paso a montar el mosfet y ver el resultado.
Colocando el mosfet sin conectar el transformador la imagen a la salida que obtengo es esta.
La señal de la salida del LM está en el canal de abajo y la señal de la salida del mosfet está en el canal de arriba, se amplifica poco ya que al no tener la línea de la tensión conectada pues ya saben


Paso a la siguiente etapa que es colocar el transformador y ver el resultado.

en la imagen se puede ver el resultado, el canal inferior es la salida de la PWM del LM y en el canal de arriba es la salida del transformador, en este punto es cuando ta me empiezan las dudas, veo que la señal de la salida del LM ya no es cuadrada y solo es un pico y casi que se ve mal y tengo que amplificarla mucho para poder ver algo, y la salida del transformador se ve el pico y luego la señal amortiguada de la descarga de la bobina del trafo, no se si esto es normal o hay algún problema de filtrado en la malla que está en la patilla source del mosfet con el pin 13(CS) del LM.
No he calculado la frecuencia de la señal senoidal pero está muy por encíma de los 250KHz de la señal PWM


Esta misma señal de la salida del trafo también está en la salida del mosfet.


Creo que para poder montar el opto-acoplador y los filtros de salida del trafo primero he de conseguir que las etapas anteriores funcionen bien.

¿que opináis?


« Última modificación: 01 de Diciembre de 2014, 15:32:22 por Thulsa Doom »
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 720
    • https://electronicaaficion.wordpress.com/
Re: Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #22 en: 05 de Diciembre de 2014, 10:07:59 »
Hola a todos, pues ya he conseguido que esto funcione.  :-/ :-/ :-/ :-/ ((:-)) ((:-))

resulta que el esquema que viene en el datasheet tal y como está funciona perfectamente, solo hay que ajustar unas cosillas.
Hay que ajustar el divisor de tensión que alimenta el LMV431A, R17 a 130K y R18 a 15K, con eso tenemos con una tensión de 12v una tensión en el divisor que alimenta la patilla 4 del LMV a 1,24v, y las resistencias que alimentan al opto-acoplador (R16 a 100 ohmios y R20 a 5926 ohmios) tal y como se dijo en mensajes anteriores en este hilo, le doy las gracias a los compañeros  Chaly29 y KILLERJC que han ayudado aportando sus conocimientos

Lo otro que hay que ajustar y es la ganancia de la fuente es la resistencia R7, esa resistencia está conectada a la patilla 13(CS) del LM5070 y se regula la ganacia de la fuente


Lo tengo todo montado en protoboard, se que no es lo apropiado pero para mi es más cómodo de ajustar, no se consigue un funcionamiento 100% pero te acerca bastante.

El tema de esas resistencias es tan delicado que es muy difícil conseguir un ajuste perfecto con las resistencias normalizadas y las tolerancias pero para lo que yo lo quiero me sirve perfectamente.

voy a compartir unas fotos para que vean las señales en el osciloscópio y la tensiones.

Esto es la fuente en vacío, el canal 1 que esta en la parte inferior del osciloscópio es la señal PWM que sale de la pata 9 del LM y entra en la gate del mosfet, el canarl 2 que está más arriba es la salida del flyback, sin pasar por el diodo rectificador


Esta imagen es la fuente en carga y las señales no cambian


y Esta imagen es la práctica montada en la protoboard, está la fuente con el LM un PIC18F4620 y una tarjeta de red con eun ENC28J60 montado en otra protoboard



« Última modificación: 05 de Diciembre de 2014, 10:10:56 por Thulsa Doom »
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4311
Re: [SOLUCIONADO]Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #23 en: 07 de Diciembre de 2014, 21:57:15 »
Hola Thulsa Doom, me alegro de que te haya funcionado, y gracias por confirmar/contar tus resultados.

Muy lindo proyecto, es posible saber que es lo que estás queriendo construir? la curiosidad mata  :D

Un saludo y FELICIDADES !!!

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 720
    • https://electronicaaficion.wordpress.com/
Re: [SOLUCIONADO]Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #24 en: 08 de Diciembre de 2014, 07:54:28 »
Si claro, cuento...Esto ha sido un reto personal.... resulta que en mi trabajo hay muchos cuartos de cableados y estos cuartos están refrigerados por aires acondicionados y el proyectista que los ideó no contó con un sistema de alarma cuando estos aires fallen por cualquier causa.

Ya hemos tenido algún susto que otro porque ya se ha parado algún aire y el cuarto se ha puesto a 50ºC de temperatura, buscamos en el mercado una solución y no encontramos nada que se adapte a lo que queremos.

Pues por iniciativa propia y con ayuda de mis compañeros me puse manos a la obra y he ideado un sistema donde por medio de un pic, esté comprobando constantemente la tempeartura del cuarto y si se supera un valor de consigna envíe una trama por el protocolo telnet a un receptor, otro pic con lo mismo pero en lugar de tener una sonda de temperatura tiene un display donde aparece el cuarto que ha entrado en alarma y suena una sirena.

Por medio del protocolo telnet se puede entrar en cada tarjeta de cada cuarto de cableado y se puede comprobar la temperatura en tiempo real y se pueden cambiar parámetros de consigna y demás cosillas.

En teoría todo esto estará supervisado por un servidor donde se montará una web donde controlaremos en tiempo real cada cuarto en un sinóptico. (estoy muy flojo en programación web pero todo se andará)

Claro que podría haber alimentado la tarjeta con transformador normal y a correr pero lo suyo era montar una alimentación POE ya que los equipos implementan esta tecnología y sobre todo por superación personal, de todas maneras los prototipos llevan un conector para poder alimetarlas también con un transformador por si donde vaya a instalarla no haya POE

Con este proyecto llevo ya como 2 años y la razón es que no soy ingeniero si no técnico y lo voy haciendo a ratos mientras aprendo.

Cuando estudié electrónica no entro programación y por iniciativa propia y porque me encanta me metí a programar y cada vez he pillado más experiencia (gracias a la ayuda de este foro entre otros) y ya tengo un cierto nivel donde me siento muy cómodo con los códigos que hago, el código que he hecho funciona pero le falta pulir algo más y ahora ya tengo el hardware donde poder seguir desarrollandolo, me falta montarle una memoria externa para meter mas datos pero eso ya está probado en otros desarrollos y va fenomenal.

Lo mejor de todo que con este desarrollo no seremos cautivos de ninguna compañía que cuando tengas un problema se aprovechen de la situación y tampoco de la dichosa obsolescencia programada

También he migrado el código para utilizar un PIC18F97J60 que ya tiene la tarjeta integrada pero esa será la versión 2.0 del proyecto  :D :D

Ya saben, si alguien quiere montar una fuente POE puede preguntarme y estaré encantado de ayudar en la medida de lo posible
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7231
Re: [SOLUCIONADO]Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #25 en: 08 de Diciembre de 2014, 12:44:04 »
Y al final estaba equivocado yo :3

Y a pesar que lo lei y sabia para que servia el pin CS no me di cuenta al pensar de cambiar esa R7.

Santos protoboards batman! Ahora ya no se como puede que ande eso  :D

PD: El unico que aporto conocimientos es Chaly yo vine a molestar :3

Desconectado Thulsa Doom

  • PIC24F
  • *****
  • Mensajes: 720
    • https://electronicaaficion.wordpress.com/
Re: [SOLUCIONADO]Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #26 en: 08 de Diciembre de 2014, 16:39:58 »
Que va hombreeeeee, todos han ayudado, simplemente el estar ahí opinando es una ayuda.

El truco de este montaje está entre la resistencia R7 que es donde regulas la ganancia de la fuente en carga y la resistencia R20 que es donde controlas la intensidad del diodo del opto, por lo que comprobé, no es muy importante dejar en 1.24v el divisor de tensión ya que el zenner tiene un rango de trabajo que va desde 1,24v a 30v, lo importante es limitar la corriente del diodo del opto para que trabaje dentro del rango estable.

Lo que hice fue, en carga le ajusto la ganancia hasta 12v y en vacío la resistencia del diodo y queda perfecto cuando trabaja en carga

al final casi siempre las soluciones son una chorrada lo que hay que dar con ellas y eso lleva tiempo y romper algún que otro circuito  :oops:
Más códigos y desarrollos en https://electronicaaficion.wordpress.com/ date una vuelta y curiosea un rato...

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4311
Re: [SOLUCIONADO]Ayuda con LM5070 (Integrado para hacer una fuente POE)
« Respuesta #27 en: 08 de Diciembre de 2014, 21:50:29 »
Hola Thulsa Doom y KILLERJC.

Thulsa Doom, muy buen proyecto, muy completito por lo que cuentas.... No hace falta ser ingeniero para poder hacer un buen proyecto, es más de seguro muchos "ingenieros" no podrían hacer ni la mitad de lo que ya tienes. Así que a no flaquear y para adelante colega TECNICO. Yo en mi caso me hago llamar técnico, pero no tengo título y ni siquiera hice el más simple curso de electrónica, todo de manera autodidacta, así y todo trabajo reparando electrónica....  ;-)

KILLERJC, no trata de quien tiene la razón o no, esta ves le puedo haber acertado yo, la próxima puedes ser tú, si todos supiéramos de todo ¿para que serviría un foro? Lo importante es si tanto vos como Thulsa Doom han aprendido algo, con eso ya me quedo satisfecho, yo por mi parte y con la "discusión" que hemos montado e aprendido a analizar o ver un circuito desde otro punto de vista, me has hecho pensar y eso me gusta, y aunque tú teoría no fuera acertada a mi me valió para aprender y eso es lo bueno y rescatable de los foros.

Un saludo a ambos y espero en un futuro poder seguir "discutiendo" con ambos.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.