Autor Tema: Problema de ruido electromagnético muy extraño  (Leído 1118 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado RodrigoAndres

  • PIC16
  • ***
  • Mensajes: 171
Problema de ruido electromagnético muy extraño
« en: 02 de Noviembre de 2015, 12:37:38 »
Saludos a todos. tengo un problema de ruido electromagnético que no logro solucionar:

Tengo un transformador de 120v a 12v y de 500 mA. El problema que tengo es que cuando conecto o desconecto el transformador de la red electrica, hace que el arduino deje de funcionar. el arduino lo tengo conectado y alimentado de la computadora por cable USB.

El problema es de interferencia electromagnética, ya que hice la siguiente prueba:

Desconecte el arduino totalmente del circuito, solo conectado a la PC por el cable USB y lo coloce a 30 cm del transformador.
Desconecte el transformador de todo circuito.

E incluso en estas condiciones, al momento de enchufar o desenchufar el transformador de la red electrica, el arduino se colapsa y deja de funcionar. Lo que me pregunto es que tecnica o metodo puedo emplear para que el transformador no emita ese ruido electromagnetico al momento de ser conectado o desconectado?

habia pensado en unir la carcasa del transformador y la tierra de la red electrica, pero no estoy seguro de eso, espero sus consejos.

Otra cosa que noté es que el ruido electromagnético se reduce si conecto a la entrada del transformador una resistencia de 10K con un capacitor de 1 nF, ambos en paralelo. Sin embargo, todavia sigue habiendo mucho ruido que no logro suprimir y hace que en ocasiones al momento de conectar/desconectar, el arduino colapse.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Problema de ruido electromagnético muy extraño
« Respuesta #1 en: 02 de Noviembre de 2015, 14:01:22 »
Hola RodrigoAndres, definitivamente tu Arduino no está debidamente filtrado., puedes probar colocándole un capacitor de 0.1uF conectado entre los pines de alimentación del micro y lo más próximos posible a estos.

La otra posibilidad es que hagas una serie RC para conectarla en paralelo a la entrada del transformador, usa una resistencia de 100 ohms y un capacitor de 10nF x 630V de aislación.

Espero te sea de ayuda.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado RodrigoAndres

  • PIC16
  • ***
  • Mensajes: 171
Re:Problema de ruido electromagnético muy extraño
« Respuesta #2 en: 02 de Noviembre de 2015, 14:15:15 »
Saludos, gracias por la sugerencia. Solo haciendo esto he logrado reducir el ruido del transformador de una manera considerable:



Me imagino que eso trabaja como el filtro RC que mencionaste, filtrando los picos de voltaje al momento de conectar/desconectar el transformador.

De todas formas me parece muy extraño que el arduino sea tan exageradamente sensible al ruido electromagnetico. Con un microcontrolador PIC nunca tuve ese tipo de problemas, y eso que era en protoboard.

En cuanto al arduino, tendria que ver bien que es lo que pasa ya que cada vez que se cuelga tengo que cambiarle el puerto para poder comunicarme con el por la PC. Esto ya iria en un foro de arduino.


Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Problema de ruido electromagnético muy extraño
« Respuesta #3 en: 02 de Noviembre de 2015, 14:31:08 »
RodrigoAndres, entendí perfectamente lo que as implementado para filtrar la entrada, pero está mal aplicado y los valores no son los correctos.

La resistencia debe de ser de 100 ohms y el condensador de 10nF y estos deben de estar en serie y no tal como tu los pusiste.

Esto es de lo que te hablo:


* TZkFD.jpg
(11.09 kB, 292x214 - visto 298 veces)


Otro tema es que la fuente de alimentación de una PC no está completamente aislada de la red eléctrica domiciliaria, por lo tanto, y por medio del cable de USB parte de la tensión de la red llega a tu Arduino y con esta tensión también llegan las interferencias de la línea de alimentación.

Si al USB lo usas solo como alimentación del Arduino, pues te recomiendo que construyas una fuente propia para alimentarlo, con un transformador, regulador rectificado y condensadores. De esta manera ya le será muy difícil a las interferencias de la red eléctrica de la casa llegar a tu Arduino, aparte conseguirás una aislación total de la misma.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado RodrigoAndres

  • PIC16
  • ***
  • Mensajes: 171
Re:Problema de ruido electromagnético muy extraño
« Respuesta #4 en: 02 de Noviembre de 2015, 15:27:43 »
Gracias por tus consejos. He hecho una serie de pruebas combinando el circuito que hice con el que me aconsejaste y conectandolo de diferentes maneras.
 he concluido que el circuito que mas reduce el ruido electromagnético que emite el transformador es el siguiente



Asi no se colgó en ninguna de las veces que lo conecte/desconecte.
se tambien que la resistencia de 100 provocaria una caida de tension considerable, pero como el circuito  consume solo unos cuantos miliamperios, el voltaje solo se cae 1V.

Lo que me pregunto es el desfase, no estoy seguro cual de estas formulas es:

desfase = -arctan(Fc/F)

o

desfase = 90 - arctan(Fc/F)
« Última modificación: 02 de Noviembre de 2015, 15:34:03 por RodrigoAndres »

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7851
Re:Problema de ruido electromagnético muy extraño
« Respuesta #5 en: 02 de Noviembre de 2015, 15:47:05 »
Bueno, por lo menos vas a pagar menos gas con eso, ya que lo que va a calentar la resistencia de 10K no tiene precio xD, 5W o mas si o si.

Desconectado RodrigoAndres

  • PIC16
  • ***
  • Mensajes: 171
Re:Problema de ruido electromagnético muy extraño
« Respuesta #6 en: 02 de Noviembre de 2015, 16:13:33 »
Bueno, por lo menos vas a pagar menos gas con eso, ya que lo que va a calentar la resistencia de 10K no tiene precio xD, 5W o mas si o si.

De todas maneras no me importa mucho, solo serian 1.5 watios de consumo, con una de 2W los soporta perfectamente. o es eso o es armar un transformador miniatura que no emita tanto ruido electromagnetico, para lo cual no tengo el tiempo ni las ganas.

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7851
Re:Problema de ruido electromagnético muy extraño
« Respuesta #7 en: 02 de Noviembre de 2015, 16:20:28 »
No se por que asumis que van a ser 1.5W

(220V ^ 2) / 10K = 4.84 W

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Problema de ruido electromagnético muy extraño
« Respuesta #8 en: 02 de Noviembre de 2015, 17:15:20 »
Hola RodrigoAndres, puedes sacar las cuentas que desees, pero esa resistencia de 10K no tiene sentido que esté ahí, lo único que haces es calentar, porque eléctricamente hablando no sirve para nada.

Y vuelvo a repetirte, la resistencia y el condensador deben de estar en serie, ahí lo que armaste es un circuito tanque, donde las oscilaciones están a la orden del día.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.


 

anything