Autor Tema: Error en el CAM de Eagle  (Leído 743 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado planeta9999

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3520
    • Pinballsp
Error en el CAM de Eagle
« en: 13 de Noviembre de 2016, 20:45:29 »
.

hola.

Me está pasando algo raro con el CAM de Eagle, solo es con un componente, un micro Kinetis de NXP, encapsulado QFN32 con pad central de disipación. Me he bajado el BXL de la web de NXP y con Ultralibrarian he generado el script para Eagle, lo he ejecutado y he generado el componente en una librería mía.

El problema es que al ejecutar el CAM, me sale un aviso "Package contains a polygon that may cause extremely large plot data". Sospecho que es por la capa tCream para el pad central de disipación. He editado el componente y no veo nada especial, hay cuatro cuadrados en la capa tCream del pad.

¿ Se os ocurre cual puede ser el problema y como eliminarlo ?, supongo que si quito esos cuatro polígonos se resolverá, pero entonces no se que saldrá si mando hacer el Stencil, porque el pad es bastante grande. En alguna ocasión he visto que componentes con pad de disipación, al pedir el stencil, en vez de salir todo lo que es el pad, salen pequeños cuadrados.







Desconectado planeta9999

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3520
    • Pinballsp
Re:Error en el CAM de Eagle
« Respuesta #1 en: 14 de Noviembre de 2016, 11:53:32 »
.

Resuelto el problema, aunque desconozco las consecuencias de hacerlo de una manera u otra. Como sospechaba los polígonos que hay en la capa tCream para el pad de disipación eran los culpables. Esos polígonos están creados con ancho de trazo a 0, y eso hace que el CAM se vuelva loco y se tire una eternidad generando los Gerber.

Si le cambio el trazo a uno muy fino, pero que no sea 0, ya se genera el Gerber rápido, lo que no se es que diferencia habrá en el stencil de hacerlo de una manera u otra.