Autor Tema: Cargador MCP73837  (Leído 618 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado cvargcal

  • PIC16
  • ***
  • Mensajes: 162
Cargador MCP73837
« en: 20 de Enero de 2017, 18:26:58 »
Saludos,
No se si es corrector hacer este tema aquí, pero igual es de microprocesadores.
Estoy haciendo un circuito para cargar la batería que alimenta un micro a 3.3V y al mismo tiempo alimenta un modulo gprs directamente desde la batería. asi:



Según  el manual del cargador recomienda un PFET FTKY para hacer la comuntacion entre la alimentación con cable y alimentación desde la batería.El circuito funciona bien, pero solo cuando esta conectado al puerto USB.
Alimenta el gprs a 4.2V y la fuente del micro esta a 3.3V, ahí todo es perfecto.... pero, cuando desconecto el usb, se supone que debería seguir así: 4V a 3.7V y el micro a 3.3V, pero no. el voltaje de modulo gprs se cae a 3.4 pero el micro si esta a 3.3V

http://ww1.microchip.com/downloads/en/DeviceDoc/22071B.pdf  cargador
http://www.mouser.com/ds/2/308/NTMD4184PF-D-115134.pdf     FETKY
http://www.mouser.com/ds/2/115/AP7215-59688.pdf                    Fuente 3.3V

No se en que estoy fallando.

Creo que funciona con USB, porque obvio los 4.3V pasan por el diodo, va al GPRS (3.7V) y después al regulador de 3.3V.
si hago un puente entre batería y el catado, funciona bien cuando desconecto el usb, pero no tiene sentido hacer eso.
« Última modificación: 20 de Enero de 2017, 18:35:33 por cvargcal »

Desconectado elreypic2

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1023
Re:Cargador MCP73837
« Respuesta #1 en: 20 de Enero de 2017, 22:19:47 »
Que tal cvargcal,

Si no me estoy equivocando, creo que tienes mal conectado el mosfet hacia la bateria. La bateria deberia estar conectada al Source del MOSFET y tu lo tienes en el Drain. Solo tienes que invertir las terminales del S/D del mosfet.

elreypic.

Desconectado cvargcal

  • PIC16
  • ***
  • Mensajes: 162
Re:Cargador MCP73837
« Respuesta #2 en: 21 de Enero de 2017, 02:00:21 »
Que tal cvargcal,

Si no me estoy equivocando, creo que tienes mal conectado el mosfet hacia la bateria. La bateria deberia estar conectada al Source del MOSFET y tu lo tienes en el Drain. Solo tienes que invertir las terminales del S/D del mosfet.

elreypic.

Ohh creo que ese es el error...  :/
Gracias.


 

anything