Autor Tema: gprs no responde a comando  (Leído 122 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado micronet3

  • PIC16
  • ***
  • Mensajes: 236
gprs no responde a comando
« en: 22 de Enero de 2018, 14:15:11 »
saludos , gracias por la respuesta

tengo un modulo gprs el cual le envio los comandos desde la pc y responde perfectamente , pero cuando trato de enviar comandos desde el pic no responde.

uso el siguiente codigo
 Printf("AT");putc(13);putc(10);
esto simplemente para que me devuelva un ok, pero nada

a que se puede deber
gracias

Desconectado micronet3

  • PIC16
  • ***
  • Mensajes: 236
Re:gprs no responde a comando
« Respuesta #1 en: 23 de Enero de 2018, 12:27:08 »
pucha ya no se que pasa
desde la pc he enviado la respuesta al pic y funciona perfectamente, heconectado el sim808 directo a la pc y tambien funciona, pero cuando conecto el pic con el sim808 no pasa nada, ya he revisado todo y no se que pasa
 :? :? :? :? :5] :5]

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 6287
Re:gprs no responde a comando
« Respuesta #2 en: 23 de Enero de 2018, 13:26:11 »
Pienso que deberias ver sies una buena fuente de alimentacion, por ahi esos modulos consumen moderadamente. La otra es que revises exactamente caracter por caracter cual si se esta enviando lo mismo, y tambien si las velocidades son las correctas.

Desconectado micronet3

  • PIC16
  • ***
  • Mensajes: 236
Re:gprs no responde a comando
« Respuesta #3 en: 24 de Enero de 2018, 08:59:09 »
 :-/ :-/ :-/
ya lo solucione, el problema era que el modulo gprs estaba configurado para trabajar con señales de 5V y yo le estaba enviando  3.3v.

saludos KILLERJC gracias


 

anything