Autor Tema: Problemilla con SIM800L  (Leído 378 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado vicentek6

  • PIC10
  • *
  • Mensajes: 14
Problemilla con SIM800L
« en: 04 de Febrero de 2019, 15:16:31 »
Saludos. No consigo registrarme con ningún sim800l, he probado con estos dos modelos:
modelo 1:
https://irishelectronics.ie/epages/950018241.sf/en_IE/?ObjectPath=/Shops/950018241/Products/SIM800L
modelo 2:
https://hetpro-store.com/mini-modulo-sim800l-gprs-gsm/
---
Es curioso, pero con el escaneo automático de operadora sólo me aparece Amena, tanto en un módulo como en el otro?¿?
---
AT+COPS=?
+COPS: (3,"Retevision Movil","AMENA","21403"),,(0-4),(0-2)

OK
---
He trabajado bastante con el modulo sim900a, y éste me funciona ok. La alimentación es la misma (las especificaciones lo son) y creo está correcta:
----
AT+CBC
+CBC: 0,85,4081

OK
----
Por supuesto, el pin está ok. El sim900 empezaba el registro automático nada más introducir el pin
----
AT+CPIN?
+CPIN: READY

OK
----
Una cosa curiosa es que la lista de operadores preferidos me aparece en modo numérico:
----
AT+CPOL?
+CPOL: 1,2,"20801"
+CPOL: 2,2,"20820"
+CPOL: 3,2,"23410"
+CPOL: 4,2,"26806"
+CPOL: 5,2,"26803"
+CPOL: 6,2,"22201"
+CPOL: 7,2,"26207"
+CPOL: 8,2,"20408"
+CPOL: 9,2,"60400"
+CPOL: 10,2,"23203"
+CPOL: 11,2,"22802"
+CPOL: 12,2,"27202"
+CPOL: 13,2,"334030"
+CPOL: 14,2,"20210"
+CPOL: 15,2,"22610"
+CPOL: 16,2,"22603"

OK
---
Pero no creo que influya. Los dos módulos, diferentes, hacen lo mismo.
Alguna idea?
Saludos

Desconectado vicentek6

  • PIC10
  • *
  • Mensajes: 14
Re:Problemilla con SIM800L
« Respuesta #1 en: 04 de Febrero de 2019, 15:18:09 »
Ah!, los IMEI no están en la lista negra: http://www.imeipro.info/

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17666
    • MicroPIC
Re:Problemilla con SIM800L
« Respuesta #2 en: 04 de Febrero de 2019, 15:43:56 »
¿Has probado con otra SIM?
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado vicentek6

  • PIC10
  • *
  • Mensajes: 14
Re:Problemilla con SIM800L
« Respuesta #3 en: 05 de Febrero de 2019, 06:58:41 »
Probaré con otra SIM... Pero el que gasto de Movistar funciona ok en el SIM900A.

Desconectado vicentek6

  • PIC10
  • *
  • Mensajes: 14
Re:Problemilla con SIM800L
« Respuesta #4 en: 05 de Febrero de 2019, 15:57:37 »
He probado con una vodafone, y sigue igual... Puede ser problema de firmware, o de configuracion.
Alguien gasta un sim800l por aqui?
Me puede pasar su profile (AT&V)?
Gracias!

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17666
    • MicroPIC
Re:Problemilla con SIM800L
« Respuesta #5 en: 05 de Febrero de 2019, 17:04:35 »
Yo estoy con un SIM868, si te sirve algo dímelo
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado vicentek6

  • PIC10
  • *
  • Mensajes: 14
Re:Problemilla con SIM800L
« Respuesta #6 en: 06 de Febrero de 2019, 02:02:53 »
Tiene buena pinta...
Investigaré éste: https://www.electrodragon.com/product/sim868-mini-development-board/
Gracias por contestar


 

anything