Autor Tema: consulta display no enciende  (Leído 322 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado artemis

  • PIC10
  • *
  • Mensajes: 26
consulta display no enciende
« en: 15 de Marzo de 2020, 16:09:15 »
hola gente estoy tratando de conectar un display LCD 2x16 modelo 1602A con el PIC16F876A resulta que en los pines de alimentación tengo conectado el VDD y VEE a los 5V y el VSS al negativo pero el display no da imagen, a que se debe?? Estuve testeando que están llegando los 5V al display pero no se por qué no anda

saludos.

Desconectado Fer_TACA

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3508
Re:consulta display no enciende
« Respuesta #1 en: 15 de Marzo de 2020, 16:52:46 »
¿Has probado a colocar un potenciómetro entre +5v y 0V con su punto central a VEE?
Puede ser que tengas que regular el contraste.
Hay LCD que tienen retroiluminación, comprueba si la tienes activada.

F.

Desconectado artemis

  • PIC10
  • *
  • Mensajes: 26
Re:consulta display no enciende
« Respuesta #2 en: 15 de Marzo de 2020, 18:22:25 »
¿Has probado a colocar un potenciómetro entre +5v y 0V con su punto central a VEE?
Puede ser que tengas que regular el contraste.
Hay LCD que tienen retroiluminación, comprueba si la tienes activada.

F.
logré que encienda pero no muestra el texto, este código para mostrar texto es correcto??
   
    lcd_init();
    lcd_gotoxy(1,1);
    LCD_PUTC("VELOCIDAD MOTOR");
Tengo conectado en el bus de datos los pines D4-D5-D6-D7 a B4-B5-B6-B7 y los pines de control RS,RW,E conectados a C3-C4-C5 respectivamente, adjunto una parte del esquema en proteus
 

* Sin título.png
(129.6 kB, 1378x858 - visto 66 veces)

Estoy utilizando la librería FLEX_LCD donde tengo definido lo siguiente:
#define LCD_DB4   PIN_B4
#define LCD_DB5   PIN_B5
#define LCD_DB6   PIN_B6
#define LCD_DB7   PIN_B7

#define LCD_RS    PIN_C3
#define LCD_RW    PIN_C4
#define LCD_E     PIN_C5
« Última modificación: 15 de Marzo de 2020, 18:49:33 por artemis »

Desconectado elreypic2

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1163
Re:consulta display no enciende
« Respuesta #3 en: 16 de Marzo de 2020, 12:49:41 »
Que tal artemis,

Lograste hacer funcionar tu lcd?

elreypic.

Desconectado artemis

  • PIC10
  • *
  • Mensajes: 26
Re:consulta display no enciende
« Respuesta #4 en: 16 de Marzo de 2020, 13:16:16 »
Que tal artemis,

Lograste hacer funcionar tu lcd?

elreypic.
hola rey que tal? sisi logré que encienda, era por el backlight . El tema ahora es que no me muestra los datos en pantalla.. no se si es por algún error en el código o tengo que modificar alguna conexión??


 

anything