Autor Tema: hiperterminal y compin  (Leído 3074 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado cdlopez

  • PIC10
  • *
  • Mensajes: 39
hiperterminal y compin
« en: 26 de Agosto de 2006, 18:36:25 »
Hola amigos:

Estuve buscando en el foro y no pude encontrar un respuesta que me satisfaga del conocido tema de compin, hiperteminal y Vterm,
Estoy haciendo una placa de adquisicion de datos de dos canales con el pic 16F873, del que me permita ver la variable a medir tanto en un lcd y a la vez transmitir serialmente esos mismos datos a la pc y visualizarlo en el hiperterminal.
En la simulacion del proteus funciona todo muy bien, ademas al prgrama del micro esta en picbasic y los calculos estan echo en punto flotante para dar mayor presicion en el calculo (picbasic pro con punto flotante es un dolor de cabeza pero funciona bien), La vterm conectada al max232 funciona perfecto y me mustra los mismos valores que el lcd, cuando conecto la hiperterminal a traves de un com3 virtual (virtual serial port) enlaza el compin por el com2 tambien virtual, creado ambos puertos por el virtual serial port,... en la hiperterminal recibo caracters "basura" y no pude lograr que me mustre lo mismo que la Vterm.

Adjunto un esquema del circuito que estoy haciendo si alguin podria decirme en que parte me estoy equivocando les estaria agradecido.

nos vemos

Desconectado cdlopez

  • PIC10
  • *
  • Mensajes: 39
Re: hiperterminal y compin
« Respuesta #1 en: 27 de Agosto de 2006, 17:08:10 »
Hola:

Ya encontre el problema. El COMPIN no puede ir conectado despues del MAX ya que eso me da un error en la transmision. lo conecte directamente al pin del micro encargado de la transmision serial y se soluciono el problema. :D :-)

Saludos. :-/

Cristian

Desconectado maritov

  • Colaborador
  • PIC16
  • *****
  • Mensajes: 121
Re: hiperterminal y compin
« Respuesta #2 en: 03 de Agosto de 2007, 15:30:26 »
Hola cdlopez, estoy con un proyecto similar al tuyo. Y tengo una duda que no me anima a seguir:
¿Como trataste el tema de aislacion entre la fuente de señal (en mi caso son sensores con salida de 4-20mA) y el PIC?
Me hablaron de un aislador galvanico, pero el mismo cuesta mucho dinero y el presupuesto se me iria por las nubes.
Espero me puedas ayudar.
Saludos


 

anything