Autor Tema: Puente H  (Leído 18403 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Puente H
« en: 07 de Julio de 2007, 19:35:50 »
Hola, he visto un puente en h que me parece muy facil de montar y he visto que solo lleva 4 transistores tip41. En otros puente h que he visto hay otros transistores tipo 2n3904,bc547... para controlar los transistore tip41 o tip31.



¿Se pueden conectar directamente los tip41 a las salidas del pic?

Si no es asi, me podrian ayudar?

Saludos.
« Última modificación: 07 de Julio de 2007, 19:48:10 por Trust »

Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #1 en: 08 de Julio de 2007, 12:21:39 »
Hola, se que no se pueden conectar directamente los tip41 a las salidas del microcontrolador.

Necesito una ayuda, primero intente hacer un puente en h con transistores mosfet y se me calentaban mucho o no funcionaban, he probado 3 circuitos diferentes con transistores mosfet sin exito.  :(

Ahora estoy probando con transistores tip41 y tip42 en un circuito que saque del Isis, en concreto es el que hay en Samples - Motor examples - HC11PWM.DSN. He sustituido los tip31 por tip41 y los tip32 por tip42. En ese circuito no hay diodos 1N4001 pero yo si que se los he puesto. He probado este circuito y no me funciona.  :(

Necesito ayuda, los L298N se me quedan cortos para mis motores, asi que no tengo mas remedio que hacer un puente en H.

Gracias de antemano.
Saludos.

Desconectado migsantiago

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8257
    • Sitio de MigSantiago
Re: Puente H
« Respuesta #2 en: 08 de Julio de 2007, 12:47:55 »
Hola

En el circuito que pones se puede conectar directamente la salida de 5V de una terminal de cualquier PIC.

Para hacer avanzar al motor...



La demanda de corriente de los dos tip41 al pic es de 8.6mA usando la R de 1k, estás dentro de lo permitido.


Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #3 en: 08 de Julio de 2007, 12:52:14 »
Hola migsantiago, muchas gracias.  :P
voy a probar el circuito a ver si me funciona que ya llevo mucho tiempo con el tema del puente en H.
Ya te contare si me ha funcionado o no.

Muchas gracias.
Saludos.

Desconectado ESTECA55

  • PIC24H
  • ******
  • Mensajes: 1404
Re: Puente H
« Respuesta #4 en: 08 de Julio de 2007, 12:57:21 »
Hola, si el L298 te queda corto podes usar el L6203, este es un puente H de 5A, solo contiene un puente H a diferencia de los dos que trae el L298.  Para que es para controlar un paso a paso???

Saludos
Hay que esforzarse por ser el mejor, no creerse el mejor

Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #5 en: 08 de Julio de 2007, 13:01:58 »
Hola ESTECA55, es para controlar un motor de 12V que he sacado de una maquina de taladrar a baterias.

Primero opte por controlarlo por transistores mosfet porque con el L298N se me calentaba muchisimo al instante. Al fracasar con los mosfet despues de varios intentos probe con los tip41 y tip42 y tambien fracase.
La opcion que me dices de usar el L6203 la probare si no me funciona el puente en H que estoy probando ahora.

Muchas gracias.
Saludos.

Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #6 en: 08 de Julio de 2007, 17:17:35 »
Hola, he hecho el puente en H que tiene 4 tip41 conectados directamente al pic y alimentados por una bateria recargable de 12V y 5Ah, pues he comprobado la bateria que esta cargada al maximo y el puente en h funciona pero solo me da 90 miliamperios:(

Por lo tanto con esa intensidad el motor le cuesta ponerse en marcha y le tengo que ayudar. :(
¿porque si tengo una bateria de 12V y 5Ah con este puente en H solo me da 90 miliamperios?  :shock:

Si los Tip41 pueden dar 6A continuos y 10 no continuos, porque me esta pasando esto?
Ya ven que no soy capaz de entender todo eso, agradeceria mucho una ayuda.

Gracias de antemano.
Saludos.

Desconectado migsantiago

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8257
    • Sitio de MigSantiago
Re: Puente H
« Respuesta #7 en: 09 de Julio de 2007, 11:41:05 »
Hola

Cuando alimentas el motor, ¿se cae el voltaje de la batería?

Esas baterías al terminar su vida útil se comportan de manera suspicaz. Si no tienen carga te dan 12V perfectos, pero... al aplicarles carga, pierden voltaje por completo.

Con las terminales que alimentas las bases de los TIP41... ¿tienes conectado algo más a ellas? La terminal de un pic puede entregar 25mA máximo, si conectas un led en paralelo o algo por el estilo puede que el transistor no se cierre.


Desconectado vszener

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2395
Re: Puente H
« Respuesta #8 en: 09 de Julio de 2007, 12:51:55 »
Si estás usando MOSFET tienes que ver en que región estás trabajando al igual que los bipolares, para calcular la intensidad que te están suministrando con los parámetros externos.


Suerte!!! ;)
· Nos vemos en los bares!!!!!
· Mi Blog: Aqueronte

Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #9 en: 09 de Julio de 2007, 19:22:16 »
Hola migsantiago y vszener, muchas gracias por vuestra ayuda.

El voltaje de la bateria no cae porque, las baterias son nuevas y los motores que estoy probando son pequeños de 3V, los motores de 12V los probare cuando me funcione bien con los de 3V.

Solo tengo conectados a las salidas del pic los Tip41.

Sabeis alguna forma de comprobar si los Tip41 estan en buen estado?
Yo creo que si estan bien porque son nuevos pero para asegurarme los probaria en algun circuito sencillo para saber si entran en corte o saturacion como es debido.

No dispongo de mucho tiempo para hacer pruebas pero hare todo lo que pueda para solucionarlo con la ayuda que me dais, que es mucha y estoy muy agradecido.

Con lo facil que es usar el L298N y lo que me esta costando hacer esto.

Muchas gracias.
Saludos.
« Última modificación: 09 de Julio de 2007, 19:24:24 por Trust »

Desconectado navaismo

  • Jubilado Todopic
  • PIC24H
  • ****
  • Mensajes: 1973
Re: Puente H
« Respuesta #10 en: 09 de Julio de 2007, 20:13:09 »
Y tienes la resitencia entre el PIC y el TIP. A mi me paso que no funcionaban por eso yo usaba unos TIP31C y sin la resitencia entre el pic y el tip no funcionaba con la resitencia jalo perfectamente.
"Mi tercer deseo, que otra cosa podría ser, poner un final a todo el sufrimiento, que sólo con mi propia extinción el planeta podrá ser aliviado. Pobre de mí, Si tuviera tres deseos hoy, la elección no sería dificil para mí, Sólo tres deseos serían suficientes, No tendría uso para más."

"He sido un hombre que busca y aun lo sigo siendo, pero ya no busco en las estrellas y en los libros, sino en las enseñanzas de mi sangre."

Desconectado migsantiago

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 8257
    • Sitio de MigSantiago
Re: Puente H
« Respuesta #11 en: 09 de Julio de 2007, 20:21:12 »
Mmhhh se pone rudo el asunto...

Para ver si tus TIP41 o cualquier transistor funciona...

- Mide entre colector y emisor poniendo la punta roja en C y la negra en E, tiene que medir resistencia infinita o "abierto", luego mide rojo en E y negro en C y debe medir igual. Si por alguna situación el multímetro marca corto, tu TIP habrá muerto.
- Pon tu multímetro en medidor de diodo y mide entre B y E, debe decir 0.7V, si marca corto ó 0V, tu TIP habrá fallecido.


Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #12 en: 09 de Julio de 2007, 22:24:11 »
Hola navaismo y migsantiago, muchas gracias por toda vuestra ayuda.

Tengo puestas resistencias de 1k entre las salidas del pic y los Tip41c.

He medido entre colector y emisor y esta bien porque me marca como si estubiera abierto.
En medidor de diodo me mide 743. :shock:

Muchas gracias.
Saludos.

Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Puente H
« Respuesta #13 en: 09 de Julio de 2007, 22:58:40 »
Hola Trust

Agregale a los TIP41 (a los cuatro) un BC547/8, 2N2222, 2N3904, C1815, o cualquier otro NPN de uso general para transformarlo en un Darlington y probá de esa forma.

Saludos
Mario

Desconectado Trust

  • PIC16
  • ***
  • Mensajes: 141
Re: Puente H
« Respuesta #14 en: 09 de Julio de 2007, 23:12:15 »
Hola Marioguillote, muchas gracias por tu ayuda. La verdad es que ya he probado eso que dices y no he sabido hacerlo bien, muchas gracias por responder.

Ahora estoy viendo un tema que me interesa mucho que inicio veguepic y en el que participan Marioquillote, chaly29 y Lordlafebre. Montare uno de los esquemas que salen (el que funciona bien) :) sequire todos sus consejos, que he visto que lo aclaran todo como funciona y espero que yo sepa hacer que funcione.

Puente H con BD677 y BD678

Muchas gracias a todos por la ayuda.  :P
Saludos.


 

anything