Autor Tema: Publik 8x96 Problema con la intensidad  (Leído 4167 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Publik 8x96 Problema con la intensidad
« en: 06 de Agosto de 2010, 21:40:36 »
Que tal amigos, esta es la segunda vez que tengo problemas con lo mismo.

En fin, como dice el tema, me encuentro haciendo un publik, y el problema que tengo es a la hora de encender cada una de las filas.

Primero, lo que pasa es que no ilumina lo suficiente. Si ilumina algo, pero lo he visto iluminando más, ya que ocupaba otra configuración y esta iluminaba más.

Y uds se preguntarán, porqué no lo dejé así, pues porque me dí cuenta que se encendían LEds de más, osea, se encendian levemente leds que deberían de estar completamente apagados!!  :(

Lo primero que pensé que era, fue el programa.

Pero ahora lo que creo que es, es el hardware, osea los transistores que ocupo para encender cada una de las 8 filas.

He probado lentamente para ver que es lo que sucede, pero no veo nada raro.

1. Apago las filas
2. Cargo los datos de cada columna, de la primera fila.
3. Enciendo la primera fila.
4. Espero 2 milisegundos.

5. Apago las filas.
6.Cargo los datos de cada columna, de la segunda fila.
..............
Así sucesivamente

Y el circuito que ocupo para encender CADA UNA DE LAS FIAS, es como el que adjunto a continuación.


Espero sus comentarios, y sugerencias, para saber porqué se encienden levemente esos leds que no deberia de estar encendidos, y como puedo hacer para darles más luminicidad.



Saludos, y muchas gracias !!!

Desconectado BrunoF

  • Administrador
  • DsPIC30
  • *******
  • Mensajes: 3865
Re: Publik 8x96 Problema con la intensidad
« Respuesta #1 en: 06 de Agosto de 2010, 21:50:05 »
Hola!

El problema de los LEDs levemente encendido, es que a la salida del TIP32 tenés que poner una resistencia a GND(el valor de la resistencia puede oscilar, depende de un par de parámetros, pero podés empezar por 10k y de ahí hacia abajo) para que haya un voltaje de referencia presente cuando el transistor está en corte.

Por otro lado, tal vez requieras de excitar los LEDs con más voltaje que 5v, pero eso te va a obligar a cambiar ell hardware y minimamente poner ULN2803 o simil a las salidas de los 74LS373.

Saludos.
"All of the books in the world contain no more information than is broadcast as video in a single large American city in a single year. Not all bits have equal value."  -- Carl Sagan

Sólo responderé a mensajes personales, por asuntos personales. El resto de las consultas DEBEN ser escritas en el foro público. Gracias.

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #2 en: 06 de Agosto de 2010, 22:55:45 »
Ohhhh, entonces a la salida? mmm cómo es eso? en el Colector en paralelo a los leds?? o cómo, disculpa por no entender!!

Y lo de aumentar el voltaje, lo he probado, aumentado el voltaje en el emisor del TIP32, pero lo unico que logro es que entra más aumente, se encienden más los LEDs que deberian de estar apagados!!

Saludos

Desconectado BrunoF

  • Administrador
  • DsPIC30
  • *******
  • Mensajes: 3865
Re: Publik 8x96 Problema con la intensidad
« Respuesta #3 en: 06 de Agosto de 2010, 23:48:20 »
Ohhhh, entonces a la salida? mmm cómo es eso? en el Colector en paralelo a los leds?? o cómo, disculpa por no entender!!

A la salida de cada colector, conectas una resistencia entre la salida misma y GND. Sería una conexión en paralelo. Andá jugando con el valor de la resistencia hasta dar en el óptimo.

Y lo de aumentar el voltaje, lo he probado, aumentado el voltaje en el emisor del TIP32, pero lo unico que logro es que entra más aumente, se encienden más los LEDs que deberian de estar apagados!!

Como te dije, si aumentas el voltaje, la d.d.p. presente en el LED se hace SIEMPRE >0, independientemente del estado de la salida del registro controlador de la columna asociada. Lo que sucede es que como el voltaje de las filas excede al de la alimentación de los integrados de la columna, exíste siempre d.d.p. entre el ánodo y el cátodo del LED(comandando las filas con 12V, tendrías 12V-0V = 12V o bien 12V-5V = 7V en el circuito LED-Resistencia. Siempre hay d.d.p presente, el LED enciende...) Por lo tanto sólo empeora la cosa.

Si querés mas brillo aún, vas a tener que cambiar el hardware mínimamente como te mencioné, o usar otros integrados para las columnas(son raros, pero los hay open drain que te servirían).
"All of the books in the world contain no more information than is broadcast as video in a single large American city in a single year. Not all bits have equal value."  -- Carl Sagan

Sólo responderé a mensajes personales, por asuntos personales. El resto de las consultas DEBEN ser escritas en el foro público. Gracias.

Desconectado Suky

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 6759
Re: Publik 8x96 Problema con la intensidad
« Respuesta #4 en: 07 de Agosto de 2010, 00:10:28 »
Lo correcto sería:


Porque de la manera que muestras no veo como llevas de corte a saturación el TIP32  :?


Saludos!
No contesto mensajes privados, las consultas en el foro

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #5 en: 07 de Agosto de 2010, 00:26:55 »
Saludos BrunoF, gracias por la ayuda y por la explicación, todavía voy a digerir bien lo que comentaste.

Y gracias a suky también por su diagrama, que por cierto voy a probar!  :)


Saludos y sé que parece que no tengo ni idea de lo que estoy haciendo, pero mi problema es el hardware, porque la parte de programación la tengo un poco más controlada.  :)

Saludos amigos, sigo oyendo sus comentarios y regaños porque no? jeje

Desconectado BrunoF

  • Administrador
  • DsPIC30
  • *******
  • Mensajes: 3865
Re: Publik 8x96 Problema con la intensidad
« Respuesta #6 en: 07 de Agosto de 2010, 00:30:05 »
Lo correcto sería:


Porque de la manera que muestras no veo como llevas de corte a saturación el TIP32  :?


Saludos!

True, Suky, True! :D :D
"All of the books in the world contain no more information than is broadcast as video in a single large American city in a single year. Not all bits have equal value."  -- Carl Sagan

Sólo responderé a mensajes personales, por asuntos personales. El resto de las consultas DEBEN ser escritas en el foro público. Gracias.

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #7 en: 07 de Agosto de 2010, 00:34:53 »

Ahhh que mala onda, no tengo resistencias de 100k, tendré que esperarme hasta mañana!! demonios!! :5]

SAludos!!

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #8 en: 07 de Agosto de 2010, 00:39:35 »
Bueno, de mientras probaré con 10 resistencias de 10KOhms,  :D :D :D

Desconectado BrunoF

  • Administrador
  • DsPIC30
  • *******
  • Mensajes: 3865
Re: Publik 8x96 Problema con la intensidad
« Respuesta #9 en: 07 de Agosto de 2010, 00:41:23 »
Ok, pero acordate agregar lo que te dije al esquema de Suky
"All of the books in the world contain no more information than is broadcast as video in a single large American city in a single year. Not all bits have equal value."  -- Carl Sagan

Sólo responderé a mensajes personales, por asuntos personales. El resto de las consultas DEBEN ser escritas en el foro público. Gracias.

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #10 en: 07 de Agosto de 2010, 00:47:39 »
Bueno, déjam ver si entendí bien...
Sería algo así??

Claro,  variando los valores hasta que tenga el valor que requiero??


Desconectado Suky

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 6759
Re: Publik 8x96 Problema con la intensidad
« Respuesta #11 en: 07 de Agosto de 2010, 00:50:26 »
Bueno, déjam ver si entendí bien...
Sería algo así??

Claro,  variando los valores hasta que tenga el valor que requiero??



Según Bruno si, pero según yo  :mrgreen: la resistencia adicional no es necesario.  :D Hay que probar  :mrgreen:

Saludos!
No contesto mensajes privados, las consultas en el foro

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #12 en: 07 de Agosto de 2010, 00:57:47 »
mmmmm

Saben de qeu acabo de darme cuenta??
De que tiene un BC548, y así no sirve porque mi salida del mi multiplexor 74ls138, es colector abierto, por eso usé los bc557 :(

Saludos

Desconectado Suky

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 6759
Re: Publik 8x96 Problema con la intensidad
« Respuesta #13 en: 07 de Agosto de 2010, 01:20:38 »
mmmmm

Saben de qeu acabo de darme cuenta??
De que tiene un BC548, y así no sirve porque mi salida del mi multiplexor 74ls138, es colector abierto, por eso usé los bc557 :(

Saludos

Es cierto!!! Pequeño gran detalle!  :z)  :D

Entonces proba con:

Pero cambia la lógica, con 1 lógico se apaga el led

Saludos!
No contesto mensajes privados, las consultas en el foro

Desconectado b.stronger

  • PIC10
  • *
  • Mensajes: 45
Re: Publik 8x96 Problema con la intensidad
« Respuesta #14 en: 07 de Agosto de 2010, 01:24:45 »
Hey que tal Suky he probado el circuito en ISIS y si jala.  :)  , voy a probarlo físicamente y te cuento!!

Saludos