Autor Tema: Necesito ayuda con un L298  (Leído 3287 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17764
    • MicroPIC
Necesito ayuda con un L298
« en: 01 de Septiembre de 2005, 09:23:00 »
Me tiene loco ya un L298 con un fallo absurdo para el que no encuentro explicación por más vueltas que he dado.

Intento controlar un motor de continua a través de dicho integrado. La conexión del motor la hago tal y como está en este esquema:


Y lo que me ocurre es que si pongo un 1 en una entrada, me encuentro tensión en la correspondiente salida, pero si pongo un 0 la salida se queda flotando, y por tanto no mueve el motor. Es como si le faltase masa por algún sitio.

Incluso he pensado que podía estar averiado el L298 pero he comprado otro y me hace exactamente lo mismo.

He probado a usar un canal, el otro, los dos juntos, con motor, sin motor, con unos leds. En fin, que no sé por donde seguir y me gustaría saber si alguien se encontró ya con este problema y averiguó la solución.

Gracias
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado RaDoN

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 1498
RE: Necesito ayuda con un L298
« Respuesta #1 en: 01 de Septiembre de 2005, 09:34:00 »


Ignora la parte del sensado de corriente si no la vas a usar.
Si juegas contra el mejor, pierdes como los demás.

Desconectado Nocturno

  • Administrador
  • DsPIC33
  • *******
  • Mensajes: 17764
    • MicroPIC
RE: Necesito ayuda con un L298
« Respuesta #2 en: 01 de Septiembre de 2005, 14:14:00 »
FUNCIONAAAAAAAAAAAAAAAAAAAAA

Muchas gracias a todos los que me habéis ayudado, en particular a Antoniof que lo ha resuelto por MSN.

El problema estaba en que puse unas cacho resistencias para sensar corriente, y se chupaban toda la masa en vez de entregarla a los motores.

Ahora las he anulado y he puesto unos cablecitos y ya va.

Gracias de nuevo.
Un saludo desde Sevilla, España.
Visita MicroPIC                                                                                        ɔ!doɹɔ!ɯ ɐʇ!s!ʌ

Desconectado antoniof

  • Moderadores
  • PIC24F
  • *****
  • Mensajes: 729
RE: Necesito ayuda con un L298
« Respuesta #3 en: 01 de Septiembre de 2005, 14:24:00 »
Jeje. RebotadoRebotadoRebotado

Encantado de ayudar a un maestro como tu. Sonrisa GiganteSonrisa GiganteSonrisa GiganteSonrisa Gigante