Autor Tema: Reparacion e ideas.  (Leído 2456 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7805
Reparacion e ideas.
« en: 15 de Octubre de 2015, 08:41:43 »
Hace poco me trajeron un detector de alta y baja tension que personalmente no me gusta como esta diseñado (por unos cuantos inventos para ahorrar pines de un PIC), pero en fin me lo trajeron para arreglarlo. el principal tema es que cuando se activaba el rele que da salida cuando pasa cierto tiempo y el voltaje es estable, se desactivaba ahi nomas. Habia arreglado otros iguales que tenian el mismo problema. Y era que se les habia quemado el zener de su fuente ( lo descubri midiendolos ). Nada complicado, cambiar el zener y arranco nuevamente y aun hoy en dia estan en funcionamiento.

Hace poco me traen 2 mas de estos (1 ya hace rato), presentando el mismo sintoma, a la primera suposicion fue: El zener. para mi sorpresa los zener no estaban en corto, conducian para un lado y para el otro no. Busque y busque y no encontre solucion. Asi que solo me queda pedir sus ayudas o ideas.  El circuito es simple y bastante rebuscado. No se siquiera si es que estoy mirando hacia la direccion correcta. Esta es la parte de la fuente:

NO guiarse por este circuito, esta mal, abajo puse el link a la imagen con el circuito correcto y completo


No puse los valores de las resistencias solo por que no me parecieron relevantes, las resistencias estan sanas. Esa alimentacion de 24V alimenta al Rele el cual es comandado por un BC547 desde el PIC, este lo pone a GND. Tambien de esos 24V pasa por una resistencia de 480 ohms para llegar al 7805 que es el que alimenta al PIC.

Lo que veo que produce el sintoma que nombre al principio es la caida de tension. Cuando el PIC activa el rele la tension cae por demas. Sin activar el rele estamos hablando de que no llega a 5V, esta en 4.9V la salida del 7805, pero cuando activa la tension cae a tal punto de resetear el micro. La caida de tension en la resistencia de 480 ohms esta entre 9V y 6V cuando no esta activo ( segun si el PIC enciende o no un led - Tiene 3 y normalmente enciende 1 por ves )

Cosas que probe:

- Suponiendo que hubiera un defecto en los zener, tengan una tension inversa erronea, procedi a cambiarlos - Resultado NADA - sigue igual
- Pense que el filtrado podia ser malo y que los condensadores fueron decayendo en el tiempo, cambie los condensadores electroliticos (el de polyester no) - Resultado Igual
- Intente aislar los problemas, quite el transistor y la alimentacion al PIC ( levante una patita de la resistencia que alimenta al 7805), para ver cuanto caia la tension con el rele solo sin el PIC consumiendo (Tiene una "llave de paso"). La tension cayo muy poco, solo unos volts. Y el rele se sentia el sonido que pegaba con gusto y no cuando lo comandaba el PIC.
- Quedandome sin opciones supuse que el 7805 podria haber estado molestando lo cambie - Siguio igual
- Observe que habia una caida importante de tension en la resistencia, si achicaba la resistencia iba a tener menos caida de tension ahi y el 7805 podria tener la tension suficiente para el drop-out, lo achique a 390 ohms intento mejorar pero aun asi la tension sigue baja, tan baja que por ahi el ripple terminaba reseteando el micro.
- Los diodos 1n4007 estan buenos. Los cambie, sigue igual
Veo un poco de ripple en el osciloscopio. Creo que es normal, no es un ripple super importante como para que se note tanto. ( Con el rele solo no se notaba tanto el ripple )

Entonces con la fuente poco mas casi toda cambiada excepto las resistencias que miden lo que deben medir, no me quedo otra que mirar al PIC. Pero apenas conecto la alimentacion al PIC ( 7805 ) se cae todo. Por las dudas quite el consumo de los leds y ahi nuevamente mejoro algo, Pero sigo con el mismo problema.
Intente alimentar el PIC aparte, sin alimentacion de 220V (por las dudas) y no arranca, no enciende ni un LED. Tengo una fuente de PC que tengo mis serias dudas al intentar meter todo junto y que termine volando todo.

El tema es que antes estaba funcionando bien con esos valores, por lo cual no quiero modificar los valores de resistencia o lo que sea. Pero ahora no funciona. El PIC sigue funcionando, sigue haciendo su programa. Lo que maneja el PIC son leds y solo tiene conectadas resistencias, capacitores, diodos (1N4148) para el sensado de cruce por 0, y tension. Si hubiera quedado en corto el PIC, pienso que hubiera volado en pedazos por ser una fuente no aislada y estar trabajando con 220V que seria la entrada que primer desapareceria, Y la otra el PIC ya no funcionaria.

Pero tengo 2 aparatos con los mismos sintomas. Y nuevamente para mi todo apunta a la fuente ( el cual casi reemplaze por completo ), alguno tiene realmente una idea de que puede ser ? debo seguir mirando a la fuente a pesar que cambie todo y sigue sin funcionar? O alguno puede aportar una idea?
Si es necesario hago todo el circuito y lo subo.

PD: Hasta verguenza me da no poder reparar esto... es TAN simple, pero ya no se que hacer! se me quemaron todos los libros, a lo unico que le puedo hechar la culpa es al PIC
PD2: No desolde el PIC, intente no tocarlo para nada, pero si sigue asi y nadie da ideas pruebo desoldarlo y usar algun led, para ver si el consumo sigue igual o no e intentar ver cual es el problema en realidad.
PD3: Como dije el PIC sensa la Fase, asi que hay una especie de divisores resistivos + capacitores para asi disminuir la tension de 220V a casi nada el cual usa el PIC. Y un par de diodos para el tema del paso por 0. todo a traves de grandes resistencias.
« Última modificación: 16 de Octubre de 2015, 01:04:59 por KILLERJC »

Desconectado juaperser1

  • Colaborador
  • DsPIC30
  • *****
  • Mensajes: 2795
Re:Reparacion e ideas.
« Respuesta #1 en: 15 de Octubre de 2015, 09:07:34 »
yo habría hecho exactamente lo mismo que tu, la verdad es que el diseño es un poco raro, ¿que pinta hay esa resistencia de 480? pero bueno total, ¿has pensado que pueda ser el transformador, que esta mal y cuanto le pides un poco mas de consumo o se calienta un poco deja de funcionar? supongo que sera un transformador pequeñito de unos 100 o 200 mA no?

yo te habría sugerido lo primero cambiar el 7805 por que pasaba mucho y muy parecido a tu problema en mi anterior empresa, pero si ya lo has cambiado.

este aparato trabaja en ambietes sucios? es decir puede haber un corto entre pistas por suciedad humedad?

hagas lo que hagas no enchufes un programador al pic o si que volara todo por los aires hasta el ordenador, al no ser la fuente aislada.

si se me ocurre algo te lo comentaré pero es raro de narices. ¿podría ser el transistor del rele? que este mal y consuma en exceso aunque no lo suficiente como para quemarse por que se apaga todo?

PD: asi me gusta, usando KiCad  :D :D, si no voy a argentina y te mato, y después voy a por leonardo  :D :D

PD2: lo del transformador es una chorrada acabas de decir que es una fuente no aislada perdona
« Última modificación: 15 de Octubre de 2015, 09:15:24 por juaperser1 »
Visita mi canal para aprender sobre electrónica y programación:

https://www.youtube.com/channel/UCxOYHcAMLCVEtZEvGgPQ6Vw

Desconectado Fer_TACA

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3564
Re:Reparacion e ideas.
« Respuesta #2 en: 15 de Octubre de 2015, 09:35:07 »
La resistencia de 480 creo que esta puesta para que caiga una cierta cantidad de tension en ella y de esa manera el 7805 no que de alimentado a 24V directamemte. Ya que si asi fuera podría tener que disipar una cantidad importante, (24-5)= 19 x la intensidad podria llegar a calentarse.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2178
Re:Reparacion e ideas.
« Respuesta #3 en: 15 de Octubre de 2015, 09:39:09 »
Yo no soy bueno con la análogica, y quizá por eso no entiendo el circuito:

Cuando viene el semiciclo positivo el diodo de arriba queda en directa y la corriente llega al zenner superior. Como está en inversa funciona como zenner y gracias a la R de entrada (valor?) se limita la corriente. El zenner de abajo queda en directa y deja pasar la corriente hacia el neutro. En los pines del Zenner de arriba tenes la Vz (24V evidentemente). En principio la resistencia de entrada es importante porque limita la corriente por el zenner, no?
Cuando viene el semiciclo negativo es que no entiendo. El neutro es el más positivo, por lo que el diodo vertical queda en directa y el otro diodo en inversa. La corriente no puede ir a ningun lado... aaaa, es de media onda la cosa? esa parte no la llego a entender...

Saludos!
-
Leonardo Garberoglio

Desconectado juaperser1

  • Colaborador
  • DsPIC30
  • *****
  • Mensajes: 2795
Re:Reparacion e ideas.
« Respuesta #4 en: 15 de Octubre de 2015, 09:39:20 »
Citar
La resistencia de 480 creo que esta puesta para que caiga una cierta cantidad de tension en ella y de esa manera el 7805 no que de alimentado a 24V directamemte. Ya que si asi fuera podría tener que disipar una cantidad importante, (24-5)= 19 x la intensidad podria llegar a calentarse.

pero el 7805 en TH creo que puede ofrecer hasta 1 amperio, dependiendo de la tension que caiga en el 7805 claro, pero imagina esa resistencia si por hay circula una intensidad excesiva. A mi no me gusta.

PD: con esa foto, da miedo discutir contigo FER_TACA porque parece que estas de mala hostia xd, asi que... yo opino igual que FER_TACA  :D :D
Visita mi canal para aprender sobre electrónica y programación:

https://www.youtube.com/channel/UCxOYHcAMLCVEtZEvGgPQ6Vw

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7805
Re:Reparacion e ideas.
« Respuesta #5 en: 15 de Octubre de 2015, 16:30:20 »
Citar
este aparato trabaja en ambietes sucios? es decir puede haber un corto entre pistas por suciedad humedad?

No, esta totalmente limpio. Estaba ubicado en un domicilio de un particular.

Citar
¿podría ser el transistor del rele? que este mal y consuma en exceso aunque no lo suficiente como para quemarse por que se apaga todo?

No entiendo como es que podria consumir mas de lo que el rele da xD..

Citar
pero el 7805 en TH creo que puede ofrecer hasta 1 amperio, dependiendo de la tension que caiga en el 7805 claro, pero imagina esa resistencia si por hay circula una intensidad excesiva. A mi no me gusta.
El 7805 que yo abrevie mal es un 78L05 en encapsulado TO-220

Citar
La resistencia de 480 creo que esta puesta para que caiga una cierta cantidad de tension en ella y de esa manera el 7805 no que de alimentado a 24V directamemte.
Es la idea, por eso pense que era causa del problema, al consumir mas corriente el PIC.. Pero por que deberia consumir mas corriente que antes ?

Come dije al comienzo:
Citar
Hace poco me trajeron un detector de alta y baja tension que personalmente no me gusta como esta diseñado

Citar
En principio la resistencia de entrada es importante porque limita la corriente por el zenner, no?
Si es una resistencia baja, la primera es de 100hms y 1W, la resistencia del capacitor de poliester es mucho mas grande, es de 1M pero de 1/4W, la idea es generar una caida de tension en esos componentes.

Citar
Cuando viene el semiciclo negativo es que no entiendo. El neutro es el más positivo, por lo que el diodo vertical queda en directa y el otro diodo en inversa. La corriente no puede ir a ningun lado... aaaa, es de media onda la cosa? esa parte no la llego a entender...

Creo que meti la pata en el esquematico xD con respecto a eso, cuando tenga un tiempo lo acomodo y paso el circuito completo xD
(Loz zener estan antes que los diodos ) Asi recortan la onda y luego se rectifica como si fuera un trafo con punto medio, eran las 8am cuando lo hice estaba dormido xD

« Última modificación: 15 de Octubre de 2015, 16:38:52 por KILLERJC »

Desconectado juaperser1

  • Colaborador
  • DsPIC30
  • *****
  • Mensajes: 2795
Re:Reparacion e ideas.
« Respuesta #6 en: 15 de Octubre de 2015, 18:28:48 »
Citar
No entiendo como es que podria consumir mas de lo que el rele da xD..

Porque el transistor este malo y este en corto, o que haya un pequeño corto entre emisor y colector.

Es por descartar cosas porque lo que comentas es muy raro, solo queda eso y el pic no?


Visita mi canal para aprender sobre electrónica y programación:

https://www.youtube.com/channel/UCxOYHcAMLCVEtZEvGgPQ6Vw

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7805
Re:Reparacion e ideas.
« Respuesta #7 en: 16 de Octubre de 2015, 00:40:38 »
Bueno encontre mi carpeta con el circuito ya relevado. No pongo la imagen por que es de 1000 y algo de pixeles. Sino que dejo el link

https://drive.google.com/open?id=0B1v4IhprZLsqMTFGV3RNelVPU28

Por si se preguntan como es que sensa la tension, es "raro", la verdad que no recuerdo exactamente como era, pero me acuerdo como que tenia al final de los RC la alterna reducida bastante y no recuerdo si montada a un DC, Luego uno de los Pines del PIC funciona como entrada. Y la otra como salida, dandole un pulso cuando esta en el mayor tension de esa alterna reducida. Imagino que esto lo obtendra del detector de cruce por 0. El micro es un 12C508 ( oscilador interno, sin ADC, sin nada, solo timer y digital ) asi que supongo que medira el tiempo o de subida o bajada y con eso registrara la tension.

Luego hay una parte de señalizacion + sensado de una llave todo con un pin, esto es malisimo, hay una resistencia de 500ohms director de 5V a GND siempre, El funcionamiento de esa parte es simple, Como entrada va a tener una tension de 5V, si se activa la llave para cambiar el tiempo va a tener otra, supongamos que pasa de 1 a 0 gracias a eso y con eso detecta la llave. Como salida maneja los diodos leds, Poniendo la salida a 0V activa un diodo y a 5V activa el otro, se denota que para desactivarlo si o si hay que pasarlo a alta impedancia ( entrada )

Finalmente el transistor... y ese arreglo de diodo led paralelo resistencia, El cual queda encendido cuando activa el rele, Y cuando esta desactivado el rele, el PIC lo maneja a traves de esa resistencia de 180 ohms, con una onda pulsante, nada de encender el led poniendo a 1 la salida y dejarlo asi hasta que deba apagarlo, sino que es una onda cuadrada lo que le llega al led para encenderlo (un claro PWM a 50% de duty se podria simplficar.). Tambien se ve la llave de bypass del rele.

Ahora. Con eso en mente, deberia pegarle una patada y tirarlo a la basura :P.
No se si pensarlo como una GENIALIDAD o una BURRADA a este circuito. De funcionar funciona.
Especialmente a mi que me gusta ver lo que los demas hacen y como lo hacen.

PD juanjo: Las llaves son gigantes!!! y no hay un rele e.e, hay un rele DPDT pero no uno simple :P Asi que use un "filtro" para simular la bobina.
PD2: Como el circuito es comercial si alguno tiene problemas procedo a quitarlo, solo debe comunicarse conmigo y borrare toda informacion del mismo.
« Última modificación: 16 de Octubre de 2015, 01:03:56 por KILLERJC »

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Reparacion e ideas.
« Respuesta #8 en: 16 de Octubre de 2015, 01:07:38 »
Hola KILLERJC, iva a decirte que el esquema que habías posteado estaba definitivamente mal levantado, pero me ganaste y posteaste el esquema correcto.

En esa fuente no hay ninguna complicación. Aunque a ustedes les parezca lo contrario, es una de las muy clásicas fuentes sin trafo no aislada, pero esta es de onda completa, la conmunmente vista es de media onda.

Si sin consumo, digamos con el relay desactivado tienes los 24V y los 5V en los puntos que indicas en la fuente, pues podemos deducir las siguientes cosas:

1) 7805 en buen estado (es un 7805 y no un 78L05 que este solo vienen en encapsulado TO92) de lo contrario no estarían los 5V
2) Todos los diodos en buen estado.
3) La resistencia de 100 ohms 1W de entrada en buen estado.

La resistencia de 1M es solo para descargar el condensador de poliester y que la fuente no "vuele" por los aires si hay una desconexión/conexción rápida. Por lo tanto, si este funcionaría igual.

Y lo que nos estaría quedando en el tintero es el condensador de poliester. Estos con el tiempo saben fallar perdiendo no solo capacidad, si no también otras propiedades importantes (aumento de ESR).

Según e leido, este capacitor no lo as cambiado, por lo tanto te aliento a que lo cambies, ya que de seguro es el causante del problema de caída de tensión. Este problema pasa muy seguido en plaquetas de heladeras y lavarropas que usan este tipo de fuente, y la mayoría de las misma con solo cambiarles el condensador por uno adecuado el problema es resuelto.

Un saludo.

Atte. CARLOS.


 
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado vixctor

  • PIC16
  • ***
  • Mensajes: 105
Re:Reparacion e ideas.
« Respuesta #9 en: 16 de Octubre de 2015, 01:20:40 »
El problema me parece sencillo de resolver pero complejo de explicar...

Intenta poner en paralelo al capacitor de 1 uF otro capacitor del mismo valor, para generar 2 uF. y prueba todo de nuevo....

El problema es que la fuente NO está entregando la corriente necesaria para activar el relevador.

Eso se debe a que para reducir la tensión de 220V a 24 V usan un divisor "resistivo", pero ahí viene el tema....

Si se usaran resistencias tal cual, la caída de tensión sería tan grande que la potencia que deberían de disipar dichas resistencias sería muy alta...

Para evitar ese inconveniente, en lugar de una resistencia se usa un capacitor (1 uF) y se hace uso del principio de impedancia capacitiva.

La impedancia capacitiva se calcula usando la frecuencia de la RED (50 Hz o 60 Hz) tal que el capacitor se comporte como una impedancia.

La enorme ventaja de esto, es que en la impedancia la parte REAL genera la resistencia requerida mientras la parte compleja (imaginaria) o sea la disipación de potencia, no existe.... Eso es lo que evita la generación de calor...

Como la impedancia depende de la capacitancia, a mi gusto el valor de 1 uF es demasiado bajo, tal que no genera la corriente necesaria para encender el relevador y por lo tanto su voltaje cae...

Te menciono todo esto porque me toco diseñar muchas fuentes de ese tipo para controlar pics que controlaban electrodomesticos...

Como ejemplo, en donde tu tienes 1 uF, yo tenia un capacitor de 470 nf, y eso solo alcanzaba para alimentar el PIC y encender un TRIAC, OLVIDATE de encender 1 solo led...

Para encender varios LEDS, y circuitos, llegamos a emplear valores de hasta 4.7 uF y ya con eso todo funcionaba bien.

Pero, los capacitores de poliester son "caros", así que por eso se pretende usar el mínimo valor que funcione adecuadamente, esa es la razón que creo que está pasando, o redujeron el valor de capacitor en ese lote, o las caracteristicas del relevador consumen más corriente.

En cualquier caso, prueba poner dos capacitores de 1 uF en paralelo y lo más probable es que soluciones el problema...

Saludos...


Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7805
Re:Reparacion e ideas.
« Respuesta #10 en: 16 de Octubre de 2015, 01:32:39 »
Gracias Chaly, si es una de las fuentes mas comunes, y lo eh visto en los lavarropas tambien, incluso vi que calientan hermoso las resistencias esas de 5W/10W que les ponen :P y que por el consumo no vale la pena uno con trafo. Lo que si me llamo la atencion del circuito fue:

- Tomar 220V asi como si nada y referenciarlo a GND de la fuente, que no me ubico donde estaria con respecto a la fase y al neutro (como para tener una diferencia de potencial y medir la tension ), esta bien que pasa por grandes resistencias, pero me parecio "peligroso" como para jugar.
- Su forma de medir la tension , sin ADC, genialidad, no se lo preciso que sea eso si.
- Lo que no me gusto es eso de manejar todo con un pin, en especial por esa resistencia de 500ohm que queda de 5V a GND consumiendo para nada. Pero como dije funciona :P

Citar
1) 7805 en buen estado (es un 7805 y no un 78L05 que este solo vienen en encapsulado TO92) de lo contrario no estarían los 5V
es un 78L05, de encapsulado TO-92, el de 0.1A. Yo escribi 7805 y TO-220 y causo confusion. Fue OTRO error mio. Cada ves que escribo parece que escribo solo errores.

Yo no le encontraba respuesta, es lo unico que me falta de cambiar... el sabado debo viajar (40km para un capacitor no lo vale  :D) y comprare unos capacitores de estos para probar.
Y jamas pense que uno de poliester me hiciera eso (por eso lo deje y no lo cambie), siempre dude de los electroliticos esos si y es uno de los que mas se nombran sobre el "envejecimiento", pero de poliester no estaba dentro de mis conocimientos. Asi que bueno, cambiare eso y dare los resultados por aca.

Citar
En cualquier caso, prueba poner dos capacitores de 1 uF en paralelo y lo más probable es que soluciones el problema...

Gracias vixctor, yo solo me toco hacer tal ves 1 fuente de estas, incluso tengo los AN de algunos fabricantes con todos los calculos, se el principio basico del funcionamiento de las mismas, pero vos tenes mucha mas experiencia que yo asi que podes darte cuenta a simple vista el tema de los valores, no poseo capacitores de estos pero poseo 2 placas, asi que podria quitarselo a uno y ponerlos en paralelo y probarlo.
« Última modificación: 16 de Octubre de 2015, 23:07:13 por KILLERJC »

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7805
Re:Reparacion e ideas.
« Respuesta #11 en: 16 de Octubre de 2015, 01:45:46 »
Acabo de probar como dije, con el capacitor en paralelo de la segunda placa (que igual no funcionaba por el mismo problema) y funciona a la perfeccion. Asi que debo darle la razon a ambos , a vixctor y a Chaly. Gracias a ambos, como que caia en muy obvio que era el capacitor, pero mi mente suponia que el capacitor NO podia ser.

Ahora la cuestion es:

Si compro un capacitor, elijo del mismo valor que antes ( 1uF ) o procedo a comprar uno de 2.2uF (cercano a lo que probe), o me limito a comprar el valor inmmediato mayor a 1uF (1.5uF)?.
Yo no voy a pagar el arreglo y si me cuesta unos cuantos pesos mas prefiero gastarlo (y suponiendo que entre en el PCB) , cobrarselos al cliente y que le funcione perfecto el resto de su vida. Creo que a nadie le gustaria volver cada 6 meses por el mismo problema :P
« Última modificación: 16 de Octubre de 2015, 01:51:25 por KILLERJC »

Desconectado vixctor

  • PIC16
  • ***
  • Mensajes: 105
Re:Reparacion e ideas.
« Respuesta #12 en: 16 de Octubre de 2015, 02:03:12 »
Que bien que lo solucionaste, iba a apostar a que ese era el problema pero por leyes de murphy no lo hice...

Ok, vamos por partes:

Chaly tiene razón en lo del envejecimiento y el aumento de ESR con el tiempo.

Un capacitor de poliester es menos susceptible a ese tipo de problemas que un electrolítico, pero al estar sometidos a ALTERNA, lo que sucede es que los remaches de los pines respecto a las placas se van estropeando por el cambio constante de polaridad, de hecho, a simple oido se detecta el problema porque con el tiempo empiezan a zumbar... Lo que genera más ESR y menos corriente....

Ahora la cuestión está así:  La idea de esas fuentes es que sean MUY baratas, tal que el componente más caro en una fuente capacitiva es el capacitor...

Cuando trabaje para una empresa de electrodomésticos (3 años) diseñábamos las fuentes para un funcionamiento OPTIMO, pero de ahí por costes nos hacían bajar el valor del capacitor hasta el mínimo que aguantase el circuito sin fallar...

Eso me suena muy familiar en las placas que tienes por la parte del ahorrarse pines en el PIC...

A simple vista te diría que es un mal diseño, pero en una segunda opinión diría que por costes usaron el(los) valor(es) mínimo(s) que pudieron poner...

Yo te diría que usaras un capacitor de 2.2 uF, le dará larga vida al circuito y tu reputación con el cliente quedará de 5 estrellas...

Acá en México el valor optimo para varios leds y un rele era un capacitor de 4.7 uF,. pero la tensión es de 120 AC, así que un capacitor de 2.2 uF te dará un desempeño equivalente a 220 AC...

Por ultimo, he mencionado que el diseño optimo nos arrojaba 4.7 uF y terminamos poniéndole 470 nF, o sea un valor 10 veces menor que el recomendado, para que te des una idea de como se las gastan al momento de fabricar las cosas a bajo coste...

Dirían por acá: "Con que cumpla la NOM (Norma Oficial Mexicana) ya quedó, si al cliente se le funde al día siguiente de la garantía es su problema..."

Saludos...

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7805
Re:Reparacion e ideas.
« Respuesta #13 en: 16 de Octubre de 2015, 02:16:06 »
Nuevamente gracias por la explicacion y por la anecdota del trabajo.

Ahora con todo esto resuelto puedo ver el por que de algunas decisiones que tomaron:

- PIC el mas pequeño ( aunque hacer esto implica tener casi 10mA desechados por el invento ese de tener todo en 1 pin, y estoy mas que seguro que hay uno mas barato y que tiene mas cosas )
- El que usen una onda cuadrada ( PWM a 50% de duty ) para encender el led, asi la tension no cae formandose una especie de "ripple" de carga y descarga debido a la falta de corriente para cargar los capacitores electroliticos

Y gracias a ambos de nuevo

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Reparacion e ideas.
« Respuesta #14 en: 16 de Octubre de 2015, 02:59:12 »
Hola KILLERJC, yo no coincido con lo expuesto por vixctor, por lo menos no en todo.

Lo de bajar costos, eso 100% de acuerdo con sus palabras.

Pero lo de aumentar el valor del condensador, pues no estoy de acuerdo, con esos valores ya la fuente está capacitada para entregar una corriente de 70mA, los cuales la mayoría se los "come" el PIC y su led. Unos 10mA el relay cuando está encendido y la "dichosa" resistencia que tu supones esta de gusto.... y no es así.

En el mayor momento de consumo, pues el circuito se debe de estar consumiendo casi todos los 70mA, pero el problema es al momento del menor consumo posible y aquí viene el problema, todos los mA que no se consuma el circuito se lo deben de consumir los diodos zener.

y si colocas un capacitor más grande, pues los zener deberán de soportar mas potencia todavía

El colega vixctor de seguro diseñaba fuentes de media onda y esta es de onda completa y por ser de onda completa ya entrega el doble de potencia que la de media. En definitiva, si colocas un capacitor de 1uF tal como el que tienes, es como si fuera uno de 2uF de las fuentes "normales" de media onda. Si colocas uno de 2.2uF serían unos 4.4uF en una de media.

Colocando un capacitor de 2.2uF la fuente sería capaz de entregar hasta 150mA, lo que significaría que si antes funcionaba todo con un máximo de 70mA no quedaría que 150-70=80mA o sea que los zener deben de absorber 40mA cada uno para compensar el incremento de capacidad. Y si vas al datasheet del zener podrás ver que con 40mA estaría frito, junto con tu 75L05 (que es de solo 0.1A) y tu PIC por haberles pasado una tensión muy alta (de seguro más de 50V).

Para finalizar, consejo de un técnico viejo: Si tenía de 1uF y funcionaba, ponle lo mismo por algo será... Y si el equipo se rompe seguido, pues que el cliente compre de mejor calidad. La culpa no es tuya.

Si quieres ponerle algo mejor, compra los de poliester de 1uF 275VCA MKP X2

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.