Autor Tema: Sensores de automoción.  (Leído 5884 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #45 en: 24 de Agosto de 2016, 10:07:01 »
Si tu posees un buen circuito adaptador de señal de entrada, el pico proveniente de la entrada no debería de llegar al micro. Por lo que las interferencias están llegando por otro lado para lograr resetear el micro, y ese otro lado es la batería o la alimentación del mismo micro.
Es por esto que te recomiendo un muy buen filtrado para el micro, y por más que uses una batería, este filtrado debe de estar lo más cercano posible al mismo micro.
Atte. CARLOS.

Entonces debe ser que el circuito, posiblemente por las modificaciones que hice, no es correcto: ya que el micro sólo se resetea cuando el cable de la bujía manda pulsos...

Saludos!
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Sensores de automoción.
« Respuesta #46 en: 24 de Agosto de 2016, 12:17:59 »
Hola manwenwe

Citar
Entonces debe ser que el circuito, posiblemente por las modificaciones que hice, no es correcto: ya que el micro sólo se resetea cuando el cable de la bujía manda pulsos...

No necesariamente el circuito debe de esta mal, ya que ambos fenómenos se presentan con el mismo evento. El circuito puede ser el correcto y el filtrado de la alimentación puede esta muy mal hecho.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #47 en: 24 de Agosto de 2016, 16:37:59 »
Bueno: voy a disfrutar de mis 2 semanitas de vacaciones que este año son algo más tarde de lo que me hubiese gustado y a la vuelta le doy caña y comento.

Gracias Carlos.
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #48 en: 20 de Octubre de 2016, 03:23:47 »
Al final la alimentación está bien. Era un tema de oscilador: los PIC32MZ tienen una silicon errata por la que si usas un cristal de cuarzo tienes que poner una pull-up en uno de los pines del oscilador.

El tema de del reset por la señal de la bujía todavía lo tengo pendiente.

Saludos.
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #49 en: 25 de Noviembre de 2016, 09:36:48 »
No le saco punta a lo del sensor inductivo en el cable de la bujía, he probado varios circuitos y nada. Con el último me cuenta bien y no se me resetea casi la placa pero va mejor o peor dependiendo de la moto con la que lo pruebe. Todos los esquemas que encuentro en internet son de gente que se los fabrica como hobby (arduino sobre todo). Probé esta técnica porque mi cliente me comentaba que los tacómetros de los chinos funcionan todos así. Investigando un poco más he visto que los tacómetros que vienen integrados en los vehículos utilizan otras soluciones que parecen más profesionales. He visto varios circuitos basados en LM2907 (frecuencia a voltaje) y utilizando dos tipos de sensores: pickup inductivo y la señal del trigger del CDI (si no he entendido mal). La verdad es que el LM2907 no lo necesito ya que puedo contar los pulsos con el micro (no hace falta señal analógica proporcional), pero sí me gustaría coger la señal del trigger del CDI ya que como los sistemas los van a instalar al tiempo que las motos no habría problema con atornillar un par de cables (lo de los sensores de los chinos es muy cómodo para instalar por el usuario final pero en este caso no hace falta realmente ). Creo que si paso la señal de entrada del CDI por una optoacoplador con salida smith trigger debería sacar una señal bastante limpia y aislada de la alimentación del vehículo (mi sistema lleva batería propia). ¿qué opinais?. Otra duda que tengo es cual suele ser el voltaje de entrada al CDI (he leido por ahí +-5V pero no estoy seguro).

Gracias.
Saludos!
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #50 en: 29 de Noviembre de 2016, 11:11:28 »
Bueno, al fin solucionado. Usando un H11L1 (optoacoplador con salida trigger-smith), con la entrada al "pickup" del estator y la salida con pull-up a 3.3V va "fetén". Bueno entre el pickup y el diodo del opto, en serie, una resistencia limitadora (2K2) y un 1n4007 para eliminar los pulsos negativos. Sale una señal super limpita con pulsos casi perfectos. El único "pero" que le veo es que en los pulsos negativos del pickup no puedo evitar que caiga algo del voltaje (4V) en el diodo del opto, aunque supongo que no degradará el IC ya que el 1n4007 sólo debe dejar pasar la corriente de fuga en inversa.

En principio debería funcionar igual con un cable arrollado al cable, valga la redundancia, que va del CDI a la bobina de alta... pero se me ha olvidado probarlo.

Espero que a alguien más le sea útil.

Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Sensores de automoción.
« Respuesta #51 en: 29 de Noviembre de 2016, 12:13:26 »
Hola manwenwe, lo que estás midiendo es alta frecuencia, reemplaza el 1N4007 por un FR107 o SR107 (diodo rápido) y la cuestión debería de mejorar. Luego, en paralelo al led del opto deberías de colocar en inversa un 1N5819 (diodo schottky).

Por último te recomendaría que el GND del led lo conectes a masa (chasis) de alguna manera, porque la descarga producida por la bobina de alta puede "pincharte" el opto internamente.

No creo que dicho circuito funcione con la baja tensión (entre 200 Y 400 V) que sale del CDI hacia la bobina de alta. Pero es cuestión de probar.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #52 en: 29 de Noviembre de 2016, 13:18:36 »
Carlos,

tomo nota de lo del diodo rápido. Lo del diodo en inversa al del opto lo había pensado pero puse en serie el 1N4007 para "no joder" el pulso negativo del pickup que supongo (no tengo ni idea) también es utilizado dentro del CDI: no lo hice por si acaso. De todas formas poniendo los dos diodos comentas tu se soluciona todo: proteges el opto y no fastidias el pickup. Gracias!!!

El GND lo cojo efectivamente del chasis (bueno, del terminal GND del CDI que está a chasis). Lo que no te comprendo es lo la bobina de alta. La señal la cojo del pickup(sensor inductivo del estator) no de la salida del CDI que va a la bobina de alta. El pickup te da de +-6V a +-40V, la salida del CDI me da a 1200rpm +-250V como tú comentas (no lo he subido más). Tenía claro desde el principio que con la salida del CDI no funcionaría: me iba a chamuscar la resistencia limitadora :P

Saludos!
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Sensores de automoción.
« Respuesta #53 en: 29 de Noviembre de 2016, 15:49:09 »
Hola manwenwe, no, yo pensé que lo estabas tomando desde el cable de alta tensión que va a la bujía. Pero si lo tomas de pickup el tema es otro  :mrgreen:

Claro, debes de colocar ambos diodos y por supuesto la resistencia, con el diodo en serie recortas solo el pulso positivo, con el diodo en paralelo inverso proteges el led, y con la resistencia serie limitas la corriente.

A la salida del CDI dispones de una alta frecuencia (condensador del CDI en serie con primario de bobina de alta), medir después del CDI complica siempre mucho más el tema, aparte de que las tensiones son mucho más altas.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7334
Re:Sensores de automoción.
« Respuesta #54 en: 29 de Noviembre de 2016, 16:03:14 »
Hola manwenwe, no, yo pensé que lo estabas tomando desde el cable de alta tensión que va a la bujía. Pero si lo tomas de pickup el tema es otro  :mrgreen:

Claro, debes de colocar ambos diodos y por supuesto la resistencia, con el diodo en serie recortas solo el pulso positivo, con el diodo en paralelo inverso proteges el led, y con la resistencia serie limitas la corriente.

Supongo que es una señal alterna. Si es asi con un solo diodo en forma inversa y en paralelo al diodo del opto seria suficiente.
La unica desventaja es tener que sobredimensionar un poco mas la resistencia de entrada que posea. ya que ahora ambos ciclos pasarian por la misma y no solo el positivo.

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #55 en: 29 de Noviembre de 2016, 16:15:09 »
Por eso lo cogí del pickup: después de la experiencia con el arrollamiento de cable en la bujia no quería saber nada de tensiones altas jeje.

El único miedo que me daba es que cuando subes mucho las revoluciones también sube la tensión del pickup con lo que la corriente que entra al fotodiodo empieza a subir... me daba "canguele" que el pickup no fuese capaz de entregar tanta corriente y "fastidiase" el funcionamiento del CDI. He probado en 3 motos y parece que no pasa eso. Lo tenía previsto así que puse una etapa anterior disparando con un NPN para bajar el consumo... simulado en laboratorio muy bien pero cuando fuí a probarlo me comentaron que la entrada de alimentación de los CDI venía de un alternador y yo esperaba que fuese una dinamo y coger de allí los 12VDC ó 24VDC (o lo que fuese) para el colector del NPN. Así que al final no pude probar todo el circuito y como por ahora parece que el pickup no se resiente pues lo dejo como está ; si en el futuro se da ese problema creo que en vez de utilizar el NPN cambiaré el opto por uno de entrada AC y le pondré un smith trigger a la salida...

Gracias Carlos.
Saludos. 
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #56 en: 29 de Noviembre de 2016, 16:20:17 »
KILLERJC,

sorry: he escrito antes de leerte. ¿Si pongo un único diodo en inversa al del opto no fastido la señal del pickup?. En relación a lo que comentaba arriba...
Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7334
Re:Sensores de automoción.
« Respuesta #57 en: 29 de Noviembre de 2016, 18:02:33 »
Por lo que entendi y estaban hablando, sobre:

- 1 Diodo para recortar la onda positiva
- 1 Diodo para proteger cuando la señal queda inversa al led del opto

Y pense en algo asi de forma resumida:


* dsadas.png
(5.33 kB, 795x295 - visto 135 veces)


Lo que decia, es que no es necesario el diodo en serie.
Lo mas seguro que me meti sin saber si quiera del circuito. Y si asi fuera, ignoren este mensaje xD.

Desconectado manwenwe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2155
Re:Sensores de automoción.
« Respuesta #58 en: 29 de Noviembre de 2016, 18:13:27 »
Justo, ese es el circuito. Bueno, la salida del opto es smith trigger en vez de NPN pero sí ese es el circuito. Le pusé el diodo en serie porque no sabía que la Vr del diodo del opto era tan baja (6V) ya que nunca me había fijado en ese parámetro de los optos. Pero sí, tienes razón: no hace falta el diodo en serie ya que la resistencia limita la corriente en ambos sentidos y no debería modificar la señal del pickup. Mañana lo pruebo.

Gracias KILLERJC!!!

Ojo por ojo y todo el mundo acabará ciego - Mahatma Gandhi -

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Sensores de automoción.
« Respuesta #59 en: 29 de Noviembre de 2016, 23:41:41 »
Hola manwenwe, acá otro circuito que si deseas puedes probar, el una fuente de corriente, por lo que calculando de manera correcta la resistencia R2 (0.7 / Ix = Rx), la corriente de led del opto variará muy poco con respecto a las grandes variaciones de tensión.


* OPTO.png
(1.78 kB, 469x319 - visto 134 veces)


Este circuito es capaz de funcionar de manera correcta con tensiones de entrada de entre unos 5V aprox. y 100V o más, y ya posee todas las protecciones necesarias a aplicar para proteger la entrada.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.