Autor Tema: Problema con Latch OR  (Leído 1143 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jfmateos2

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3145
Problema con Latch OR
« en: 25 de Julio de 2006, 13:21:26 »
Hola, esta pregunta creo que debe ser sencilla para cualquiera con un poco de experiencia práctica en electrónica, pero a mí me está volviendo loco.

Estoy intentando simular el siguiente LATCH compuesto por una puerta OR en ISIS y no entiendo por qué, al arrancar la simulación en la posición que indica la figura, la salida 3 aparece con tensión alta. ¿Cómo se podría resolver esto? Creo que podría hacerse con una resistencia pull-down, o quizás con una combinación resistencia+condensador, pero no soy capaz de encontrar la solución. Les adjunto también el DSN por si pueden echarme una mano.



Gracias.


Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Problema con Latch OR
« Respuesta #1 en: 25 de Julio de 2006, 20:45:07 »
Hola jfmateos2:

Estuve viendo tu circuito.
Prueba de cambiar el 74LS32 por un CD4071 y verás que arranca en un estado bajo, como tu quieres, siendo que ambas son el mismo tipo de compuerta.
La diferencia radica en la "construcción interna" de los CI.
A pesar de esto, una vez disparado tu LATCH, te será imposible cambiarle la salida, (volverla a estado bajo), salvo que interrumpas la alimentación al circuito, (te hablo en la práctica) dado que siempre tendrás una entrada de la OR (la conectada a la salida), en estado alto y por más que a la otra la cambies con SW1 .......

Espero haberte sido útil.

Saludos

Mario
« Última modificación: 25 de Julio de 2006, 20:47:54 por Marioguillote »

Desconectado jfmateos2

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 3145
Re: Problema con Latch OR
« Respuesta #2 en: 26 de Julio de 2006, 02:14:11 »
Muchas gracias Mario. Probaré la solución que me dices.
Yo había conseguido resolverlo, pero metiendo un par de resistencias adicionales a modo de divisor de tensión. Aunque, la verdad, no entiendo por qué funciona mi solución, que es la siguiente (imagino que tiene algo que ver con lo que tú comentas de cómo están construidos internamente los CI):



Precisamente lo que me interesa es que una vez establecido el latch no pueda cambiarse. Este circuito forma parte de un velocímetro digital sobre el que tengo otro tema ya abierto(http://www.todopic.com.ar/foros/index.php?topic=12037.45) y en el que, gracias a todos los compañeros del foro, estoy logrando avanzar.
Muchas gracias de nuevo.