Autor Tema: Pic conectado a led conectado a un optoacoplador y una resistencia no funciona  (Leído 2160 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado MINDFIELD

  • PIC16
  • ***
  • Mensajes: 139
Buenas tengo una preguntita  :? tengo un pic conectado a un led(verde 5mm) que está conectado a un optoacoplador(moc 3021) y una resistencia(330r) (toda la coneccion en serie) el led prende bien con buena intencidad pero parece como si el opto no respondiera... en la salida de potencia tengo un relay de 220 vac, queria saber si la resistencia de 330 en la face de bajo voltaje es correcta o es muy grande? y lo pregunto porque al darle alimentacion el relay funciona y se apaga y ya no hace nada más, no responde, este pic controla varias cosas bien con 220vac y con la misma configuracion en baja potencia y en alta pero este en particular el del led verde solo hace lo que dije y nada más, tambien queria saber si puedo obviar la r?
« Última modificación: 17 de Noviembre de 2015, 22:22:19 por MINDFIELD »

Desconectado PalitroqueZ

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5440
    • Electrónica Didacta
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #1 en: 17 de Noviembre de 2015, 22:24:46 »
se entendería mejor con un diagrama de circuito eléctrico.
La propiedad privada es la mayor garantía de libertad.
Friedrich August von Hayek

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7854
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #2 en: 17 de Noviembre de 2015, 22:42:45 »
Eso seguro es por que no te da el voltaje.. trata de que el PIC alimente a :

Una rama con una resistencia y el led
Otra rama con una resistencia y el opto

es decir cada rama con su propia resistencia y esas 2 ramas en paralelo, de esa forma es posible darle 5 V a ambas.
Si lo pones en serie te tenes que dar cuenta que son casi 2V aprox o tal ves un poco mas de los diodos leds + otros 1.2V y algo ams del opto (10mA). tal ves llegando casi a los 5V, eso queda que en la resistencia caeria poca tension, por lo tanto poca corriente pasarian por los mismo.

Con la corriente necesaria para ambos diodos tal ves sea mejor un transistor que conmute el diodo y que no el PIN provea enteramente de la corriente para los 2 diodos leds. Podes conectarlo en serie. Pero creo que la resistencia sera muy pequeña.

Calculale 10mA de corriente por el led y fijate cuanto voltaje cae con esa corriente sobre el led verde de 5mm. Luego calcuclas:

5V - Vled - 1.2V / 10mA = R

Desconectado MINDFIELD

  • PIC16
  • ***
  • Mensajes: 139
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #3 en: 17 de Noviembre de 2015, 22:57:40 »
Bueno por si los mosquitos KILLERJC le voy a hacer caso a PalitroqueZ y ahi subo el circuito


* ledyopto.png
(185.68 kB, 797x298 - visto 872 veces)
« Última modificación: 18 de Noviembre de 2015, 08:15:00 por Chaly29 »

Desconectado MINDFIELD

  • PIC16
  • ***
  • Mensajes: 139
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #4 en: 18 de Noviembre de 2015, 00:01:25 »
puenteando la r no pasó nada, por otro lado en el programa para activar este relay tengo un if que dice if (input(Pin_C0) == 1) esvalido asi? o asi? if (input(Pin_C0) )

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7854
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #5 en: 18 de Noviembre de 2015, 01:04:15 »
puenteando la r no pasó nada, por otro lado en el programa para activar este relay tengo un if que dice if (input(Pin_C0) == 1) esvalido asi? o asi? if (input(Pin_C0) )

Puenteando la R es casi un corto circuito. Es lo mismo el programa.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #6 en: 18 de Noviembre de 2015, 08:23:27 »
Hola MINDFIELD, yo creo que tu problema es uno de interferencia y este problema es el que te "tilda" el PIC y luego ya no hace nada.

Tu dices relay de 220V, pero en realidad me gustaría que pongas una foto de dicho "relay", porque en realidad creo que tienes un contactor, y si es un contactor, pues te aconsejaría que en paralelo a este colocases una red RC (condensador de 10nF en serie con resistencia 100 ohms 1W) de filtrado, porque estos generan muchísima interferencia, esta red filtraría las mismas.

Por otro lado, sería aconsejable que al programa del PIC lo trabajes con el watchdog, así se reseteará ante un problema de interferencias.

También te recomendaría que la resistencia sea de 180 ohms, si sigues usando led verde y el led del opto en serie.

Un saludo, y espero tu respuestas.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado MINDFIELD

  • PIC16
  • ***
  • Mensajes: 139
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #7 en: 18 de Noviembre de 2015, 23:05:10 »
Hola Charly29 el tema es que prende el led y tambien lo apaga como si todo funcionara bien pero el "relay" que en realidad es una resistencia electrica de 800 watts, enciende al prender el led pero este led se apaga y la resistencia electrica sigue encendida, me aconsejas filtrarlo igualmente o no?

Citar
Por otro lado, sería aconsejable que al programa del PIC lo trabajes con el watchdog, así se reseteará ante un problema de interferencias.

esto no lo entiendo porque se supone que la face de potencia esta aislada del pic, como la interferencia generada en la face de potencia afecta al pic?

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #8 en: 18 de Noviembre de 2015, 23:20:31 »
Hola MINDFIELD, pues no te entiendo nada, es relay o es resistencia, no son lo mismo por lo tanto llamarlos de la misma manera no tiene sentido y confunde.

Si es una resistencia de 800W imposible de comandarla con un optoacoplador.

Pero te repito nuevamente, no termino de entenderte.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado MINDFIELD

  • PIC16
  • ***
  • Mensajes: 139
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #9 en: 18 de Noviembre de 2015, 23:26:44 »
Disculpas! es una resistencia electrica de 800w el circuito basico es el de la imagen más arriba y tomo al opto como referencia porque penseque el triac interno del opto era el problema... puede ser que alguna parte de la face de potencia se quede "enganchada" por no tener filtro?

Desconectado KILLERJC

  • Colaborador
  • DsPIC33
  • *****
  • Mensajes: 7854
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #10 en: 19 de Noviembre de 2015, 02:13:32 »
Pero lo comandas con un TRIAC. no con una RELE.

El opto TRIAC, maneja un TRIAC y este activa una resistencia. Eso es la imagen, yo todavia no encontraba un Rele por ningun lado.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4315
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #11 en: 19 de Noviembre de 2015, 11:50:37 »
Hola MINDFIELD, a ver si nos entendemos:

Disculpas! es una resistencia electrica de 800w el circuito basico es el de la imagen más arriba y tomo al opto como referencia porque penseque el triac interno del opto era el problema... puede ser que alguna parte de la face de potencia se quede "enganchada" por no tener filtro?

Que estás comandando/controlando una resistencia de 800W eso está claro.

Un circuito básico no sirve para el caso, porque no tenemos un circuito "real" que analizar, si tu colocas o no un componente y no está en el circuito básico, pues el análisis no sirve de nada.

Si deseas una respuesta clara o concisa, pues tómate el tiempo para realizar un circuito real y exactamente igual al que estás usando y recién ahí podremos aconsejarte. Creo que si buscas una respuesta es lo mínimo que debes de hacer. Nosotros no podemos ser adivinos de lo que tienes montado o deseas montar, y menos darte una respuesta sobre un circuito que hasta ahora no tenemos claro como montaste.

Un saludo.

Atte. CARLOS.



La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado MINDFIELD

  • PIC16
  • ***
  • Mensajes: 139
Re:Pic conectado a led conectado a un optoacoplador y una resistencia no funciona
« Respuesta #12 en: 19 de Noviembre de 2015, 20:33:12 »
Gracias a todos! desde acá en adelante voy a buscar info por mi cuenta no soy un experto pero creo que publicar todo el circuito no es tan necesario porque van a ver lo mismo que hice en el diagrama de proteus... la pregunta era facil pasa que me es dificil explicarlo, y más dificil se me hace cuando me piden tantas cosas, supondria esperar unos dias más para la respuesta.

En esta pagina en todopic creo esta la solución, saludos y espero que tengan un exelente dia!

http://www.todopic.com.ar/foros/index.php?topic=16065.15

Citar
Renatox_: Si quieres variar la potencia con cargas inductivas, la corriente de esta no cambia en el momento, esto significa que no crecerá tan pronto como se cierra el SCR ni se detendrá al final del semiciclo. El voltaje inductivo en la carga mantendrá encendido al SCR por un tiempo en la siguiente semionda, y no se apagará hasta que la corriente caiga por debajo de la corriente de mantenimiento.

 Para esto hay dos soluciones, primero es dar un pulso de mayor duración en la compuerta, esto asegura que el SCR se encienda y segundo adicionar un diodo de marcha libre en paralelo con la carga, que asegura que el SCR se apague al final de la semionda, la corriente inductiva de la carga se descargará por el diodo de marcha libre y no por el SCR.