Autor Tema: Problema extraño  (Leído 7352 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado aitopes

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5102
    • uControl
Problema extraño
« en: 22 de Septiembre de 2006, 18:45:38 »
Hola amigos!

Tengo un problema que me ha tenido a mal traer toda la semana, me animo a publicarlo por si alguien me tira una pista. :lol:

En un proyecto que involucra varias placas con un esquema como el que posteo abajo (esta simplificado, para no complicar el analisis) cada varios dias se me quema algun 7805.
Habia medido el consumo de las placas, y no superaba los 30mA, por lo que un 78L05 deberia ir bien, pero por las dudas use 7805, que deben funcionar bien hasta 500mA. No obstante....una vez instaladas, se queman seguido.

Hoy fui a medir "in situ", y descubri lo siguiente: el consumo de la placa, con el motor conectado (el motor es de 5A) en el arranque es de casi 800mA!!!!!!!!! en unos pocos segundos, el consumo va disminuyendo (a medida que el motor entra en regimen) y se estabiliza en 30-40mA con el motor a pleno (una 3500 rpm). Si pongo el motor a girar a unas 2500 rpm (de eso justamente se encarga el circuito en cuestion) el consumo es de unos 100 mA.

En mi modesto entender, el motor no deberia influir en el consumo de la placa...pero lo hace! :shock:
El mosfet tiene una corriente en el gate de menos de 10mA, el Hall consume 9mA, etc.
La corriente que consume la placa, que mencionaba mas arriba, esta media con el amperimetro colocado entre +12V y la entrada del 7805....

Me gustaria que alguien que la tenga clara (evidentemente no es mi caso) me ayude con esto, por que me parece que me supero. Debe ser una pavada, pero no logro verla. :shock:
El sistema completo tiene 10 motores, cada uno con una placa como la que muestra la imagen.


GRACIAS!!!!!
Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

Desconectado Arbolito

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 892
Re: Problema extraño
« Respuesta #1 en: 22 de Septiembre de 2006, 19:02:49 »
Hola aitopes

Por lo que entendi la fuente que dibujaste es solo para alimentar el hall y el pic ¿no? y la masa es la misma para todo. ¿no?

y una pregunta que no entiendo vos decis que el motor es de 5 amperes, y la pregunta es esta:

¿El motor en algun momento llega a los 5A? o yo te estoy interpretando mal
« Última modificación: 22 de Septiembre de 2006, 19:07:53 por juanacho_ar »
Existo, aunque pienses que no pienso

Desconectado aitopes

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5102
    • uControl
Re: Problema extraño
« Respuesta #2 en: 22 de Septiembre de 2006, 19:23:53 »
Hola Juanacho!

Efectivamente, el motor es de 12V, consume 5A de maxima, si lo frena la carga. Si gira sin carga consume unos 2.3A.
El negativo es comun a todo (obvio! :lol:) y el 7805 solo alimenta al PIC, a un CD4093 y al hall.

Lo extraño es que la corriente la entrega el mosfet, pero no deberia acusarlo el 7805...cuando el motor esta "cargado", la corriente en el gate del mosfet no llega a 10mA, y los 5A del motor pasan por el mosfet pero no por el 7805 (al menos que me este equivocando MAL....) :lol:


Saludos.
Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

Desconectado Arbolito

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 892
Re: Problema extraño
« Respuesta #3 en: 22 de Septiembre de 2006, 19:48:31 »
Bien vamos por partes

En el circuito logico no veo errores.

Pero la masa de a etapa de potencia tiene que estar separada de la del circuito logico (estas masas nunca deven juntarse)

Una de las posibilidad seria separarla con un optoacoplador.

Existo, aunque pienses que no pienso

Desconectado aitopes

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5102
    • uControl
Re: Problema extraño
« Respuesta #4 en: 22 de Septiembre de 2006, 19:53:21 »
No te entiendo :shock:

Separar las masas? Es la unica manera de que las placas de los motores interpreten los datos que mando desde el control, si no tengo una masa de referencia, estoy listo, no?

Dios mio...estoy cada vez mas confundido!! ja ja ja!

Debe ser la hora.  :mrgreen:
Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Problema extraño
« Respuesta #5 en: 22 de Septiembre de 2006, 19:54:20 »
Hola gente !

Ariel, no mencionás si los 7805 los colocaste sobre disipador o no.
Una de las "probables" es que le estás metiendo los 12V directamente a la entrada.
No te olvides que es un regulador serie, por lo que tiene que bajar 7Volts él solito. Esos 7 Volts a una corriente constante de 100mA, son casi 1W para un encapsulado que está preparado para disipar 2W sin disipador.
Y ni hablar si son los de encapsulado totalmente plástico. Más fáciles de quemar.
Si no tienen disipador, pónselo. Pequeño pero algo.
Otra cosa. De acuerdo al consumo máximo experimentá de colocarle una resistencia en serie con la entrada, de modo tal que le lleguen al 7805, entre 8 y 9 Volts, nada más. De esa forma disipará menos potencia el IC. (La calculás por Ley de Ohm)
Otra.
No dejes de colocarle a la entrada y a la salida de tensión, lo mismo que al circuito, capacitores cerámicos de .01 y .1 para desacoplo de los transitorios que puedan andar dando vueltas porla conmutación del TR. (Esa conmutación te puede estar generando un ruido que es el que te mata los 7805)(Fijate el hilo de Chaly29 acerca de la reducción de ruidos en líneas de alimentación)(Porqué escribo entre paréntesis?)

Respecto al consumo inicial de 800mA .... eso lo voy a pensar un poquito.
Mientras charlemos de esto que te dije, con vós y los demás amigos.

Saludos.

Mario

PD: No entiendo Juan, lo de las masas que daban ir separadas .... Por?

Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Problema extraño
« Respuesta #6 en: 22 de Septiembre de 2006, 19:55:47 »
Que lindo te anda el ISIS, Ariel !  :D  :D  :D  :D
« Última modificación: 22 de Septiembre de 2006, 19:58:17 por Marioguillote »

Desconectado Arbolito

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 892
Re: Problema extraño
« Respuesta #7 en: 22 de Septiembre de 2006, 20:07:40 »
Lo que te dice Mario es totalmente correctisimo (yo lo daba por echo  :mrgreen:)

A que me refiero, a ver si me puedo explicar.

a que no se debería poner al mismo punto de masa la salida del pic y y el motor (por eso digo un optoacoplador a la salida del pic)
Al menos yo siempre lo realice así y nunca tube problemas. ¿no se entiende no?

Denme un rato y veo si puedo armar un circuito (la voz nunca supera a la vista  :D)
Existo, aunque pienses que no pienso

Desconectado aitopes

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5102
    • uControl
Re: Problema extraño
« Respuesta #8 en: 22 de Septiembre de 2006, 20:10:58 »
Hol Mario!

Citar
Que lindo te anda el ISIS, Ariel !
Soy un desecho....pero es mas rapido! :)

Entiendo perfectamente lo que decis del 7805 (disipador, 7V, etc...), pero si el consumo de la placa es de 30mA, no hace falta...de hecho, ni se entivia. El tema es el porque de ese consumo extra! El motor NO PASA por ese circuito.. :?

Los capacitores esta puestos, es el diseño clasico, con .1 a la entrada y salida, y un electrolitico (al pedo, pero bue) a la salida.

Gracias por la ayuda, y por el frote del ISIS... :)
Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

Desconectado Arbolito

  • Colaborador
  • PIC24F
  • *****
  • Mensajes: 892
Re: Problema extraño
« Respuesta #9 en: 22 de Septiembre de 2006, 20:26:28 »
Me refiero a realizar este tipo de circuitos a mi siempre me an dado buen resultado

Suele yamarse aislamiento galvanico


Existo, aunque pienses que no pienso

Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Problema extraño
« Respuesta #10 en: 22 de Septiembre de 2006, 20:27:41 »
Una jodita lo del ISIS  :D , no lo tomes a mal .... a mí también me pasa ....

Sí, entiendo lo del motor que no pasa por ese IC.
Tal vez diga una guarangada, estoy pensando en voz alta ...... Será que hasta que hasta que alcanza las RPM correctas el motor, hace que el PIC trabaje generando un PWM acorde a lo que le está informando el Hall ....??????? y esa variación de ancho de pulsos signifique una variación de consumo en todo lo previo al MOSFET y por eso en ese momento inicial el consumo sea más alto y luego baje  ..... ????
Repito, estoy pensando en voz alta ....

Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Problema extraño
« Respuesta #11 en: 22 de Septiembre de 2006, 20:33:53 »
Me parece Juan que esa configuración es más útil cuando trabajás con AC.

Ariel está trabajando con un motor tipo limpiaparabrisas ...... no necesita, creo ese aislamiento.

Dos preguntas Ariel:

1 - La alimentación de las puertas que van del Hall al PIC, se alimentan con 5 o con 12 ?
2 - En el momento de los 800mA mediste si los 12V si se mantienen constantes?

Desconectado aitopes

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5102
    • uControl
Re: Problema extraño
« Respuesta #12 en: 22 de Septiembre de 2006, 20:38:02 »
Mario:

Exacto, el pic genera PWM para acelerarlo, pero en ese momento, el gate del mosfet (unico consumo alimentado por el 7805) es menor a 10,mA....

Voy a ver si agarro el ISIS despues de cenar y posteo el esquema completo, por ahi hay otra cosa que se me escapa.

Juanacho:

Yo tambien he usado lo que propones, pero en este caso, no puedo usarlo...el motor tiene recibe la corriente desde el mosfet. La unica podria ser optoacoplar el gate del mosfet del resto del circuito, pero por ahi no esta pasando la corriente que me preocupa, al menos la mido en otro lado, ahi no hay mas que picos de 10mA o menos.... :(

Lo parioooo! :)

[Me llama la bruja, dije "ya voy!!!" pero menciono un Gancia y un salame casero (y yo me acorde de unas aceitunas y queso que habia en la heladera), asi que .....desaparezco por un rato.]

Gracias!
Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

Desconectado aitopes

  • Moderadores
  • DsPIC33
  • *****
  • Mensajes: 5102
    • uControl
Re: Problema extraño
« Respuesta #13 en: 22 de Septiembre de 2006, 20:40:32 »

Citar
1 - La alimentación de las puertas que van del Hall al PIC, se alimentan con 5 o con 12 ?
5v

Citar
2 - En el momento de los 800mA mediste si los 12V si se mantienen constantes?
No, pero tengo una bateria de 70A (con el motor de la maquina en marcha y el alternador cargando), supongo (mañana lo voy a medir) que no debe hacerle ni la tos...estaba probando con un solo motor cuando media eso, y normalmente estan funcionando 10 juntos... :lol:

Si cualquier habilidad que aprende un niño será obsoleta antes de que la use, entonces, ¿qué es lo que tiene que aprender? La respuesta es obvia:
La única habilidad competitiva a largo plazo es la habilidad para aprender
“. Seymour Papert

Desconectado Marioguillote

  • Moderador Local
  • PIC24H
  • *****
  • Mensajes: 1926
    • Servisystem
Re: Problema extraño
« Respuesta #14 en: 22 de Septiembre de 2006, 20:53:36 »
Para los amigos de otras latitudes que no hayan entendido las letras en rojo de Ariel, significa que lo tentaron a un aperitivo sublime muy Argentino e irresistible a la vez. No hay 7805, ni PIC que se le resista a eso.

Respecto a los 5 Volts, por lo que se vé, no sólo son los 10mA del gate ..... está el Hall, las puertas, el PIC ..... algún que otro led .... todo suma.....

Esperamos el circuito completo. Disfrute del aperitivo amigo.
Después la seguimos.

PD: Te repito; lo del ISIS era broma ..... hacélo a mano nomás .....


 

anything