Autor Tema: Modificar fuente ATX para 1 a 16V y 0 a 20A.  (Leído 9136 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #15 en: 18 de Junio de 2016, 21:31:06 »
Hola micro_pepe, pero que apurado vienes, mis felicitaciones!!!

La medida A es de 8.7v y la medida B de 5.1v, lo siguiente que hice es medir la Vref del pin 14 del TL494, que anda cercano a 5v (no lo apunté, pero muy proximo a 5v) y la del divisor de referencia del pin 2, que da 1.01v; no he seguido, pues el voltaje A parece muy bajo.

El tener la medida de B en 5.1V nos está indicando que la fuente auxiliar funciona de manera correcta, los 8.7V son un poco bajos, pero a no asustarse.

La Vref del TL494 no tiene tanta exactitud como es de esperar, y en realidad lo más importante es que posea estabilidad, mientras esté próxima a los 5V nos vale.

Tensión de pin 2, perfecta, 0.01V es despreciable para esta aplicación.

Sigue con las mediciones, que de igual manera debería de darte los valores que te e indicado. Pero para asegurarte que la fuente funcionará de la manera correcta a pesar de los 8.7V, as las siguientes comprobaciones:

Con PS-ON conectado a masa, y un osciloscópio que posea aislación, mides la señal (con respecto a masa, pin7) ya sea del pin 8 o del pin 11 del TL494. Presta atención en el periodo de la señal y forma de la misma. Debería poseer un periodo apenas superior al 50% y una forma cuadrada. Esta señal esta invertida con respecto a la siguiente que mediremos.

Luego vas y mides cualquiera de los transistores de conmutación del trafo principal, colocas la masa del osciloscópio en el emisor y la punta en la base del mismo transistor. Cuidado con la tensión que en esta zona es de más de 300V.
Lo medido acá debería de tener el mismo periodo (o muy similar) a lo medido en el TL494 (invertido), y la señal, a pesar de no superar el nivel de 1V debe de poseer un formato casi cuadrado, igual que la salida del TL494. Esta señal no es invertida, por lo que el periodo será apenas inferior al 50%.

Si esto esta todo como lo indicado, significa que a pesar de solo tener 8.7V la fuente funcionará de manera correcta. Ya puedes montar el capacitor de 1uF y probar.

EDITO: quizas no sea tan bajo como parece, si el objetivo original de la fuente, es que una vez arranque se alimente de la salida de 12V, tiene que ser menor a ese valor, para que el diodo D04 quede en inversa, y entre a suministrar la corriente la salida de 12v.

No necesariamente. Dependiendo el diseño de la fuente, en algunas, la extracción de tensión del trafo  principal se hace por delante del diodo de rectificado principal, o sea directo desde el secundario, y como no posee inductor, luego de filtrar esta tensión sabe ser mayor a los 12V, las e visto incluso arriba de los 17V.
Pero otras fuentes, la tensión de 12V la extraen luego de rectificada y filtrada y por medio del citado diodo la introducen al TL494, y este debe de ser tu caso.

Pero no importa, haz las pruebas mencionadas y comenta los resultados.

Un saludo.

Atte. CARLOS.

Pda. en último caso, para no perder el trabajo, te indico como bobinar el secundario del trafo auxiliar para que este posea una salida de 12V. Y ahora me acuerdo, cuando conectes el PS-On a masa y la fuente auxiliar posea un mayor consumo, es probable que esta tensión se incremente al no estar regulada por la fuente.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #16 en: 18 de Junio de 2016, 21:53:24 »
Hola elgarbe

Uuuuuu!!!! que bueno!
Se parte de una fuente con el TL494 o hay que buscar alguna caracterìstica màs?
son de las fuentes viejas no?

No, solo es necesario que posea el TL494 o el KA7500 (reemplazo directo), es la única característica necesaria e indispensable.

El resto de los integrados usados en fuentes del tipo ATX o son muy integrados, por lo cual no nos permiten realizar muchas modificaciones y de lograr algunas no conseguimos las características logradas con el TL494, o son integrados con pocas opciones de regulación para sernos de utilidad.

Búscate una y acá te estaremos esperando.  :mrgreen:

ya te dije carlos que tenes que escribir un libro!!! te llenas de guita.

Sería interesante, sobre todo lo último, pero no sabría de que escribir jajaja

Por cierto, la "sacabollos" està funcionando de 10!

Me alegra que funcione, felicitaciones a vos y a tu viejo!!! La construyeron con los datos que yo te pasé o le aplicaste alguna modificación? Me interesa saber para futuras referencias...  :P

Y la idea que me pasaron?! Sacabollos magnético, para no tener necesidad de arruinar pintura.... Te la dejo picando  :-/

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado elgarbe

  • Moderadores
  • PIC24H
  • *****
  • Mensajes: 2173
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #17 en: 19 de Junio de 2016, 12:41:26 »
Carlos, ya estoy buscando fuentes!

El trafo, como me indicaste. O muy parecido a lo que me indicaste. Conseguimos 6.6V de alterna a la salida y con un pulso de menos de 1seg pegamos clavos comunes y arandelas...
El sec quedó con un solo cond de aluminio de 6.5mm creo. Sobró un poquito de espacio para alambre más grueso. Yo creo que se podría pijotear un poco más en el núcleo...

Lo único que vi magnético es el conector de masa... lo que te han dicho es desarrollar con un súper electroimán???? Eso sería genial, ya estoy buscando info!!!!
-
Leonardo Garberoglio

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #18 en: 19 de Junio de 2016, 23:37:59 »
Hola gente, debido a problemas del foro que hablaré con el programador, este mensaje escrito por micro_pepe no a salido de la manera correcta y ocasionaba problemas a todos los mensajes escritos después del mismo, por lo tanto e transcripto ambos mensajes indicando su autor, para que la información no se pierda:

Mensaje enviado por micro_pepe

Citar
Con PS-ON conectado a masa, y un osciloscópio que posea aislación, mides la señal (con respecto a masa, pin7) ya sea del pin 8 o del pin 11 del TL494. Presta atención en el periodo de la señal y forma de la misma. Debería poseer un periodo apenas superior al 50% y una forma cuadrada. Esta señal esta invertida con respecto a la siguiente que mediremos.

Resultado en el pin 8:

Imagen 1

Citar
Luego vas y mides cualquiera de los transistores de conmutación del trafo principal, colocas la masa del osciloscópio en el emisor y la punta en la base del mismo transistor. Cuidado con la tensión que en esta zona es de más de 300V.
Lo medido acá debería de tener el mismo periodo (o muy similar) a lo medido en el TL494 (invertido), y la señal, a pesar de no superar el nivel de 1V debe de poseer un formato casi cuadrado, igual que la salida del TL494. Esta señal no es invertida, por lo que el periodo será apenas inferior al 50%.

El resultado es el siguiente, soldé un par hilos al transistor para hacer la medida, así se mide con más seguridad:

Imagen 2

Le soldé el condensador de 1uF, conecté la fuente con una lampara de 40w en serie, y el voltaje de salida se ajusta bien (solo llega a 14v, pero es por culpa de la tolerancia del potencihometro, mide 8.8K), con el ajuste de corriente al minimo el voltaje cae a 0v, hasta aquí todo bien salvo por un zumbido agudo que se escucha continuamente.

Citar
No necesariamente. Dependiendo el diseño de la fuente, en algunas, la extracción de tensión del trafo  principal se hace por delante del diodo de rectificado principal, o sea directo desde el secundario, y como no posee inductor, luego de filtrar esta tensión sabe ser mayor a los 12V, las e visto incluso arriba de los 17V.
Pero otras fuentes, la tensión de 12V la extraen luego de rectificada y filtrada y por medio del citado diodo la introducen al TL494, y este debe de ser tu caso.

En mi caso parte directamente del condensador de filtro de la salida de 12V.

Elgarbe: Yo me he recorrido varias tiendas de informática, me junté con 6 fuentes, la ultima tenia el TL494, algunos son reacios a darte chatarra, en un caso me dijo que no tenia fuentes averiadas a pesar de ver asomando en la caja del punto limpio tres fuentes, y los que me dieron alguna fuente, intenté darles un par de euros para que se tomasen un café a mi salud, pero no quisieron. Del resto que no tienen el integrado deseado puedes recuperar un montón de cosas utiles.

Gracias, un saludo!!!
« Última modificación: 20 de Junio de 2016, 00:07:37 por Chaly29 »
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #19 en: 19 de Junio de 2016, 23:48:34 »
Mensaje enviado por elgarbe

El miércoles fui a buscar una ftes a una casa de informática y me dieron 2. Les saque los toroides. No tienen el 494.
En la Facultad donde trabajo siempre consiguen chatarra electrónica, voy a ver si consigo un par de ftes y me uno al montaje.

Saludos
« Última modificación: 19 de Junio de 2016, 23:52:19 por Chaly29 »
La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #20 en: 20 de Junio de 2016, 00:47:36 »
Hola micro_pepe

Citar
Le soldé el condensador de 1uF, conecté la fuente con una lampara de 40w en serie, y el voltaje de salida se ajusta bien (solo llega a 14v, pero es por culpa de la tolerancia del potencihometro, mide 8.8K), con el ajuste de corriente al minimo el voltaje cae a 0v, hasta aquí todo bien salvo por un zumbido agudo que se escucha continuamente.

Reemplaza la resistencia de 680 ohms por una de 593 (560 + 33) ohms y conseguirás los 16V

Es normal que con la corriente al mínimo la tensión caiga a cero.

El zumbido agudo que mencionas casi seguro que proviene del transformador principal, es porque el chino que los debía barnizar o no lo hizo o lo hizo muy mal, si deseas eliminarlo, sacar el transformador principal, y lo sumerges en barniz aislante hasta que dejen de salir burbujas, luego lo retiras y lo dejas escurrir hasta que deje de caer barniz y lo dejas secar 24 hs, lo instalas nuevamente y el zumbido debería de haber desaparecido.

Si el zumbido proviene de algún otro sector, trata de localizarlo y comenta cual es.

Citar
En mi caso parte directamente del condensador de filtro de la salida de 12V.

Era lo que sospechaba, no hay problema mientras la fuente funciona correctamente, pero por las últimas mediciones que realizaste, todo debería de funcionar perfectamente.

Un saludo y a disfrutarla.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #21 en: 20 de Junio de 2016, 00:50:49 »
Hola elgarbe,

Citar
El miércoles fui a buscar una ftes a una casa de informática y me dieron 2. Les saque los toroides. No tienen el 494.
En la Facultad donde trabajo siempre consiguen chatarra electrónica, voy a ver si consigo un par de ftes y me uno al montaje.

Nosotros lo tenemos más fácil, parece que para Argentina las que vinieron en su mayoría tenían el TL494, igual a no desistir.

Ojo que también vinieron muchas con el KA7500 que es el mismo integrado, pero si te confundes, pues pasará a desguace y casi seguro te hubiera sido de utilidad  :D

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado micro_pepe

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 2826
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #22 en: 20 de Junio de 2016, 09:12:51 »
Citar
El zumbido agudo que mencionas casi seguro que proviene del transformador principal, es porque el chino que los debía barnizar o no lo hizo o lo hizo muy mal, si deseas eliminarlo, sacar el transformador principal, y lo sumerges en barniz aislante hasta que dejen de salir burbujas, luego lo retiras y lo dejas escurrir hasta que deje de caer barniz y lo dejas secar 24 hs, lo instalas nuevamente y el zumbido debería de haber desaparecido.

Casi seguro que es del transformador principal, sin conectar el PS-ON a masa no se escucha, y con un voltaje de salida menor de 4v tampoco.

¿que tipo de barniz hay que usar? sirve del normal trasparente para puertas y ventanas de madera.

En cuanto al voltaje auxiliar, con 8.7v que dá, funciona bien, pero si fuese un poco más alto sería mejor, el ventilador dará más caudal de aire, se me ocurre subirlo un poco ajustando los 5Vsb a unos 6V modificando las resistencias del TL431, y apurando un poco más cambiando el diodo de esa salida auxiliar por un SCHOTTKY de 1A y 60V.

Y se me ocurren un par de florituras, usar un PIC y un LCD para medir el voltaje y corriente de la fuente, y aprovechando un pin del PIC, poner un retardo en el encendido para activar el PS-ON con un transistor a masa, así cuando corte la corriente a la fuente no consumirá nada, y el encendido de la salida se hace cuando el resto del circuito esté estabilizado.

La otra floritura sería poner un límite en potencia, así podría sacar algo más de 15A cuando el voltaje sea menor de 16V, limitaría a 240W, si por ejemplo tengo ajustado 14v y intento sacar 18A (14 * 18 = 252w) al sobrepasar el límite en potencia apagaría la salida cortando la corriente al transistor del PS-ON.

Saludos!!!
« Última modificación: 20 de Junio de 2016, 09:15:05 por micro_pepe »
Se obtiene más en dos meses interesandose por los demás, que en dos años tratando de que los demás se interesen por ti.

新年快乐     的好奇心的猫死亡

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #23 en: 20 de Junio de 2016, 11:54:19 »
Hola micro_pepe.

Citar
Casi seguro que es del transformador principal, sin conectar el PS-ON a masa no se escucha, y con un voltaje de salida menor de 4v tampoco.

Si, casi seguro, mi fuente en alguna tensión también lo hace, pero es mucho menos molesto porque es un rango mucho más chico que el tuyo.

Citar
¿que tipo de barniz hay que usar? sirve del normal trasparente para puertas y ventanas de madera.

Yo siempre lo hago con barniz dieléctrico (aislante) del usado en reparaciones de motores, el riesgo de usar barniz común, es que el solvente del mismo dañe el aislante de los alambres. Realmente no se que sucedería, lo que si se, es que usando barniz común deberías dejarlo secar mucho más tiempo, ya que es más lento.

Citar
En cuanto al voltaje auxiliar, con 8.7v que dá, funciona bien, pero si fuese un poco más alto sería mejor, el ventilador dará más caudal de aire, se me ocurre subirlo un poco ajustando los 5Vsb a unos 6V modificando las resistencias del TL431, y apurando un poco más cambiando el diodo de esa salida auxiliar por un SCHOTTKY de 1A y 60V.

El problema de esto, es que a los 5V los usa para varias funciones y no se que sucedería si al TL494 en ves de entrarle tensiones de 5V estas fueran mayores, creo que influiría bastante en su funcionamiento. Habría que estudiar muy bien este tema.

Igual, yo creo que es más sencillo agregarle unas espiras más al bobinado secundario de los 12V. Y sin dudas más seguro.

Citar
Y se me ocurren un par de florituras, usar un PIC y un LCD para medir el voltaje y corriente de la fuente, y aprovechando un pin del PIC, poner un retardo en el encendido para activar el PS-ON con un transistor a masa, así cuando corte la corriente a la fuente no consumirá nada, y el encendido de la salida se hace cuando el resto del circuito esté estabilizado.

Yo con un PIC, un LCD y un INA226 e construido un voltímetro, amperímetro y wattímetro todo en uno para estas fuentes, anda muy bien y es sencillo de implementar su uso y control.

Lo del retardo de encendido para estabilizar la fuente, no es muy necesario, porque el propio TL494 ya lo posee implementado. Lo hace por medio de un electrolítico conectado a los +Vref y pin4, en conjunto con un resistor desde pin4 a masa. Este circuito es el llamado DTC (deat time control) y si deseas un tiempo muerto un poco mayor, solo debe de reemplazar el valor de condensador y listo.

Citar
La otra floritura sería poner un límite en potencia, así podría sacar algo más de 15A cuando el voltaje sea menor de 16V, limitaría a 240W, si por ejemplo tengo ajustado 14v y intento sacar 18A (14 * 18 = 252w) al sobrepasar el límite en potencia apagaría la salida cortando la corriente al transistor del PS-ON.

Esto es bueno, ya que le sacarías un mayor provecho a toda la potencia de la fuente. Igualmente no se el uso que le darías vos, pero yo con mi fuente de 20A en muy contadas ocasiones e llegado a usar  el regulador al máximo o necesitar los 20A. Igualmente a mi me limitaría el diodo rectificador de salida.
Ten cuidado que el bobinado secundario también posee un límite y el alambre que poseen ya de por si no es el que deberían de tener.

Un saludo.

Atte, CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Miquel_S

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1223
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #24 en: 20 de Junio de 2016, 16:24:44 »
Gracias Chaly29 por el tutorial, voy a intentar modificar una que tengo pero no consigo dar con el modelo para intentar localizar su esquema, alguien conoce la marca de dicha fuente.

Subo imagen.


Saludos!
« Última modificación: 20 de Junio de 2016, 16:30:06 por Miquel_S »
Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.

Desconectado micro_pepe

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 2826
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #25 en: 20 de Junio de 2016, 16:47:26 »
Gracias Chaly29 por el tutorial, voy a intentar modificar una que tengo pero no consigo dar con el modelo para intentar localizar su esquema, alguien conoce la marca de dicha fuente.

Subo imagen.


Saludos!

Hola, no creo que encuentres el esquema exacto, pero si puedes encontrar algo parecido, yo para la mia puse en google "esquema ATX LM339" y busqué en imagenes, vas pinchando y viendo si tiene cosas en común con la tuya.

Lo de LM339 es porque la mia lleva ese operacional cuadruple, hay otras que tienen el LM393, busca dentro algún detalle y filtra por eso.

Suerte!!! Un saludo!!!
Se obtiene más en dos meses interesandose por los demás, que en dos años tratando de que los demás se interesen por ti.

新年快乐     的好奇心的猫死亡

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #26 en: 20 de Junio de 2016, 16:47:48 »
Hola Miquel_S, es muy difícil conseguir el esquema exacto de las ATX, ya que los chinos las reforman a cada rato.

Igual si sigues los pasos acá indicados, no creo que tengas problemas, y si tienes alguna duda, pues solo tienes que consultarla y trataremos de responderte. Aparte no es algo tan complicado, parece más de lo que realmente lo es.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado Chaly29

  • Moderador Global
  • DsPIC33
  • *****
  • Mensajes: 4253
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #27 en: 20 de Junio de 2016, 16:56:54 »
Hola a todos. Acá comparto una pequeña colección de circuitos AT y ATX que poseen el TL494 o el KA7500

https://drive.google.com/file/d/0BzMYllotj1ZEZjBrWjRhSU0xalk/view?usp=sharing

Se aceptan comentarios y circuitos para colaborar a ampliar la colección.

Un saludo.

Atte. CARLOS.

La teoría es cuando se sabe todo y nada funciona. La práctica es cuando todo funciona y nadie sabe por qué.

Desconectado micro_pepe

  • Moderadores
  • DsPIC30
  • *****
  • Mensajes: 2826
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #28 en: 20 de Junio de 2016, 17:01:46 »
Citar
Citar

    ¿que tipo de barniz hay que usar? sirve del normal trasparente para puertas y ventanas de madera.


Yo siempre lo hago con barniz dieléctrico (aislante) del usado en reparaciones de motores, el riesgo de usar barniz común, es que el solvente del mismo dañe el aislante de los alambres. Realmente no se que sucedería, lo que si se, es que usando barniz común deberías dejarlo secar mucho más tiempo, ya que es más lento.

OK. Trataré de encontrar ese tipo de barniz, hay un taller que bobinan motores, les preguntaré donde comprarlo, o si me pueden vender un bote.

Citar
Citar

    En cuanto al voltaje auxiliar, con 8.7v que dá, funciona bien, pero si fuese un poco más alto sería mejor, el ventilador dará más caudal de aire, se me ocurre subirlo un poco ajustando los 5Vsb a unos 6V modificando las resistencias del TL431, y apurando un poco más cambiando el diodo de esa salida auxiliar por un SCHOTTKY de 1A y 60V.


El problema de esto, es que a los 5V los usa para varias funciones y no se que sucedería si al TL494 en ves de entrarle tensiones de 5V estas fueran mayores, creo que influiría bastante en su funcionamiento. Habría que estudiar muy bien este tema.

Igual, yo creo que es más sencillo agregarle unas espiras más al bobinado secundario de los 12V. Y sin dudas más seguro.

He revisado mi fuente, y la salida de +5Vsb no alimenta nada dentro del circuito, solo hay un cable violeta que sale al exterior, y una pista que llega hasta el divisor de voltaje para la referencia del TL431. Es como en el esquema que postee al principio del hilo: http://320volt.com/wp-content/uploads/2011/05/m-atx-180w-400w-tl494-tl339-eel19-ei33-e17007-fr104-fr304.png

Citar
Se aceptan comentarios y circuitos para colaborar a ampliar la colección.

Gracias por los esquemas, yo tenía algunos en papel, pero no los encuentro.

Gracias, un saludo!!!
« Última modificación: 20 de Junio de 2016, 17:21:07 por micro_pepe »
Se obtiene más en dos meses interesandose por los demás, que en dos años tratando de que los demás se interesen por ti.

新年快乐     的好奇心的猫死亡

Desconectado Miquel_S

  • Colaborador
  • PIC24H
  • *****
  • Mensajes: 1223
Re:Modificar fuente ATX para 1 a 16V y 0 a 20A.
« Respuesta #29 en: 20 de Junio de 2016, 17:27:46 »
Gracias voy a ver que encuentro.
Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.